Purchasable Home In Skaal Village
43 Comments
< >
Raexer Jun 28 @ 9:41am 
Tried it. no options at all to purchase this from Skaal leader. If the ownership options are updated and cleaned up a bit I'll try this out again. It looks like a very nice idea for a mod.
loxoceles May 11 @ 2:35pm 
The ddialogue to purchase the house never comes up. I can get "improvement" dialogue and Basement dialogue but no way to get a key.
Katano Apr 11 @ 3:05pm 
could you make the home only buy able after the main quest in dragonborn it seems like there giving to you for no reason. btw sweet mod :)
Definitely Not Deks Mar 28 @ 2:08pm 
Btw everyone, if you can't get in the house, target the door and type "unlock"
Definitely Not Deks Mar 28 @ 2:03pm 
I just went through the basement to get in
Kironic Aug 10, 2013 @ 10:42am 
Should have added a childrens room so I can move my kids in there D:
Sir Toaster Aug 2, 2013 @ 12:27am 
she no giveing me the option frm her
tiaonthenet Jul 17, 2013 @ 7:21am 
its as if i already own it but i never got the key
tiaonthenet Jul 17, 2013 @ 7:21am 
It doesn't show up all that shows up is someone is missing, and something about being who she is. and then there is one about adding on to the house. But nothing about a key.
ArtificialSloth  [author] Jul 16, 2013 @ 3:14pm 
@tiaonthenet Can you see the dialogue to buy the key or does it not apear?
tiaonthenet Jul 16, 2013 @ 3:05pm 
I am unable to get the key from Fanari, yet I can upgrade the home.... I have tried to get in to the home but I don't have the key to do so. I am tried to left the game and gone back and nothing.
Sgt Slaughter May 9, 2013 @ 5:08pm 
@ArtificialSloth , its working now, thanks!
ArtificialSloth  [author] May 9, 2013 @ 11:17am 
@sgt Slaughter If she has other dialogue options try saving and reloading the game. If you can't talk to her at all you need to be farther into the dragonborn story.
Sgt Slaughter May 8, 2013 @ 8:56pm 
Fanari Strong-Voice has no dialog in aquiring the key. Please help.
ArtificialSloth  [author] May 8, 2013 @ 8:12am 
@Handee8 If your using a different character with my mod uninstalled then its not my mod causing it. For the Frea's dialogue try saving and reloading that usually fixes the problem, but the great hall I have no idea whats causing that to happen. You could try downloading the unnoficial dragonborn patch. If that doesn't work (wich I don't think it will) try unloading all your mods or at least the ones that require dragonborn all this with my mod deleted, then open skyrim start new character and see if you can enter the great hall. If you can then just slowly keep loading you mods until the problem comes back then you know whats causing it. Sorry I can't be more help but thats the best I can do.
handee8 May 8, 2013 @ 7:00am 
I subcribed to this bfore going to solstheim thinking it would come in handy. I have no other mods in solstheim. When I went to skall village the door to the great hall won't open to buy the house. The door label came up as the Raggin Flagon. I went on to do the Temple of Miraak quest onlt to discover that on completion I do not get The fate of the Skall initiation quest dialogue from Frea. I unsubcribed thinking maybe the mod screwed it up. I also deleted the file. I went back and tried again. The door to the Great Hall still wont open and after completeing the The Temple of Miraak quest again the next quest dialogue with Frea is still nonexistant. I realize this is the chance you take with mods but this prevents me from in any way completing the main quest line. I have restarted many times and even went with a different character with the same unfortunate results. Any suggestions?
ArtificialSloth  [author] Apr 28, 2013 @ 6:18pm 
@094Ghostman Try downloading the loose file version on the nexus if that doesnt work let me know.
Kaptein-morgan12 Apr 28, 2013 @ 11:27am 
I cant get the key
ArtificialSloth  [author] Apr 15, 2013 @ 7:55pm 
@jbyrnes behind the greathall in skaal village near the cliff.
jbyrnes Apr 15, 2013 @ 7:48pm 
where is this place
Hacker Apr 14, 2013 @ 1:05pm 
VERY great idea! I have the manor in Raven Rock from doing good deeds for the village and now i can live here too! Witch means i dont have to fast travel here to go to the black smith to get Stalhrim
IronSheep Apr 12, 2013 @ 1:00am 
hey coffin fuck off ur ruining awesome mods with ur spamming about the Elder Scrolls Online
just make ur own mod and make that the title BITCH
Rayne River Burton Apr 11, 2013 @ 1:03pm 
Thanks for this.
† Artheдain † Apr 11, 2013 @ 3:32am 
jcoffin@

dude, seriously do you have nothing else to do but spam every mod with your beta keys? -.-
Jo_Blow Apr 9, 2013 @ 12:18am 
Btw , to those who need the key , when you buy the house the leader gives you the key ....no worries in opening the door then :)
Jo_Blow Apr 9, 2013 @ 12:17am 
Its working ok ...with dragonborn, hearthfire,dawnguard for me ....was expecting more in the house ...shame you did not add childrens beds , would of like my kids and husband to travel and stay while , am on the Island too some day:)
Matt Damon Apr 8, 2013 @ 7:09pm 
Why would bethesda put beta keys on youtube? Lol
ArtificialSloth  [author] Apr 8, 2013 @ 7:40am 
Try uninstalling the mod and downloading the loose file version on the nexus it might fix it. If not open the console click on the door and type unlock.
NAX Apr 8, 2013 @ 12:05am 
what's the id code for the key
NAX Apr 7, 2013 @ 11:58pm 
can't purchase key
Videl Apr 7, 2013 @ 7:54pm 
i see kool and ty :)
ArtificialSloth  [author] Apr 7, 2013 @ 6:49pm 
@Hinata You can't move you're child in and I don't know of any house mods that let you do that. Theres this for you spouse though http://skyrim.nexusmods.com/mods/11370
Videl Apr 7, 2013 @ 5:50pm 
is it for the DLC HF and can my cild move in to it. b/c im look for a new home for me and my cild :p
ArtificialSloth  [author] Apr 7, 2013 @ 5:31pm 
@Partizan Theres a warmer version you can download on the Nexus: http://skyrim.nexusmods.com/mods/34385
The Red Glow Apr 7, 2013 @ 9:43am 
GREAT MOD !
Jokerer Apr 7, 2013 @ 6:07am 
@partizan: don´t take too personal, but i think the Skaal village is a quite cold area,so it´s not to bad that the house seems a bit "cold".
i think it´s nice, got my thumbs up!
Partizan Apr 7, 2013 @ 2:57am 
The home looks a bit empty and cold, so is this mod already finish?
SPAM223 Apr 6, 2013 @ 2:28pm 
I thought the Skaal didn't care for gold, and just wanted to serve the "All-Maker"
huckin Apr 6, 2013 @ 2:06pm 
Get your Free Elder Scrolls Online Beta Keys @ vimeo.com/62174328
† Artheдain † Apr 5, 2013 @ 9:23am 
thx ;)
ArtificialSloth  [author] Apr 5, 2013 @ 8:23am 
The last screen shot is a balcony you can get to if you buy the basement.
† Artheдain † Apr 5, 2013 @ 6:23am 
and could you perhaps add more screenshots of the outside of the house so I can know WHERE exactly the house lies in the village?
† Artheдain † Apr 5, 2013 @ 6:22am 
great mod!! subbed and favorite it right away, but what does that last screenshot show exactly?