Castle Draco Riverwood Edition 5.5
367 Comments
< >
Draco1122  [author] May 19 @ 10:22pm 
k glad to hear you got it
wodokuma May 19 @ 7:47pm 
had to re-subscribe..had to walk through the quest again...but everything was already dead...back now...and treasure room actually looks better! the mounds of gold were missing the first time
Draco1122  [author] May 19 @ 3:49pm 
really???? did steam disable the esp maybe?
wodokuma May 19 @ 3:40pm 
mine just disappeared...love it...had it for a long time....my character is spawning on the side of the mountain where the forge would be
3at7he5ausage May 1 @ 12:55am 
I got lost...
Draco1122  [author] Apr 20 @ 10:20pm 
all dependson the mod and how it is set up this one has a quest
=(e)= Ragtacoman Apr 20 @ 4:23pm 
Hey, I never tried to get my own player home before, so I was just wondering; is there a specific way that I have to set Castle Draco as my home or is it automatic?
CanadianBoom Apr 8 @ 4:45pm 
Oh sorry, I just re-read the mod description. :p
CanadianBoom Apr 8 @ 4:44pm 
When I talk to the cat guy I don't get the diolog option to buy the key. I bought the book from him thinking I needed it to buy it but the quest isn't even updating. It's still saying that I need to find him.
Draco1122  [author] Apr 5 @ 11:49pm 
cant in this version
Mostschedl Apr 3 @ 6:06am 
How can i open the doors in the chapel?
FREDGARD Mar 23 @ 6:34am 
super!
iggy102 Mar 4 @ 8:54am 
this mods kinda busted bruh, even with all the save reloading, Forced commands and trickory I try to ket the key from the money grovling kitten, he never gives meh the key to the place, the first time I got the diolog, but the key that was meant to be handed over was never given, and when I went to enter the place without the key, I turn around and he ghosted it and never was saw again XD

danielfish-defcon123 Jan 7 @ 4:27am 
yeah i thought that was funny haveing all them things moveing around LOL
Draco1122  [author] Jan 6 @ 8:03pm 
That is from a missing meshes should be in the bsa weird their should be cion piles their let me check some things.
Silvasco Jan 6 @ 7:52pm 
The castle is very beautiful! I'll probably enjoy by ordering all my armors and weapons. My retirement from adventurer's job will be perfect!

Yet I'm experiencing a bug in the treasure vault: the chests, statues and other object are floating on each other: http://steamcommunity.com/sharedfiles/filedetails/?id=370841420
[GG] Dugan Dec 13, 2014 @ 10:05am 
I wish I had downloaded this one instead of the high hrothgar one. lol. It looks amazing.
danielfish-defcon123 Nov 17, 2014 @ 5:02am 
I thought i would take a look see before rateing or saying anything,..... I have to say you did a very nice job on this Mod, its going to stay on my mod list along with my GOD ring... again i say Good job Draco1122!!!!!
SoapMayhem Nov 5, 2014 @ 10:42am 
Anyone has non-imperial version?
ShadowsFate Sep 15, 2014 @ 10:58pm 
Seems the castle is either sinking of there are some serious glitches with this building, my bartender just slipped into an underground dungeon.. lol
SoullessHeart Sep 4, 2014 @ 11:23am 
I was meaning more like its a set feature in the Chapel, or the Vaults. Just a suggestion of course.
Draco1122  [author] Sep 3, 2014 @ 5:26pm 
Their is one on the nexus that add a stone at the guardian stones and lets trade souls for stats too
SoullessHeart Sep 3, 2014 @ 4:45pm 
Think you could add something that lets you trade Dragon Souls for perks in the Chapel? The one I had was eaten by the castle when I got the mod.
SPyRU Aug 25, 2014 @ 8:26pm 
so cool is the castle nice work..
Draco1122  [author] Jul 27, 2014 @ 11:53pm 
Their is a mod that fixes the mannquin bug I know it is on the nexus not sure about steam.
partyartbyrobin Jul 27, 2014 @ 9:23pm 
Love the castle! Stored TONS of stuff in the vault, but I came back after it reloaded and none of the mannequins in the entire castle are wearing their armor!?! It is still in their inventory, thankfullly, but they are not wearing /displaying it! So annoying! Any idea how to fix this so I don't have to re-dress all the mannequins every time it reloads? Also, and this REALLY pisses me off... the Dragon Priest Mask Altar thingy by the Throne of the first dragonborn... it is NOT safe for storage! I put my four hard-fought, hard-won, one-of-a-kind dragon priest masks on there... and after it reloaded they are GONE!!! Now how am I going to collect the full set? I'm freaking out! I'll have to try to figure out how to get them using console commands or something! Please fix these issues because I'd love to be able to display my collected loot! At least all the weapon racks seem to be safe.
Astro Jul 22, 2014 @ 10:23am 
Ok, thank you :)
Draco1122  [author] Jul 22, 2014 @ 10:15am 
place the file in you data folder
hultslander12345 Jul 22, 2014 @ 10:13am 
I couldnt get into my skyrim so i xcouldnt check :(
Astro Jul 22, 2014 @ 9:57am 
Thanks :) One more question, what do I do with the file?
Draco1122  [author] Jul 22, 2014 @ 9:38am 
To fix the dialog download the nexus fix file. Under optionial files. It is a game bug.Link is under troubleshooting above in description.
Astro Jul 22, 2014 @ 9:06am 
For me Malcom only has the shop option available, would you mind helping me with getting this fixed?
hultslander12345 Jul 22, 2014 @ 7:09am 
:P well the guards werent attacking me but most of the people were
maybe
Draco1122  [author] Jul 20, 2014 @ 5:16pm 
Do you have a bounty?
hultslander12345 Jul 20, 2014 @ 3:13pm 
mac jal or whatever the kajjit the first guy that you have to talk to keeps attacking me so ill just try the other edition of this but if you can reply in some way please do i will use it
x42shadow Jul 14, 2014 @ 11:24am 
i cant get all the way threw the cave. iget to the barred gate
BIA_SLENDER Jul 9, 2014 @ 11:59am 
Oh but you did great though!
BIA_SLENDER Jul 9, 2014 @ 11:58am 
The manakins were...walking....They did stop after a few seconds but...wow....
Draco1122  [author] Jun 24, 2014 @ 1:22pm 
lol, Really you are getting a castle not a tent. But player.additem 0000000f 20000 for the money also the key is in old storage for free.
K9 Kilz May 26, 2014 @ 6:38am 
im impressed this is AMAZING!!!!!
madcat6977 May 18, 2014 @ 2:05pm 
Captian who gives a crap how much money is in a journal
Realize Focus Apr 26, 2014 @ 7:04pm 
Draco1122= Best Skyrim House Modder EVER!!!!!
Captain Apr 19, 2014 @ 7:41pm 
WHY IS THE JOURNAL OVER 20000 GOLD??? ITS A JOURNAL UUUUGH!!!!!
trisman98 Apr 14, 2014 @ 9:27am 
i just wanted to enter the vault but the game crashed and then i tried agian then it crashed again HELP!!!
Draco1122  [author] Mar 28, 2014 @ 8:20am 
No it is not a harry potter reference from the movie dragonheart.
Sebastianator Mar 26, 2014 @ 4:22pm 
...Harry Potter reference?
madcat6977 Mar 25, 2014 @ 4:41pm 
This mod looks awesome but the last mod i downloaded Castle draco hrothgar was very laggy
NumjucksThePrepper Mar 17, 2014 @ 2:32pm 
i am sorry to tell you but there is no castle courtyard in riverwood.
mycastlecellar Mar 7, 2014 @ 6:07pm 
OK; this is a super mod. But you need to get that place hopping. No dialoge no one is doing anything but standing around. Make it do something. It's a Castle. Make it alive. Watch a few old movies of Knights and kings and you know. Make it alive; DracoStien. You've created a monster, now make it alive. Ha Ha Ha Go for it.
Draco1122  [author] Mar 5, 2014 @ 9:08am 
I dont mind the list I have been working on the high Hrothgar edition for awhile now but I was think of making an update for this one too.