Recurve Longbows
355 commentaires
< >
Juicy Fruit :3 Il y a 20 heures 
Longbow Perks page no longer exists. Any chance it will be up again on workshop? Or perhaps it's already/still up on nexus? Just wanted to know what happened to it, I downloaded months ago and never got around to playing so I was curious when it failed to load just now lol
LoMan 23 août à 12h51 
Ok thanks :)
Grantiz  [créateur] 23 août à 12h50 
@LoMan - most of them are craftable
LoMan 22 août à 9h52 
Is it craftable, you never mentioned that
AssassinXpRO 9 août à 5h03 
What is the first bow in the screenshot ?
Loading... 30 juin à 23h35 
Can u make a nightingale longbow?
~EntryFrags~ 20 juin à 10h19 
What is the first set of armor!?!?!?!
Timesplitter 5 juin à 23h27 
Skyrim Ultimate RPG Experience: All Expansions thanks you for your mod/mods made that have been implemented into the collection. It does require all the Skyrim expansions, but is composed of all the most promising mods ever made for Steam. Make sure to check it out at http://steamcommunity.com/sharedfiles/filedetails/?id=106745968 and don't forget to rate it.
nicksib91 26 mai à 17h23 
What is the name of the bow in the first screenshot and how can I get it?
pethrusii 16 mai à 14h45 
Ok... i saw that coming :) Thanks
Grantiz  [créateur] 16 mai à 14h36 
@pethrusii - you have to kill silus to get the longbow.
pethrusii 16 mai à 13h26 
Problem here... I got the fake daedric longbow quest BEFORE starting pieces of the past, after completing PotP (Ps: i spared Silus) i returned to Randal, but nothing hapened, he was even selling another fake daedric longbow. I realized that i was stuck and did the only thing i could do, i killed randal thus making the quest fail (i have a "backup" save before killing randal) and got the lonbow via console. What i did wrong? btw great mod
Blue Phoenix 9 mai à 6h05 
it would be nice if the armour was on steem
TheKMan 5 mai à 1h44 
what is the first hooded armor in the pictures called?
bSun Nihilanth 4 mai à 15h04 
can you link? please
Grantiz  [créateur] 4 mai à 14h30 
@bSun Nihilanth - it is now Longbows and Crossbows that have the perk addons.
bSun Nihilanth 3 mai à 22h39 
mod works perfectly im guessing steam just wanted something to error at :D
Grantiz  [créateur] 3 mai à 20h56 
@bSun Nihilanth - you mean steam is coming up with this error when you start the launcher?
bSun Nihilanth 3 mai à 20h49 
ive had the mod for a really long time now and now its failing to acquire information error 15??
Teleporting BλTMλN 30 avr à 13h19 
Okay.... I already got the bow, but I tried that anyways and it worked... thanks.
Grantiz  [créateur] 29 avr à 20h04 
@Teleporting - try typing ("help "bound longbow") minus the parentheses.
Teleporting BλTMλN 29 avr à 17h18 
Where is the bound longbow?.... You can't add it with the script since it is not an object so what is the tome ID?.... any suggestions would be helpful.
PINKIEZz 25 avr à 13h02 
thx find on my own but thank u :)
Grantiz  [créateur] 25 avr à 12h44 
BEAST|PINKIEZz - its the bound longbow!
PINKIEZz 25 avr à 12h38 
which bow is on the 8th picture? The ghost bow? Because i saw a mod with ghost arrows and the bow looks like its matched with the arrows. Am i right?
foolexia 7 avr à 16h10 
Thanks for these posts, they really helped me out since NMM is malfunctioning and hasn't been too kind to me anyways.
DropDead [Raven Guard] 30 mar à 2h56 
i want that armor
dracodraconis1000 23 mar à 0h43 
how do you get the mehrunes dagon longbow?
Scarface 12 mar à 7h08 
Where in blackreach is the boxed artifact quest?
Ima mudda truckin T-rex 2 mar à 22h02 
whats the note called i cant find it in my inventory
prb666 23 fév à 7h37 
huh i wonder where these came from lol i dont even have dawnguard installed
Grantiz  [créateur] 22 fév à 23h51 
@prb666 - nope not me!
prb666 22 fév à 23h23 
did you add some vampire powers in this mod?
Dogma 19 fév à 23h12 
What armor is that?
Grantiz  [créateur] 1 fév à 11h07 
@Everyone maybe links can be found under question 1 of the q and a.
D. Idaho 18 jan à 16h26 
@Grantiz - I got it a couple days ago.
Grantiz  [créateur] 18 jan à 10h03 
@Professor of Satchness - when was the last time you updated the mod?
D. Idaho 18 jan à 4h04 
I got the Ancient Dwemer Longbow, but whenever I equipt it, a message pops up at the upper left-hand section of my screen saying that I have not comepleted the quest required to use this bow.
Mōd 16 jan à 12h58 
The Ancient Dwemer Bow doesn't seem to be enchantable, is that a thing or a bug that I'm having?
Anor Silverfall 21 déc 2013 à 5h10 
@Grantiz
It works. So easy :D Thanks for the tip. I didn't use the help function.
And sorry for my stupidness. Today I found a lonbow.
Grantiz  [créateur] 20 déc 2013 à 5h38 
@AnorSilverfall - have you tried using the help function? To get the id codes.

help "ash longbow"
Anor Silverfall 20 déc 2013 à 4h13 
@Grantiz
Yes its all activated. I have checked it in the Nexus Mod Manager and in the Skyrim Launcher. I also checked the right order of the mods. Maybe ist not compatible with a other mod I have?
I have activated this mod collections: http://steamcommunity.com/sharedfiles/filedetails/?id=201730451 and http://steamcommunity.com/sharedfiles/filedetails/?id=91132733 and a few more single one. Maybe I just used the wrong ID-Code. I used the codes from your nexus-site.
Grantiz  [créateur] 19 déc 2013 à 15h07 
@AnorSilverfall - have you activated the esp?
Anor Silverfall 19 déc 2013 à 15h01 
This is a great mod, but for some reason I can't use it. I can't find a longbow. When try to get one with the ID-Code it dosen't work either. The console says that there is no item with that ID-Code. The Perk-Mod works very good, but without a longbow? That's really sad.
Mod Tester 16 déc 2013 à 9h14 
@Grantiz If you do use the Greatbow idea can you make them knock humans and stuff down? if so that would be AWSOME!
GEN. Martinez 12 déc 2013 à 21h31 
and it is a very good mod as well!
Grantiz  [créateur] 12 déc 2013 à 20h54 
@lamthech0sen0ne - Thanks?
GEN. Martinez 12 déc 2013 à 18h48 
thanks for helping me find that armor just for that i'll download your mod.
Dr. Death 6 déc 2013 à 13h17 
The item codes are not working for me. I have the mod installed, but they won't show up in my inventory when I type in the item codes.
Mod Tester 6 déc 2013 à 7h58 
Also ive tride this many times and it works!