Defective Map! (Exchange) stand by for rebuild...
28 Comments
< >
Reiman  [author] Feb 28, 2013 @ 1:42pm 
@hflare: I apologize! Check out my epiphany
Reiman  [author] Feb 27, 2013 @ 3:07pm 
Sadly I haven't time at the moment, but I think I'll rebuild it someday and try to revive the ID.
Thank you.
Geneosis Feb 27, 2013 @ 8:40am 
Hi there, same crash problem when I tried to play the map... It's possible to hack the worksop map ID if you rebuild a copy of the original map, but sometimes it wont work.
Reiman  [author] Feb 16, 2013 @ 2:37am 
Well, I thought, the backup is in the steam cloud, but there it's corrupted as well, so...
I didn't find out yet, how to repair this file and looking into it and comparing with others it doesn't seem broken, so the best will be to recreate it and try to name it with the old SteamID. I'll let you know here, if it worked. Thank you so far.
buff00n Feb 14, 2013 @ 5:02pm 
Oh no!

The actual editor files are located in (Steam home)/steamapps/common/portal2/portal2/puzzles. Each .p2c file appears to be accompanied by a .jpg thumbnail, so you should be able to identify which one it is. Maybe you have a backup, or some way to revert files to a previous version?

Other than that I don't have any clue. You're best bet is probably checking the forums to see if anyone else has had the same problem.
Reiman  [author] Feb 14, 2013 @ 12:42pm 
I'm going to COL* now! My file has been corrupted and isn't even able to be loaded into the editor anymore. Any suggestions, what I can do now? It was one of my most popular maps - now it's gone -_-,



*Cry out Loud
buff00n Feb 13, 2013 @ 6:31pm 
I've tried a number of times to take another look at this, but every time I try to start it up it crashes Portal. It dumps me to the menu screen, but with no menu. I have to use the console to exit. I'm not sure what to make of that. Maybe you could try uploading again?
Reiman  [author] Jan 27, 2013 @ 11:04am 
buff00n: thanks for the constructive comment!
I implemented the visual, as it might be as misleading as it will be a help, since it 'clicks' in the players brain :)
Didn't know at first, what the grate for, then it 'clicked' in my brain, so I found it to be no bad idea as an assist tool. Hope, it's what you were thinking of.

Added "Game of Cubes" and "The Shaft" to the queue.
buff00n Jan 26, 2013 @ 5:28pm 
I like this one a lot.

I got about as far as you can possibly get without realizing that you need the cube to turn on the blue funnel. Then I reset and did it correctly.

I ended up using the funnel to take the cube off and the back on the button remotely, the latter of which took a number of tries. If that's the correct solution then you could probably make it easier with a grate behind the button, and maybe marking out which part of the back wall lines up with it.


A while ago I create a puzzle that takes one of the techniques used in this one to the extreme:
The Shaft.

Reiman  [author] Jan 25, 2013 @ 9:59am 
I just went through that map again and think, what has to be changed is less the light in that passage, more the brightness of your monitor. The destination circles of the faithplates are so bright green and the walls in the passage upstairs so shiny, that it's not really pitch black, just a little dark but not fully. On the other hand, that's just a way if you got totally lost. So the darkness shall tell you a little story. If there was a sign, that would tell you: "hey there, I'm Cave Johnson and you did something wrong, please start over", I would add that and a spotlight, to show you, where to go. Sadly that editor has not this many capabilities and I not so much time to start with Hammer. I hope, you understand. Thanks for the constructive comment anyway!
hflare Jan 24, 2013 @ 10:32pm 
The vertical passages above the faith plates are pitch dark. Put in some light. Very annoying to be in pitch dark and to fall back through again and again.
Reiman  [author] Jan 10, 2013 @ 10:05am 
I wonder if I can use a spoiler-tag, if it's not in my youtube channel. Didn't find it, so I placed a link in the description.
Reiman  [author] Jan 10, 2013 @ 9:57am 
Thank you very much for the video, I'll use it! It's hard to overstate, how GLaD I am that you like it!!! You earned an A++ on using the cube on the button before entering by yourself ^_^
The glitch I am aware of, as it also happened to me on testing. (That's why there is one in this direction) But as you told, that it doesn't affect the solution and is not this bad, just a little frustrating, I kept it as a learning effect for further tests anywhere in the workshop. :)
KennKong Jan 9, 2013 @ 2:03pm 
I went ahead and recorded a solution video: Exchange. If you want to put this in your snapshots, you can use the spoiler tag on it.
KennKong Jan 9, 2013 @ 1:18pm 
One of the best funnel mazes I've played. There is one glitch which doesn't affect the solution: the cube can be pulled through the grate at the end of the funnel in the orange direction, but can't be pushed through in the blue direction. I was a little slow firing my portal after pulling the cube through the death grille and the cube re-entered the maze.
Ebbzylon Dec 22, 2012 @ 8:24am 
Yup. As far as I can tell, no shortcut for the cube anymore.
Reiman  [author] Dec 22, 2012 @ 8:05am 
Ooh right, you didn't mention that before, so I was wondering why the whole puzzle was able to bypass. Well, that shouldn't happen again now. Want to check out the test again?
Ebbzylon Dec 22, 2012 @ 6:13am 
Oh, my bad. I thought I was getting the cube the intended way :-)
Here's what I do to get the cube to its first required location (hence the quick portal bump to the exit when it was there).
Reiman  [author] Dec 22, 2012 @ 5:30am 
@Ebbzylon: thanks again for telling the exploit. So if you first needed to get the cube anyway, not the whole grating puzzle was broken, just the half (and difficult part).
@tedwilliams4808: can't tell, if you did it the intended way, but talking of "then you got to do it" makes it seem so!
I'm happy, both of you like it ^_^v
stormsend Dec 22, 2012 @ 2:18am 
Don't knpw if I did it the intended way but it was quite difficult. Enjoyed figuring out what to do but that's just half of it. Then you got to do it. I tried to make a similar map a while back and couldn't get it to work right. You suceeded and came up with a great map. Thanks.
Ebbzylon Dec 21, 2012 @ 3:12pm 
When portal bumping was possible, I would just portal bump to the exit with the cube. Now it is fixed. I had to do the puzzle the proper way to reach the exit with the cube.

Nice puzzle. Thumb up!
Reiman  [author] Dec 20, 2012 @ 1:07pm 
Hi Ebbzylon, of course I wasn't aware of that glitch. I now did an update, but couldn't figure out, why the whole grating puzzle shall suffer from the portal bumping. Please play again and tell me, where else you find an exploit in here. Thank you very much!
Ebbzylon Dec 19, 2012 @ 4:50pm 
Hey Reiman. You should eliminate the portal bump opportunities. When it is there, I can't help but to use it :-) In this case, portal bumping allow to bypass the whole grating puzzle.

See my map Glitches & Exploits, first room video (videos links are in the first comment), to see what I mean.

cheers
E.
Reiman  [author] Dec 9, 2012 @ 1:50pm 
I'm GLaD, you enjoyed it! ^.^v
daloboy Dec 9, 2012 @ 1:26pm 
Done! Had fun! I kept trying to travel the cube...when I realized that I had to travel myself...
daloboy Dec 9, 2012 @ 10:27am 
Hi Reiman! I just realized, thanks to your pictures above, that I could pull it up!!! I'll try again.
Reiman  [author] Dec 9, 2012 @ 5:34am 
Hi daloboy. I can't see this problem you mentioned. I let fall the cube into the orange beam at each of the three segments and I was always able to push/pull it back to a higher level and continue. I admit, it's a bit tricky at this point, but please try it again and experiment a little with the funnels, so you will come to the solution. Furthermore you always can push the cube into the goo with the blue beam, so that it will respawn, if you feel the need. But keep in mind, that you aren't able to respawn if it's your turn ^_-
daloboy Dec 8, 2012 @ 7:17pm 
Hi Reiman. There a major problem with your map: if I lose the cube of the right side, near the orange funnel, there's no way to retrieve it! If you had a button to either stop the funnel (will drop in goo) or respawn the cube, I can continue! Let me know if you updated it!