Garry's Mod

Garry's Mod

Advanced Ball Socket Tool (Adv. Ballsocket)
< >
70 Comments
Dale Boomstick Apr 27 @ 3:44pm 
One question, let's say I make a something using this and I dupe it, somebody without this mod spawns the dupe, will it still work perfectly fine?
Sabertooth Python Jan 15 @ 7:24pm 
Is anyone else having an issue in that the tool is no longer centered? It's now actually creating a ball socket at the point I click
Vortex Jan 8 @ 1:57pm 
YES!
For The Side Bars On Steamers
[DFS] Xxx_TheGamingBloke_xxX Nov 6, 2015 @ 7:34am 
would you use this for connecting rods on wheels on a steam train?
juмρмǺи jØяÐǺи Aug 24, 2015 @ 6:01pm 
COME ON MAKE AN UPDATE U CAN DO IT
juмρмǺи jØяÐǺи Aug 24, 2015 @ 6:01pm 
WHEEL SPAZ. WOBBLY TIRES. TIRE LOCKUPS. CANT GAIN HIGH SPEED WITHOUT WHEEL SPAZ. MA NIGGA U NEED TO RECODE OR SOME SHIT CUZ I LIKE THE TOOL AND ALL BUT I CANT DO MUCH WITH IT NOW
Adam Aug 17, 2015 @ 5:30pm 
it wasn't remove...
Arctic Fox 004 Jun 28, 2015 @ 12:49am 
2 day's and still no response, great!!
Arctic Fox 004 Jun 26, 2015 @ 12:53am 
whenever i use this, the tires i socket will become wobbly, is there any way to fix this?
Orion May 23, 2015 @ 12:06pm 
I have the add-on installed, I can see the settings menu and change the settings but when I try to attach it to 2 objects and use it it won't do anything. Tried disabling and enabling and then re-installing. Still nothing.
Danny D Apr 7, 2015 @ 1:54am 
No right click mode that lets you set where the rotating prop will be?
Hard to make doors, I don't want them to float above the ground.
DifficultDig Feb 12, 2015 @ 10:55pm 
Is there a way i can download someone else's settings and use them?
James D Sep 22, 2014 @ 9:59pm 
Yeah. Its is strange how that works. Though sometimes can be a headache, Lol.
[GME] TweaK  [author] Sep 22, 2014 @ 9:13pm 
Ah, the ole turn it off and back on trick. Good to know.
James D Sep 21, 2014 @ 9:14pm 
and might I add, still a great tool. Works wonders with complex builds :)
James D Sep 21, 2014 @ 9:12pm 
I didnt delete it per se', But im guessing the validations from steam were either overlooked while checking workshop files or something. So, I disabled then re-enabled the tool. worked for me afterwards.
[GME] TweaK  [author] Sep 21, 2014 @ 7:10pm 
Interesting... so did you just delete the gma and let it redownload? If that did it then perhaps it is an issue of steam not verifying the file or something. Glad to hear you got it figured out, anyway.
James D Sep 17, 2014 @ 7:22am 
actually, i discovered the issue. wasnt an addon conflict, as its fine. turns out somewhere down the line the .gma file was overwritten. the is "was" that the advanced aspect of the tool was more along the lines of basic when the settings were nowhere to be seen. other than that, the tool itself still worked, sorta. now that i've corrected the .gma all seems fine.
[GME] TweaK  [author] Sep 17, 2014 @ 2:18am 
What exactly IS the issue you are experiencing? Have you tried disabling all other addons to test it? "It worked fine before" does not rule out an addon conflict.
James D Sep 13, 2014 @ 8:37pm 
No, unfortunately it isnt due to an addon conlict, as every addon client and server side worked fine several months back, and still the same set up. As I'm being told, i am not the only one experiencing this issue, other servers are as well. Figured there was a sort of bug that may have worked its way in during the update recently.
[GME] TweaK  [author] Sep 13, 2014 @ 1:13am 
It should be working fine with the current update... unless there is something I am not aware of? if you are experiencing a blank context menu then that is due to an addon conflict
James D Sep 9, 2014 @ 1:34pm 
Normally i would have taken a hard file through Gmad extractor, though that isnt working neither. Any ideas when you can update this tool to work with the current update, or how i can fix its current state server/client side, the way it is?
Tomisup Sep 7, 2014 @ 10:28am 
thank you! this has saved me from frustration
Russian__Bear_142 Aug 14, 2014 @ 9:16pm 
Классный мод,мне понравился.
koun Jun 25, 2014 @ 5:33pm 
Hello when i play on a server my ballsocket adv. settings doesnt appears on the menu can you help me?
[GME] TweaK  [author] May 20, 2014 @ 2:05pm 
It could be part of a tool pack or some other addon you have installed, I dunno. Kinda hard to track down the problem when it doesn't happen to me, lol
Xer0n_ May 20, 2014 @ 2:35am 
I just deleted the addon itself and converted it using gmadconverter and it works fine now. It was in my spawn menu even though it wasn't on the server which concerns me a little as well.
VAC3 & Overwatch Hacked May 20, 2014 @ 12:48am 
fuck1111111111111111111111111!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
u re car !!!
i can !!!! i fixed !!!! fucker !!!!!!!
dont fuckin make error
fuck my asshoe
VAC3 & Overwatch Hacked May 20, 2014 @ 12:45am 
im not have fuck
i ll kill my self
fucker
VAC3 & Overwatch Hacked May 20, 2014 @ 12:42am 
i ll try
[GME] TweaK  [author] May 20, 2014 @ 12:21am 
Hmm. Do you have a settings/controls/ballsocket_adv.txt in your garrysmod folder? If so, does removing/renaming that file fix it? (you have to exit and restart garrysmod)
Xer0n_ May 19, 2014 @ 9:23pm 
Menu is completely empty for everyone now, before it was just select users.
VAC3 & Overwatch Hacked May 19, 2014 @ 3:42am 
ok ill try
if icant i l lkill my self fucker
[GME] TweaK  [author] May 18, 2014 @ 8:04pm 
Try disabling all other addons
VAC3 & Overwatch Hacked May 16, 2014 @ 8:54pm 
fucker
VAC3 & Overwatch Hacked May 16, 2014 @ 8:54pm 
im reinstalled my window7 ultimate
VAC3 & Overwatch Hacked May 16, 2014 @ 8:53pm 
yes fuck
[GME] TweaK  [author] May 14, 2014 @ 4:30pm 
Does the latest version still not work for you?
VAC3 & Overwatch Hacked May 14, 2014 @ 12:12am 
Fixxxxxxxxxxxxxxxxxxxxxxxxx
Misssssssssssing menuUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUaAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
VAC3 & Overwatch Hacked May 9, 2014 @ 8:38pm 
when is fuckin fix and i can gmod fucker!!!
m0nclous May 9, 2014 @ 10:42am 
Нет меню настроек! \ Missing menu settings!
Czeczen May 9, 2014 @ 7:23am 
And all tanks are dead... Why menu? WHYY?
[LBS]SANDERS May 7, 2014 @ 4:16pm 
this is borken must be fixed!!
Mr.Prof.Dr. Ghostkiwo May 6, 2014 @ 11:30am 
The ADV Ballsocket menu dont show up ingame can u fix this i need this tool :(
VAC3 & Overwatch Hacked May 3, 2014 @ 4:07am 
when is fix
VAC3 & Overwatch Hacked Apr 18, 2014 @ 3:09am 
now is fixed?????????
Keksovel Apr 17, 2014 @ 8:55pm 
НЕРАБОТАЕТ !
Benito "Linguini" Mussolini Apr 15, 2014 @ 9:20pm 
I also seem to be getting the "no menu" error on Manjaro Linux. The PA adv ballsocket still works, but it's a pain to use on a regular basis.
SpeedKiller Apr 12, 2014 @ 10:11pm 
Free Movement does not work anymore!!! pls fix!!!