Advanced Ball Socket Tool (Adv. Ballsocket)
59 Comments
< >
Uszatek Oct 28 @ 5:16pm 
hello, it is a nice tool but the rotational constraint option causes the constraint to get wonky over time, I made a video on it, add me if you wish to discuss& investigate this some more
JamesDennison Sep 22 @ 9:59pm 
Yeah. Its is strange how that works. Though sometimes can be a headache, Lol.
[GME] TweaK  [author] Sep 22 @ 9:13pm 
Ah, the ole turn it off and back on trick. Good to know.
JamesDennison Sep 21 @ 9:14pm 
and might I add, still a great tool. Works wonders with complex builds :)
JamesDennison Sep 21 @ 9:12pm 
I didnt delete it per se', But im guessing the validations from steam were either overlooked while checking workshop files or something. So, I disabled then re-enabled the tool. worked for me afterwards.
[GME] TweaK  [author] Sep 21 @ 7:10pm 
Interesting... so did you just delete the gma and let it redownload? If that did it then perhaps it is an issue of steam not verifying the file or something. Glad to hear you got it figured out, anyway.
JamesDennison Sep 17 @ 7:22am 
actually, i discovered the issue. wasnt an addon conflict, as its fine. turns out somewhere down the line the .gma file was overwritten. the is "was" that the advanced aspect of the tool was more along the lines of basic when the settings were nowhere to be seen. other than that, the tool itself still worked, sorta. now that i've corrected the .gma all seems fine.
[GME] TweaK  [author] Sep 17 @ 2:18am 
What exactly IS the issue you are experiencing? Have you tried disabling all other addons to test it? "It worked fine before" does not rule out an addon conflict.
JamesDennison Sep 13 @ 8:37pm 
No, unfortunately it isnt due to an addon conlict, as every addon client and server side worked fine several months back, and still the same set up. As I'm being told, i am not the only one experiencing this issue, other servers are as well. Figured there was a sort of bug that may have worked its way in during the update recently.
[GME] TweaK  [author] Sep 13 @ 1:13am 
It should be working fine with the current update... unless there is something I am not aware of? if you are experiencing a blank context menu then that is due to an addon conflict
JamesDennison Sep 9 @ 1:34pm 
Normally i would have taken a hard file through Gmad extractor, though that isnt working neither. Any ideas when you can update this tool to work with the current update, or how i can fix its current state server/client side, the way it is?
Tomisup Sep 7 @ 10:28am 
thank you! this has saved me from frustration
Werewolf Aug 14 @ 9:16pm 
Классный мод,мне понравился.
Pedrohor037 Jun 25 @ 5:33pm 
Hello when i play on a server my ballsocket adv. settings doesnt appears on the menu can you help me?
[GME] TweaK  [author] May 20 @ 2:05pm 
It could be part of a tool pack or some other addon you have installed, I dunno. Kinda hard to track down the problem when it doesn't happen to me, lol
|TBB| Xer0n_ May 20 @ 2:35am 
I just deleted the addon itself and converted it using gmadconverter and it works fine now. It was in my spawn menu even though it wasn't on the server which concerns me a little as well.
UTRgames May 20 @ 12:48am 
fuck1111111111111111111111111!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
u re car !!!
i can !!!! i fixed !!!! fucker !!!!!!!
dont fuckin make error
fuck my asshoe
UTRgames May 20 @ 12:45am 
im not have fuck
i ll kill my self
fucker
UTRgames May 20 @ 12:42am 
i ll try
[GME] TweaK  [author] May 20 @ 12:21am 
Hmm. Do you have a settings/controls/ballsocket_adv.txt in your garrysmod folder? If so, does removing/renaming that file fix it? (you have to exit and restart garrysmod)
|TBB| Xer0n_ May 19 @ 9:23pm 
Menu is completely empty for everyone now, before it was just select users.
UTRgames May 19 @ 3:42am 
ok ill try
if icant i l lkill my self fucker
[GME] TweaK  [author] May 18 @ 8:04pm 
Try disabling all other addons
UTRgames May 16 @ 8:54pm 
fucker
UTRgames May 16 @ 8:54pm 
im reinstalled my window7 ultimate
UTRgames May 16 @ 8:53pm 
yes fuck
[GME] TweaK  [author] May 14 @ 4:30pm 
Does the latest version still not work for you?
UTRgames May 14 @ 12:12am 
Fixxxxxxxxxxxxxxxxxxxxxxxxx
Misssssssssssing menuUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUaAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
UTRgames May 9 @ 8:38pm 
when is fuckin fix and i can gmod fucker!!!
m0nclous [55rus] May 9 @ 10:42am 
Нет меню настроек! \ Missing menu settings!
Czeczen May 9 @ 7:23am 
And all tanks are dead... Why menu? WHYY?
Mr.Colonel Sanders May 7 @ 4:16pm 
this is borken must be fixed!!
☭ Ghostkiwo (ಠ_ಠ)☭ May 6 @ 11:30am 
The ADV Ballsocket menu dont show up ingame can u fix this i need this tool :(
UTRgames May 3 @ 4:07am 
when is fix
UTRgames Apr 18 @ 3:09am 
now is fixed?????????
НЕРАБОТАЕТ !
Mitchell Loves Penus Apr 15 @ 9:20pm 
I also seem to be getting the "no menu" error on Manjaro Linux. The PA adv ballsocket still works, but it's a pain to use on a regular basis.
SpeedKiller Apr 12 @ 10:11pm 
Free Movement does not work anymore!!! pls fix!!!
UTRgames Apr 12 @ 8:54am 
cant set X Y Z
Artur Apr 8 @ 5:17pm 
Please fix this tool's missing menu, I am unable to build anything without this.
MammoN Apr 7 @ 11:46am 
Menu has no options for me. Please fix!
counterkiller Apr 6 @ 3:30pm 
im haivng a glitch where the menu doesnt show please help i need this to work
Teeto_FAM Mar 21 @ 12:07pm 
why i cant use it

MrKicker Feb 17 @ 10:03am 
For some reason, I'm having trouble with the free movement option aswel.
Jeune Padawan Jan 15 @ 5:10am 
Fixed by adjusting the Y and Z Minimum to -1 and the Y and Z Maximum to 1.
Jeune Padawan Jan 13 @ 5:15pm 
Hi! For some reasons which I have yet to understand, whenever I used ball socket advanced with the X Minimum to -180 and the X Maximum to 180 and the rest to 0 on the wheels of my car, the wheels goes flying at the moment when I unfreeze them... It's like if they spaz out everywhere... I am building facing north. I tried to follow these two youtube tutorials step by step and still have the error...:

http://www.youtube.com/watch?v=Hp3Y_IHvmR4

http://www.youtube.com/watch?v=23WW61pHxGo

Thanks for any help!
[FF] Adam (UK): Admin from GMOD Dec 31, 2013 @ 12:11pm 
Perfect!
Kajet Dec 3, 2013 @ 1:14pm 
good
Shadow Man Nov 9, 2013 @ 8:14pm 
Also, not sure if it's this or a mounted Bsocket, the free movement option does not seem to work.