The Elder Scrolls V: Skyrim

The Elder Scrolls V: Skyrim

Autodidact Wizard
< >
63 Comments
ADOPTED Oct 19, 2013 @ 8:35am 
subscribed now cant unsubscribe cuz its fuking my game up argghh somone help
Bluefunction Jun 14, 2013 @ 7:08am 
mabie u can use multiple at once?
Puzzled Panda Apr 4, 2013 @ 5:15pm 
I have found a weird bug with this at lvl 100 in desctruction every once in a while it tells me i learn fire ball and ice spear even though i've already learned them, any thoughts?
Concrete Traveler  [author] Mar 12, 2013 @ 2:31pm 
If I remember well, there was a misstake in the script for the novice destruction spells (you don't learn frostbite and spark). I thank I've done the correction.
Mama Crime 2.0 Mar 12, 2013 @ 1:58pm 
Genius
Simply awesome, great mod. 'Nuff said.
Emetivore Feb 18, 2013 @ 4:13pm 
I love this mod. Makes it easy to get spells instead of having to go through the excruciating Mage's Guild chain and/or run all over the world trying to find tomes. Also, makes sense; wonderful work!
Booney Jan 30, 2013 @ 9:15pm 
I havent seen this mod work yet. i cant seem to learn spells unless i need to cast flames for like and hour straight.
Concrete Traveler  [author] Jan 21, 2013 @ 3:47am 
I'm glad to see this mod continue to inprove people's Skyrim experience.
Puzzled Panda Jan 20, 2013 @ 8:22pm 
Def one of my fav mods now, thanks so much for making it. I hope it sticks around the workshop for a long time. :)
Puzzled Panda Jan 14, 2013 @ 8:49pm 
Just stumbled upon this mod today, looks amazing! Will give it a try tonight.
Concrete Traveler  [author] Dec 15, 2012 @ 4:15pm 
Your Merchants don't sell spell books ? I have replaced them because I think changing them have to be in an other mod (which could change all the merchants goods) and don't have his place in this one.
Chaos_Lord Dec 4, 2012 @ 12:45am 
Great mod, but quick question. Are the vendors supposed to have spell books again? There was a time where there wasnt before and I kind of liked it that way.
gabrielfos12 Nov 27, 2012 @ 9:43am 
this works really well for mix classes like nightblade and battlemage
oskar.engesvik Nov 19, 2012 @ 8:02am 
I'm currently not doing a mage-playthrough but when i do i will think of it.
Concrete Traveler  [author] Nov 18, 2012 @ 2:14pm 
If you think some things could be better do not esitate to share me your ideas.
oskar.engesvik Nov 18, 2012 @ 1:27pm 
Okay, gonna try it out again.
really like the concept of the mod so really wanna use it :)
Concrete Traveler  [author] Nov 18, 2012 @ 11:40am 
The new update should clean all your problems.
The Ghost Pyro From Outerspace!! Nov 17, 2012 @ 9:55pm 
Also are you supposed to be able to learn spells normally still? Becuase when I try to activate a tome with this mod it just opens it like a book and that really affects the early game harshly.
The Ghost Pyro From Outerspace!! Nov 17, 2012 @ 9:51pm 
I have the same problem oskar. I've noticed that if I open up either vendor UI or chest UI with this mod and they contain a spell tome I crash. I really like the concept of this mod but that alone is really killing it for me. Also I never start the game with any spells, I don't know if this is a common problem or because I have a alternate start, but either way I have to turn off the mod, spawn spell books and learn spells, leave the game and restart the mod to really have any early game.
oskar.engesvik Nov 17, 2012 @ 3:05pm 
I have a problem with CTDs whenever the vendor UI opens up and i'm pretty sure this mod is causing it. Haven't tested very much to search for incompatibles, but the problem dissapears when I uncheck this mod. Any ideas as to why?
Concrete Traveler  [author] Nov 15, 2012 @ 10:27pm 
I can not upload yet, but you can found ithe last version on Nexus [skyrim.nexusmods.com].
Concrete Traveler  [author] Nov 15, 2012 @ 10:09pm 
You are not the only one and I do not understant why some people have this problem. This is still the last version. I think I will reset the steam version to the precedent one which is more compatible. I'll do it now but you can also find it in the nexus website.
Rezialn Nov 15, 2012 @ 8:52pm 
This mod is causing my game to crash when I look throw my books list. Possibly related, magicduel is causing a crash when I look through my misc list. Any ideas?
Concrete Traveler  [author] Nov 12, 2012 @ 2:38pm 
I think theire is no way. The bound weapon spell tome in the two mods have been modified, Autodidact Wizard (AW) change the way to learn it, Extanded Bound Weapon (EBW) change the spell it teaches.
You certenly have placed EBW plugin before AW in your data file list, and this is good, if you place AW before EBW, the spell tome will not learn you the good spell (I think the EBW's author has done a personal bound spell, the original still exists, the spell tome just learn an other spell, or he has maybe create a new spell tome and removed the original from all the game lists.)
Concrete Traveler  [author] Nov 12, 2012 @ 2:24pm 
I think it is not possible, the OnRead() Event is an ObjectReference event. It does not exist an similar Actor event. Their is the OnObjectEquipped(Form akBaseObject, ObjectReference akReference) event, but I think it just work with weapons and armors and not with books.
Concrete Traveler  [author] Nov 12, 2012 @ 2:16pm 
That's because I have only modified the vanilla spell tomes, I can not modifie the other mods ones. But you make me thinking. Is it possible to do a non absolute version ?
smgsnipe Nov 12, 2012 @ 2:13pm 
i figured it out the expanded bound weapons can still be learned from faranger and the tome dissapears after it is read.
Concrete Traveler  [author] Nov 12, 2012 @ 1:26pm 
I think you whant to allow the character, with level and by himself to forget old bound weapon spells in way to learn better versions.
This mod does not change the vanillia spells, I've just add 4 new spells for a level 50 version of flames, frostbite, spark and heal. I could add new evolutive bound weapon spells to this plugin (and an enable/disable function in the AutodidactWizard menu for anybody who does not want to have the new spells.) The risk is to add non balanced spells or non balanced with other plugin which could rebalance the weapon damages.

I can do a compatible version with expanded bound weapons v1.3, only if I can comunicate with his author, because we both have to change some little things.
smgsnipe Nov 12, 2012 @ 12:22pm 
can you make it work wth expanded bound weapons v1.3
Concrete Traveler  [author] Nov 12, 2012 @ 11:24am 
yes 5 scripts :
AWInitialisation.pex
AWmaintenance.pex
AWOption.pex
AWSpellLearning.pex
AWspellTome.pex
SilverDragon Nov 12, 2012 @ 11:16am 
Also, is this supposed to have 5 scripts????
SilverDragon Nov 12, 2012 @ 11:14am 
OMG IM AN IDIOT!!!!! >.< I just went to your nexus version, downloaded it, and then just grabbed the scripts folder....CANNOT BELIEVE I didnt think of that before.......feel dumb now....
SilverDragon Nov 12, 2012 @ 10:37am 
until i figure it out ill just have to do the other methods of learning spells, ah well
SilverDragon Nov 12, 2012 @ 10:36am 
hmmmmmm....I deleted but didnt unsub so it would re download and i still dont have that script file.....hmmmmmmm
SilverDragon Nov 12, 2012 @ 10:21am 
Ive just looked and it seems i do not have that file, AWspellTome.pex
Dont know why it didnt download...I'll let ya know when I get it fixed :)
Concrete Traveler  [author] Nov 12, 2012 @ 10:10am 
I do not understand why it doesn't work, I've just do a test and I've learn all the spells.
Try this :
Place the AutodidactWizard plugin (alos named AutoLearnSpell) at the head of the mod loading stack (the head is at the end of the data files list.) I presume you have got an other mod which could have change the spell tomes (without any visible changement.)

Or the plugin is maybe not entirely upload, make sur you have this file : Skyrim/Data/Scripts/AWspellTome.pex
If not, just wait a moment after starting the skyrim launcher.
SilverDragon Nov 11, 2012 @ 8:41pm 
Also side note NO i do not have the perk restriction on, dunno if that matters or not..
SilverDragon Nov 11, 2012 @ 8:39pm 
First off I would just like to say that this is a great mod and I have enjoyed it so far but I have encountered one bug....seems like one to me anyways. Ok so I created a new character when I got this mod because I wanted to do a mage again, NO starting spells when I created a new character dont know if that is intended or not. Also, I was able to read an illusion book so I got some illusion spells and I was like YAY! but now I want to get some new spells...my problem is I went to riverwood trader and bought some spell tomes, frostbite, raise zombie, and lesser ward...well I went to read them and nothing happened.....I know they are supposed to now stay in inventory but they ARE supposed to let you learn the spells from them right?? so I was wondering why they didnt?
Swampie Nov 11, 2012 @ 3:48am 
Sure, I have:
skyui.esp
better dynamic snow.esp
thatsice.esp
kerplunk.esp
enhanceddistantterrain.esp
lush trees.esp
dd - realistic ragdoll force - realistic.esp
autolearnspell.esp
(and a birds.esp)
Concrete Traveler  [author] Nov 10, 2012 @ 6:53pm 
I'm looking for the source of the problem. Can you tel me which mods you have in the list ?
Swampie Nov 10, 2012 @ 6:15pm 
Hmm, no, not yet. I don't have the dlcs installed, but a few of the other enlisted mods. Aren't they compatible?
Concrete Traveler  [author] Nov 10, 2012 @ 6:02pm 
Have you tried to play a new game with just autodidact wizard activate ?
Or have you update the plugin from the 06/11 to the 09/11 one ?
Or have you got any one of those plugins installed ?

Dawnguard.esm
HearthFires.esm
item sorting by saige.esp
skyui.esp
item sorting dg by saige.esp
purewaters.esp
better dynamic snow.esp
better embers.esp
thatsice.esp
terrain bump.esp
kerplunk.esp
enhanceddistantterrain.esp
lush trees.esp
dd - realistic ragdoll force - realistic.esp
Birdsofskyrim.esp
birdshf.esp
autolearnspell.esp
staticmeshimprovementmod.esp
greenwaterfix_compatible.esp
Swampie Nov 10, 2012 @ 2:25pm 
First of all, nice mod. But (as you mentioned udner my post) the game crashes every time I want to trade with the court mages.
(And yes, I have SKSE installed)
Concrete Traveler  [author] Nov 9, 2012 @ 10:47am 
If you have any trouble with the last update, you can found the stable old version on Nexus. I have no problem with my local version, but I've receve a mail which descibes a chutdown after opening different game menue. If you have the same probleme or if you have not, tell me if you have installed SKSE, it could help me.
TORCHWOOD Nov 6, 2012 @ 9:51pm 
damit damit damit why oh why didnt this come out sooner. kick ass mod
Concrete Traveler  [author] Nov 6, 2012 @ 9:31am 
That is a good idea, I should do that. But people have to have the choice. I'm working on an in-game menu which show options to configurate the mod (enable or disable the perk restrictions for now.) When that will be done, i'll word on your idea. Apparently people whant me to make this plugin an accomplished one, it encourage me thanks to all.
jhelin0436 Nov 6, 2012 @ 8:00am 
Dude awsome. You should do this with the other perk trees to. Like enchanting weapons.You should have to find books on them to be able to make stronger enchantments or something.Smithing you should have to find the books or both book and weapon to be able to craft weapons,Or maybe have to find weapons, brake it down and then be able to make it then have to get books on how to make ur weapons better. for orc one for steel another book and so on but you have to level with the right book before you can move up to epic then superior and so on for exsample.I do it if I could but dont know how thats why you are such a bad ass.you bring things that people want and can not do themselfs
Concrete Traveler  [author] Nov 4, 2012 @ 2:23pm 
This mod is now on Nexus too.
http://skyrim.nexusmods.com/mods/26488/
Simon Nov 4, 2012 @ 12:49am 
Can't edit comments here I see.

Please release this on Nexus where mod users can have options, better packaging, etc.

The readme needs a section on compatibility. How does this play with mods that add spells through both leveled list and merchants?
matt.drain Nov 3, 2012 @ 4:16pm 
I love the idea. Overall i think its more realistic, although i never liked the idea that "oh, i just got 50 destruction, now my spells are twice as good as they were at rank 49" Maybe there is a way to have more gradual progression of spells. After all, few mages just suddenly understand more of thier magical field in a moment, it takes hours of study. This mod is a HUGE step in the right direction. Simply genius. Keep up the great work! :)