836 ratings
Jiub's Opus Quest Markers
Category: Quests
File Size:
0.005 MB
Aug 15, 2012 @ 10:43pm
Aug 15, 2012 @ 11:20pm
2 change notes ( view )
Adds quest markers to help you find the pages for the Impatience of a Saint quest.

** Dawnguard DLC REQUIRED! **
Because this modifies a Dawnguard-only quest.

Click the Subscribe button above.
Skyrim's launcher will automatically download the mod.
Click Data Files in the launcher and checkmark impatienceofasaint-markers.esp.

Q: Why?
A: Because the Soul Cairn is big and dumb and its mother is ugly. It's my least favorite feature of Dawnguard. I hated running around it with no map, no fast travel, and worst of all: no quest markers.

Need help finding Arvak's Skull for the Soul Horse miscellaneous quest?
Check out Arvak's Skull Quest Marker

I want to note that I based this on Stones of Barenziah Quest Markers by Turn_on_a_Dime. By examining his mod, I learned how to make mine.

  • v.1 - 16 Aug 2012
    • Initial Release
< >
Finally, people like me who actually got headaches running through the soul cairn, trying to find those stupid pieces of paper!
LotsofWaffles Nov 18 @ 7:17pm 
You my friend are a saint I also hate the soul cairn with a passion
Stinktier Nov 15 @ 1:13pm 
Well done, indeed. A real pain in the ass without the markers.
kelvin Oct 31 @ 9:36pm 
thank you a lot for this, that map is plainly stupid and exploring it is completely boring and dull. what on earth would they be thinking of when they decided not including a map or markers.
A Slurpy Full of Chaos Oct 28 @ 8:00am 
would be easier to just add this to the nexus cus steamworkshop is always broken when it comes to skyrim great mod the it does do the trick and also by doing this quest it fixes a ftal run time error that bethesda failed to fix but when u do the quest it gets rid of that runtime java error so this a must have for making quest a breeze
You know 6 hours ago i got all the pages legit... fok dat sh!7 never again Ty for the mod.
Balthias Sep 28 @ 12:35pm 
Worked great for me. Thank you. This quest was always a pain in my ass. Even with video walk throughs the time getting this done was ridiculous.
swiftdeath60 Sep 20 @ 3:31pm 
PS: The mod on the Nexas does not work. Even when loaded last. So I will post your URL there to let people know there is one that works.
swiftdeath60 Sep 20 @ 3:29pm 
I moved the mod to the bottom of load order, did nothing else. Went into game, and the compass quest markers for remaining pages were there. It's now obvious that a mod I have installed is conflicting with this mod. But can't figure how or which one. I have no mods installed that alter, modify any part. or change the soul Cairn. I do have a mod I made which modifies Serana, but it is cosmetic only, should'nt effect this mod at all. In any case I now know to load this mod last in the future. Again, Samutz, I thank you greatly for all the input. And I will continue to use your mod. It works as stated. And hopefully this issue does not happen to anyone else. But if it does you'll now have another possible solution.
Samutz  [author] Sep 20 @ 3:09pm 
As I said a few days ago, I tested with the latest version of the game already and it worked fine for me. It's the first thing I check when a player complains that the mod isn't working.