Euro Truck Simulator 2

Euro Truck Simulator 2

869 ratings
Scania T series by RJL
 
Rate  
Favorite
Favorited
Unfavorite

Subscribe to download
Scania T series by RJL

Subscribed
Unsubscribe
In 1 collection by ScaniaLAD1993
RJL's Mods
5 items
Description
Scania T Mod V2.2 for ETS2 version 1.27

This mod adds Scania T-series for ETS2.
Fully standalone mod, it doesn't replace anything. You can find the truck from Scania dealer.
Currently supported game version: 1.27
Current mod version: V2.2

Mod works only with DirectX, it isn't compatible with OpenGL!

NO SUPPORT IS GIVEN ON STEAM, FOR SUPPORT GO HERE: http://forum.scssoft.com/viewtopic.php?f=35&t=151394

FULL CREDITS TO RJL

UPLOADED WITH PERMISSION FROM RJL


I see there has been a lot of nagging about the OpenGL incompatibility. First of all, my mods have never been officially compatible with OpenGL. I have always used only DirectX for ETS2 (and I have never launched it on OpenGL mode). Basically it means I have never even tried to check if my mods are working with OpenGL or not. Actually, before releasing V2.0 I didn't even know that issues like that can happen. So, I would say it was just "good luck" that older 1.x.x versions were (fully?) compatible with OpenGL.

The question is; "Will my mods support OpenGL in the future?"
Unfortunately, the answer is NO. It's a lot of work to make them compatible with OpenGL because it's not anything like changing a few parameters from "false" to "true". Basically I would have to rework all models in the mod and that would take ages due to the mod's size. I'm simply not interested in doing that. From my point of view it would be just wasting my time because I am using only DirectX and my mods are already working perfectly with it.

So, I say no for OpenGL support. No need to continue crying about that. I know that's not a nice way to go here, but in my opinion it's not worth all the effort it takes.

MOD IS ONLY COMPATABLE WITH ETS2 1.26 OPEN BETA YOU WILL NEED TO UPDATE YOUR GAME
< >
300 Comments
Eddie Stobart no 1 6 hours ago 
@volchor do i have to close my game off the screen
ScaniaLAD1993  [author] 7 hours ago 
I am trying to fix some issues with the truck, the workshop uploader is a pain in the arse
Lone Wolf 9 hours ago 
I got my 1.28 version of this truck off the SCS forum page. The link was here for about a day. But of course it was removed, just not sure why.
vulchor 10 hours ago 
Also, just want to remind people here that the person who uploaded this ISN'T the mod author. RJL is the mod author.. You'd know that if you read the description. RJL updated this for the 1.28 open beta more than a week ago, that's why a lot of people were clamoring for the uploader to please ask RJL if he was allowed to upload the latest version. I wish people would do more reading before jumping down other people's throats, but that's not how the internet works unfortunately.
vulchor 10 hours ago 
You need to go into the Steam properties for ETS2, click the Beta tab and unsubscribe from the beta.
Eddie Stobart no 1 11 hours ago 
my open beta is still going what do i do to have the updated version non beta
Lone Wolf 11 hours ago 
Yes I have been driving it all day yesterday and I am not getting the updated Promods map.
Eddie Stobart no 1 12 hours ago 
so the updated full patch is now going 100 % ?
Lone Wolf 12 hours ago 
The Beta was done yesterday. So it is live now.
Eddie Stobart no 1 13 hours ago 
Stop asking to update wait for the end of the beta version of the 1.28 patch and scs bring the real version then ask him , just a REMINDER he WARNED he would pull the mod off steam just like RJL did respect the authors wishes and STOP NAGGING TO UPDATE THE @@@@@@@ MODS