Deadlock - Planetary Conquest

Deadlock - Planetary Conquest

Not enough ratings
Fix for Windows 8 and 10
By SinaCutie
This guide will help you run Deadlock in Windows 8 and 10 as well as let you save your game. I am actively looking for fixes to the issues mentioned in the comments.

Note: Windows 10 Pro is the only version of 10 that zooming and saving seem to work 100% on. However, I have also tested on the Home edition and it seems to work, too. If you use Windows 10 and can't zoom, please let me know so I can see if this is worth trying to fix. :8bitheart:
 
Rate  
Favorite
Favorited
Unfavorite
The PATCH
Navigate to the Deadlock folder. This is usually:
C:\Program Files (x86)\Steam\steamapps\common\Deadlock



Double-click on PATCH and open dlock131.zip, then copy the contents.



Copy the contents of PATCH into this folder. Replace the files in the destination.
The ISO
For making the ISO, we will use the portable version of CDBurnerXP (to avoid installing anything). You can download it from this link[cdburnerxp.se]. Make sure to download the "Portable version."

When it is downloaded, unzip it into it’s own folder. I usually make a “tmp” folder and unzip it in there.

After it is unzipped, go to where you unzipped it and run cdbxpp.exe and select your language:



Make sure “Data disc” is highlighted and press OK:



This window may look intimidating, but do not worry. Select everything in the Deadlock folder (ctrl+A is a fast way to do it) and drag it to the bottom left panel, like the image below:



Rename “Disc” to “DEADLOCK” (keep it in all caps):



Now on the top menu, click on “File” and then “Save compilation as ISO file…” and choose a destination. The default saves to your Documents folder.



Navigate to where you saved the ISO file and double-click it. This will mount the ISO.

As long as this is mounted, you can play Deadlock without any problems!



Please let me know if you have any problems!
< >
17 Comments
SinaCutie  [author] Oct 22, 2016 @ 6:12pm 
I wouldn't have thought that it would make much difference... That's a bummer. :(
PhunkyBrewster Oct 22, 2016 @ 5:07pm 
I bet it's the Pro that is making the dif. And no, without compat mode it crashes the moment you click in to your base. I spent a few hours playing around with all the settings originally.
SinaCutie  [author] Oct 22, 2016 @ 1:24pm 
Can you try to run the game without compatibility mode? I don't run the game with any compatibility mode.

I am able to zoom in and out fine, and can save and load just fine too.

My machine is:
Windows 10 Pro, build 1607
AMD R9 270x
AMD FX(tm)-8120 Eight-Core Processor (3.1GHz)
16GB RAM
SinaCutie  [author] Oct 19, 2016 @ 5:46pm 
Okay, that's the same series as mine.
PropKitty Oct 19, 2016 @ 5:04pm 
I have a AMD Radeon R9 200 series.
SinaCutie  [author] Oct 19, 2016 @ 4:30pm 
I'll double-check to see if I can. :)
PhunkyBrewster Oct 19, 2016 @ 8:43am 
I just checked and yah, I can't save either.
SinaCutie  [author] Oct 18, 2016 @ 6:36pm 
What graphics card do you have, PropKitty?
PropKitty Oct 18, 2016 @ 4:58pm 
I am having difficulty. It took neonscintillation's comment to get it to run without crashing when I tried to zoom in, but I cannot save the game. If I do save game, it opens the prompt but I can't actually enter in text to save the game. Has anyone seen a fix for this issue? (Run as Administrator, Windows 95/98 compatibility mode) If I run as Windows XP service pack 3, I can save the game... but I can't zoom in without crashing. Help, please! Thanks!
SinaCutie  [author] Oct 11, 2016 @ 5:39pm 
I am super glad to hear! :D