2,596 ratings
UI Overhaul 1080p Plus
File Size
0.422 MB
May 14, 2016 @ 2:32pm
Mar 15 @ 12:20pm
94 Change Notes ( view )

Subscribe to download
UI Overhaul 1080p Plus


Overhauls the UI to scale for 1080p resolution. Expands most windows to minimize the amount of scrolling needed while showing as much information as possible.


Lead Author : Dr. Maple
Original Author: Tyrus

  • Custom Ship Designer
  • Expanded Outliner
  • Ironman/Achievement Compatible

  • Ship Designer
  • Ouliner
  • Empire
  • Technology/Research
  • Situation Log
  • Policies and Edicts
  • Planet
  • Species
  • Species Mod
  • Leaders
  • Combat View
  • War Demands
  • Expansion Planner
  • Traditions
  • Contacts
  • Planets and Sectors
  • Factions

This mod is for use on 1920x1080 resolution or higher. If you're having issues with windows being unusable, your resolution might be set incorrectly in your in-game settings.

If you're having issues updating the mod or the mod says it's outdated
  1. Unsubscribe from the mod in the Workshop
  2. Navigate to (Documents\Paradox Interactive\Stellaris)
  3. Delete the "mods" and "workshop" folder. Warning: This will delete any mods you have uploaded yourself. Make sure to back them up!
  4. Resubscribe to the mod on the Workshop

Dark UI by ButtJunkie and Compatibility Patch with UI Overhaul 1080p
Legacy UI Overhaul 1080p for Stellaris 1.9

Popular Discussions View All (3)
7 hours ago
Dr. Maple
Mar 17 @ 1:00pm
PINNED: 2.0.2 Beta Patch
Dr. Maple
< >
Espek Mar 20 @ 12:02pm 
I can't use this mod. You rich people who have 1920x1080 resolution or higher and I don't have
Dr. Maple  [author] Mar 19 @ 5:13am 
There's a pinned post for the 2.0.2 Beta patch that requires the base UI Overhaul mod and the beta patch to use
AFK Mar 18 @ 11:08pm 
@Leng: Unhelpful.
@Eclipse: What other mod are you running that depends on this one?
Leng ☯ Mar 18 @ 11:02pm 
you may want to read the troubleshooting:steamfacepalm:
Eclipse Mar 18 @ 4:13am 
I have 1280x1024 display and that's kinda too square (5:4) for this mod, but I need this to run one of my other mod. Is there any way to, um, fix this or anything except buying new monitor? Maybe change resolution or something? It works almost fine but some elements of UI run into each other and make it uncomfortable.
Tom.025 Mar 17 @ 10:56pm 
I got the same thing with the Discovery tradition not being available "databank uplinks"
Trying the 2.02 beta

EDIT : Ok found the solution : Guys Mr Maple create a submod for the beta, check his other mod.

Thanks man !
Neopolitan Mar 17 @ 9:51pm 
Confirming both LarOmega and kelstr's reports, it happens to me too, Maple.
LAROmega Mar 16 @ 6:59pm 
Confirming @kelstr's report that the "databank uplinks" tradition on the bottom left of Discovery disappears when the mod is active. Tried clicking on it anyway, hoping it's just invisible, but no go.
SemiCharmed Mar 16 @ 1:40pm 
@Dr. Maple - PERFECT thanks :p
Peter34 Mar 16 @ 6:13am 
Thanks. I've had some trouble with the map mode icons, on my 1600x1200 display, just not enough to complain about it.