XCOM 2
2,662 ratings
Free Camera Rotation
 
Rate  
Favorite
Favorited
Unfavorite
File Size
Posted
Updated
0.351 MB
Feb 5, 2016 @ 1:40am
May 13, 2016 @ 4:48am
17 Change Notes ( view )

Subscribe to download
Free Camera Rotation

Subscribed
Unsubscribe
Description
Confirmed to work with WotC, for more info see below...

DESCRIPTION:
1. Sets default rotation angle to 45 degrees.
2. Enables free camera rotation while holding down Q and E keys (in analog mode, see hotkeys).
3. Enables free camera zoom while holding down T and G keys (in analog mode, see hotkeys).
4. Enables free camera mode controlled by mouse movement (Alt + mouse).
5. Allows to pitch camera with [ and ] keys.
6. Fully ini configurable.

DEFAULT KEY BINDINGS:
1. Alt + mouse - free camera mode.
2. Ctrl + F1 - reset camera to default view.
3. Ctrl + F2 - switch between free and fixed rotation/zoom.
4. Ctrl + F3 - toggle free camera.
5. [ and ] - pitch camera.

CONFIGURATION:
1. ini files are located under your [Path To Steam Library]\XCOM 2\XComGame\Mods\FreeCameraRotation\Config or [Path To Steam Library]\steamapps\workshop\content\268500\616359783\Config.
2. Key bindings: XComInput.ini.
3. Camera settings: XComTacticalInput_FreeCameraRotation.ini and XComCamera.ini.
4. Instructions and examples on key bindings: http://steamcommunity.com/workshop/filedetails/discussion/616359783/392183857632885222/
5. Instructions and examples on zoom settings: http://steamcommunity.com/workshop/filedetails/discussion/616359783/392183857632918975/
6. Resolving weird issues with mod not working/crashing the game: http://steamcommunity.com/workshop/filedetails/discussion/616359783/364041517008791228/

WotC:
I don't own the DLC myself, but here is some useful info from other players:
@Dingo:
Can also confirm this works fine with WotC. The only minor "incompatibility" is that the mod is flagged with a warning in the mod launcher.
@MysticalPotato:
Try a fresh install (unsubscribe to the mod first) and open up mygames/xcom2 (and the WoTC folder too) find engine.ini and delete all instances of "modclassoverrides", locate the workshop folder in your steam installation, "\steamapps\workshop\content\268500\616359783" delete the folder (the one ending in 783) then resubscribe to this mod. It worked for me

NOTE: mods do not disable achievements in XCOM2.

DISCLAIMER: I can't guarantee any of my mods are 100% bugs free, so use them at your own risk. I do play with all of them and I will release fixes or at least workarounds if bugs/problems are discovered.
Popular Discussions View All (8)
26
Feb 19, 2016 @ 4:09am
Resolving Missing Required Downloadable Content Issue
wasteland_ghost
18
Oct 20, 2016 @ 9:23am
Key bindings customization
wasteland_ghost
8
Jan 21, 2017 @ 10:16pm
Zoom customization
wasteland_ghost
< >
1,085 Comments
wasteland_ghost  [author] Jan 12 @ 10:05am 
@bohdan19891989 Cpuld be a conflict with another mod that changes camera/input, like LW toolbox.
Dragon32 Jan 11 @ 8:30am 
@bohdan19891989:
Did you do #6? And if this is for WoTC then the Config folder is:
Documents\My Games\XCOM2 War of the Chosen\XComGame\Config
bohdan19891989 Jan 10 @ 1:37pm 
I give up. Subscribed, checked to use the mod when launching the game, NONE OF DEFAULT KEY BINDINGS ARE WORKING...not even 45 degree is active, still 90 degree rotation.
read description through and through, did every step from configuration...
wasteland_ghost  [author] Dec 30, 2017 @ 6:33am 
Thanks, @BlueDevils47!
BlueDevils47 Dec 30, 2017 @ 4:02am 
Thank you so much for this. I've wanted a more functional camera forever, and you delivered. I noticed that this conflicted slighty with Gotcha Again, where the icons would not appear, but thanks to your wonderful instructions, I (a man with NO modding experience whatsoever) was able to switch the free camera mode trigger over to Right Alt, allowing both mods to run perfectly. I appreciate the time and effort you put into this mod.
QrazyQuarian Dec 16, 2017 @ 2:15am 
I'm having a similar issue in the WotC version of the game, where it flat out just doesn't work. It worked a little in the beginning, but now it's just totally 90 degree angles and the Alt button doesn't work. I'm not sure if it's my campaign or if it is conflicting with another mod. I don't have anything too fancy; just the ones everyone and their dog has like Evac All, plus a couple cosmetic ones like voice packs and such.

Interestingly enough, I'm also having issues with two other mods and I just now remembered: I downloaded an Alien Icon pack that has stopped working since WotC even though it's said to be compatible, my WotC version of Flank Preview Evolved doesn't work, and a health number rather than the little dots fails to show up. I think I'm going to just uninstall all my mods and do a fresh install on all the ones I really want to help clean things up, then resest my config settings.
SerenityNow Dec 1, 2017 @ 9:17pm 
it happened again. I didn't mess with any of the settings, but one thing did change: I played with the Templar hero for the first time. This may have been the reason why it did it earlier. I notice that not only this mod deactivated, but also other cosmetic mods. Something resets when you play with a new hero maybe and you have to reset your config when that happens.
SerenityNow Dec 1, 2017 @ 10:59am 
I probably made some small change to the settings, but it certainly wasn't mod related. I haven't had problems since and I'm about mid-campaign now, so it's probably nothing.
wasteland_ghost  [author] Dec 1, 2017 @ 8:08am 
Strange, I've never experienced this myself. Are you changing any settings mid campaign? Keys, video settings, anything? I'm not modding the game actively now, but I've heard there's some kind of in-game mod menu: not sure, but if it changes ini files, it can also cause this effect.