The Elder Scrolls V: Skyrim

The Elder Scrolls V: Skyrim

31 ratings
SkyUI - Troubleshooting
By snakster and 1 collaborators
Lists potential problems you may run into when using SkyUI and their solutions.
 
Rate  
Favorite
Favorited
Unfavorite
General issues
There are mods missing from the MCM list.

In general, it may take several seconds until all mods have registered at MCM, especially when starting a new game. If there are still mods missing, try running the repair script. Open the console and enter:
setStage SKI_ConfigManagerInstance 1
You may have to wait a few seconds for the configuration manager system to re-initialize.
There are dollar signs ($) in front of all words in the main menu and other places.

You may have accidentally deleted Data/Interface/Translate_<language>.txt.
To restore it, use Steam to verify the integrity of Skyrim's game-cache:
Steam → Library → Properties of Skyrim → Local files tab → Verify integrity of game cache.
There's an error message, reporting "SKYUI ERROR CODE X ...".

Follow the steps below for the corresponding error code.
Specific error codes
Error Code 1: The Skyrim Script Extender (SKSE) is not running...
Error Code 2: SKSE is outdated...
Error Code 3: SKSE scripts are outdated...

Different error causes, but the solution is the same: Install or re-install SKSE, either from http://skse.silverlock.org/, or directly from Steam.
Error Code 4: Your Papyrus INI settings are invalid...

One, or more, of your Papyrus INI variables are set to invalid values. There are several tweaking guides and INI generators out there that propagate setting these to out-of-range values. As a result, SkyUI or other event-based mods can start behaving erratically.

To fix this, open My Documents/My Games/Skyrim/Skyrim.ini with a text editor and reset the following values to their respective defaults
[Papyrus] iMinMemoryPageSize=128 iMaxMemoryPageSize=512 iMaxAllocatedMemoryBytes=76800
You may also have to reset these values in SkyrimCustom.ini, if it exists, which is in the same directory.
For details on the meaning of these settings, see http://www.creationkit.com/INI_Settings_(Papyrus)

Also, in case you think you know better: See these recommendations from a developer who implemented Papyrus.[forums.bethsoft.com]
Error Code 5: Incompatible menu file...

There's another mod that overrides a particular menu file SkyUI is using as well. You'll have to pick one of the two mods. If you want another mod to be able to override certain menu files of SkyUI while keeping the rest, you can disable these warning messages individually in the SkyUI configuration menu (Advanced page).
Error Code 6: Menu file version mismatch...

The versions of SkyUI scripts and interface files are not matching. This could happen if you manually extracted the SkyUI.bsa archive. Remove any loose SkyUI files from your data folder.
Error Code 7: SKSE scripts have been overwritten...

Either your SKSE scripts have actually been overwritten, then just re-install SKSE (see Error Code 1). Or, if that doesn't fix it, there's an INI setting that stops SKSE and mods in general from functioning. For some reason it may have been set. Verify the following INI setting is set to 1, not 0:
[Archive] bInvalidateOlderFiles=1
< >
81 Comments
doyleweldin Jan 12 @ 4:00am 
crashes after i use inv. but not fav. sorry not a relly good on the spot speller
Sether Nov 29, 2016 @ 2:08am 
Cannot craft with SKYUI. All crafting options are replaced with ??????? where 'Craft' or 'Select' should be. please help.
Mileszo (Bagel's Bagel) Nov 3, 2016 @ 11:03am 
I installed SkyUI and now non of the NPCs will react to me. I have tried deleting the mods and deleting and reinstalling skyrim but that hasn't worked.
Mr.Moseby Nov 2, 2016 @ 2:49pm 
Im experiencing a problem, when I have SkyUI Installed my game will randomly take screen shots at alarming rates untill I restart skyrim. Were it will proceed to happen again after about 5 minutes.
Mouse Oct 31, 2016 @ 11:10am 
I was missing installation steps! Steps 6 and on DO APPLY to steam installations as well as Nexus/Manual installations.

http://www.wikihow.com/Install-SKSE
Mouse Oct 31, 2016 @ 2:47am 
Getting Error Code 1. I verified files (1 reloaded), no effect, then reinstalled via Steam, also no effect.

I have tried launching the game by launching Skyrim and by launching SKSE, both with Error Code 1, $ in front of attributes, and long load time to open inventory menu. I've put SkyUI at the start and at the end of my mod list, in case load order was an issue.

Any suggestions? Have a missed a step in installation? (I didn't do anything besides install via steam.) Has anyone posted info on mods that are known to conflict with skyui?

I'll be testing mod disabling tomorrow; if any of them turn out to be the culprit, I'll post an update.
Churinn Oct 30, 2016 @ 7:57pm 
SKYUI can't find SKSE but I check the SKSE it's up to date so I dunno what the problem is please help.
pantherplayer74 Oct 18, 2016 @ 3:55pm 
im haveing a problem with the interface when i tell my follower to equip armor or a weapon i just end up taking it and im pressing the equip mode button
BlazeuvdeSpirit Oct 12, 2016 @ 6:49pm 
Hunterborn won't show up in my MCM. Frostfall does.
WE CALL THIS A DIFFICULITY TWEAK Oct 9, 2016 @ 2:04am 
I cant use the data files option in my launcher