163 ratings
Improved Fish - Complete
Rate  
Favorite
Favorited
Unfavorite
File Size
Posted
Updated
41.954 MB
Aug 23, 2013 @ 4:16pm
Sep 6, 2014 @ 8:58pm
2 Change Notes ( view )

Subscribe to download
Improved Fish - Complete

Subscribed
Unsubscribe
Description
REQUIRES USKP FROM SKYRIM NEXUS TO WORK

This is the NEW version of Improved Fish!!! It's compatible with many more mods now, seeing as the cabin and quests are NOT included in this version. Soon I will either discontinue the cabin/quests, or make a small separate mod for it.

Readme does not fit on here, to see change log and readme go to nexus and read please! :)
http://skyrim.nexusmods.com/mods/14320/?
86 Comments
< >
piles0216 Mar 8 @ 11:30am 
can you add new fish? i think, if you didnt already like bluegill and bulhead (Catfish) and sunfish and other like pike and trout and stuff. :D (Please Work) :riften:
Süsse Fäulnis Jan 10 @ 10:31am 
crash the game
Grey-Wolf Jack Dec 13, 2014 @ 7:07pm 
Yes, this mod causes me to crash now.. I totally love this mod too. Grr.

I went through all of my mods and its definitely this one. Hmmm.
xXthatshadowXx Nov 11, 2014 @ 2:10pm 
hey blitz this mod is not compadable with fishing in skyrim 1.00 can you make this mod compabile with fishing in skyrim please thanks
Extreme Anal Nov 1, 2014 @ 4:16pm 
Hello Blitz54 i used this mod all the time and i roleplay as a fisherman and love this mod but the lastest update has stoped working please stop the update or please fi it!
josp3 Oct 26, 2014 @ 9:39am 
crashes on start every time and with out modes
msconfig (mjo) Sep 30, 2014 @ 12:45pm 
no i just have the normal steam edition with steam mods only inkl. SkyUI with SKSE
xXthatshadowXx Sep 16, 2014 @ 5:39pm 
@blitz

can you give me a link for USKP on the steam workshop so i can download it please
xXthatshadowXx Sep 16, 2014 @ 5:36pm 
@blitz54

is that why is crashes after the bethasda logo i need USKP for it to work???
Blitz54  [author] Sep 16, 2014 @ 4:58pm 
@msconfig (mjo) Do you have USKP installed? My mod relies on it for the critter script they fixed, otherwise I'd keep getting complaints about log errors. I guess the last version didn't require it, I thought it did.