326 ratings
Civilizations of Warcraft - Kingdom of Stormwind
Rate  
Favorite
Favorited
Unfavorite
File Size:
Posted:
Updated:
1.573 MB
Jul 28, 2013 @ 10:44pm
Aug 15, 2013 @ 3:39am
13 change notes ( view )

Subscribe to download Civilizations of Warcraft - Kingdom of Stormwind

Subscribed
Unsubscribe
In 1 collection by Bamington
Civilizations of Warcraft
10 items
Description
UPDATING WILL BREAK YOUR SAVE GAME.

The Kingdom of Stormwind, led by King Varian Wrynn, as a playable Civilization! Requires 'Gods and Kings' and is compatible with 'Brave New World'

Stormwind has access to the Seventh Legion Cavalry, a Horseman replacement that is stronger, and gains a combat boost in enemy territory.

They can build the Keep, a stronger, quicker-to-build version of the Castle, allowing them to defend their cities more capably than their opposition.

Stormwind has the trait Leaders of the Alliance, which grants their Great Generals a higher bonus and allows them to produce Land and Sea military units 10% cheaper.

CivFanatics/Stand-Alone Download available soon, watch this space!

Part One of the Civilizations of Azeroth Collection!
177 Comments
< >
Induss Jun 30 @ 2:31pm 
Are you going to do the dwarves? just wondering.
Dan Dapper Raptor May 3 @ 3:34pm 
I haven't encountered this civ yet, but many other civs seem to be adopting the lion logo for the small logo. I had a similar problem with the Horde replacing Bismark's cross for Germany on small logos. A minor bug, but really confusing so I turned it off.
=AJSA= Giver of Will Mar 5 @ 6:44pm 
i subscribed to this mod and it does not show up but the other warcraft mods do and i tried to do the whole delete cache and all other mods come back but not this one?
Setrin-Skyheart Feb 15 @ 4:50pm 
For some reason, none of the WoW mods I downloaded are showing up, not even in the downloaded mods folder. Any suggestions on what might be happening?
Johnersss Nov 30, 2013 @ 5:00am 
Do these Mods replaces existing Civilizations or work alongside them?
qbacca Nov 22, 2013 @ 9:00pm 
Make it Vanilla yes do it
Moshcloud Nov 16, 2013 @ 8:15am 
Make it Vanilla
Swyoda Aug 26, 2013 @ 5:59pm 
yeah thanks that worked
Bamington  [author] Aug 25, 2013 @ 5:07pm 
Swyoda: Have you tried deleting your cache? Go to My Documents/My Games/Sid Meier's Civ 5/Cache and delete Civ5ModsCache. Also, try unsubbing from the mod, then going into the game, and subbing from the in-game 'Get Mods' menu.
Swyoda Aug 25, 2013 @ 11:11am 
Hey, i keep subscribing to Stormwind and Orcs but they dont appear in the mod screen of the game and they're not in the MODS folder. All the other Warcraft mods work fine, but not those two