759 ratings
The Mine of Malan Vael
Rate  
Favorite
Favorited
Unfavorite
File Size:
Posted:
Updated:
75.816 MB
Dec 31, 2012 @ 3:47am
May 15, 2013 @ 3:38am
1 change note ( view )

Subscribe to download The Mine of Malan Vael

Subscribed
Unsubscribe
Description
== The Mine of Malan Vael ==

Explore the mine of Malan Vael and unravel its sinister secret.

The Mine of Malan Vael is a complete Grimrock mod featuring a new tileset made from scratch.

ATTENTION: If you've started a game using v1.3 of the mod, then updated to 1.4 and didn't solve the 'serve the dinner' puzzle yet you have to start over. I'm sorry for that, but for technical reasons it's not possible to solve the puzzle anymore with that 'version mix'. Since it's less than 10% of the dungeon it shouldn't be much of a problem though I hope.


= Installation =

Put the .dat file into your dungeons folder (My Documents\Almost Human\Legend of Grimrock\Dungeons). Start the game and click on 'Custom Dungeon', then select 'The Mine of Malan Vael'.



= Gameplay Information =

This mod is complete and was extensively tested. Of course I can't promise it's 100% bug free, but it should be close (apart from some minor 'known issues', see below). There are 5 levels to explore and the average play time should be somewhere between 3 and 4 hours.

The overall combat difficulty of this mod is quite high and the good, old 'hit and strafe' tactic will often not work. If you thought the original game was challenging you may want to play this on easy difficulty on your first playthrough. I don't recommend playing on hard difficulty on your first playthrough at all. Some important things to keep in mind while playing:

1. Secret areas are important, if you miss too many and play on normal or hard difficulty it will be very hard to survive.

2. Food is not overabundant like in the original game. Don't eat when you don't have to (eg eating a large food item to bring a character from 75% to 100% food level is not a good idea) and don't sleep when you don't have to (if just one character is seriously hurt it may be a good idea to simply use a health potion instead).

3. You will often get ambushed, so don't walk into an unexplored area without preparation. Make sure your characters are on (almost) full health and energy, get healing potions and bombs ready for use. Running away IS an option.

4. Last but not least, save often. I tried to place healing crystals in places where they make sense and help, but you can't have a healing crystal everywhere.



= Known bugs and issues =

- Ballista string doesn't move. This is because I couldn't export the weight painted model correctly. As soon as a stable, fully functional export is possible I will fix this.

- iron doors opened don't show up on the statistics screen. This is a bug with the editor, iron doors aren't counted in custom dungeons



= Credits =

Akroma222 for writing the Intro text and correcting/improving the notes I've written (and for beta testing)

John Wordsworth for the Grimrock Model Toolkit and beta testing

Xanathar for the Animation Editor

Kuningas for the Molt and Cultist creatures

Wallasaurus for the 3ds max export script

Ixnatifual for the tome descriptions

The Grimrock modding community for helping whenever I had a scripting question (you know who you are...I hope)

Almost Human for making an awesome game


I'm sorry that not all of you appear in the in-game credits (namely Kuningas, Wallasaurus and Ixnatiful), but it was a bit complicated to set up and it would have taken too much time to add more names. It's just a joke anyway, simply consider yourself part of the 'Grimrock community'. :P



= Changelog =

v1.4:

- fixed bug (caused by an engine update) that would mess up the position of the emergency vent light in the contaminated area
- added a tiny bit more food (4 food items in total) and another sack
- put a snail slice in front of the not-so-secret button that opens the 'food chamber' close the 'serve the dinner' puzzle so it should be impossible to miss
- fixed bug where the level 5 axe was 'Norja' from the original game and not my custom 'Great Axe' entry with adjusted stats
- 'Serve the dinner' puzzle was adjusted so it's more obvious what to do, you only need 2 food items instead of 4 and it looks better now (no more stacking food on the same spot)

v1.3:

- fixed minor bug with pickaxe, in the inventory it would show a required axe skill of 0 (which is pointless)
- short bow now has a required missile weapons skill of 5 (instead of no requirement)
- fixed bug where you could shoot projectiles through the destructible wall in the boss room before destroying it
- made the 'from midnight to noon' puzzle easier by adding a hint
- made the 'pitfall' puzzle a bit easier by slightly increasing the time the trapdoors stay closed
- added a note in front of the gate in the chasm area on level 2 to make 100% sure the player notices the two pressure plates
- fixed bug where ogre couldn't reach a spot
- reduced number of steps in step sequence puzzle on level 4 from 25 to 19
- slightly improved visuals for step sequence puzzle on level 4
- placed ballista arrow in front of the ballista so you can't miss it anymore
- fixed 'known issue' where looping sound effects from level 4 could be heard on level 5 as well unless you reload (thanks to Batty for finding a better approach)

v1.2:

- fixed two typos
- ogre is now scripted to walk on the correct path, he will follow the player no matter what and not get confused due to AI behavior
- fixed a bug that made the game crash when you hastily clicked multiple times on the trigger of the ballista when shooting
- fixed bug that prevented you from placing items in front of alcoves that are facing east or west

v1.1:

- greatly reduced file size by removing unnecessary files from the dat file
- doors of first pressure plate puzzle will now stay open forever after the puzzle was solved, no matter what you do
- second secret room was moved, it's easier to find now (both the button and the room) and the snail will respawn more reliably in case you run out of food for the 'serve the dinner' puzzle
- Malik now explicitly mentions the use of frost bombs in the note that lies in front of the ogre room on level 3
- made the 'four times four' puzzle on level 4 easier by filling one alcove with appropriate items
- put another safety check into the ballista script to prevent any odd crashing issues



= Terms of Use =

The mine tileset is a modders resource. I only ask for three things if you want to mod with it:

1. Give credits.

2. Don't upload the source files package or the mod itself to other sites without permission.

3. Use the assets only in Grimrock mods and don't try to sell them.
302 Comments
< >
=[SK.Master]=Breno Jun 26 @ 12:13am 
Muito bom, adoro esse jogo, e esse mod é exelente, tem ótimos puzzles.
Corgi Jun 6 @ 11:36am 
Great mod except for timed puzzles which I found very frustrating. Otherwise worth trying out.
nic.snoeck May 20 @ 9:54am 
Bravo pour ce mod, de bonnes énigmes ! Aussi bien que l'original, je suis bluffé !
raixel May 17 @ 11:35am 
Just on a side note, time-test puzzles where the failure results in injury (pitfall) can make a game very difficult for those of us with physical disabilities which make it hard to move our guys quickly AND use the mouse to move or drop multiple items.

Coupled with a lack of food to prevent sleeping (with food it wouldnt be a problem, just take way more tries than the dev would have expected an average player to make), I think I'm kind of screwed here. Theres no way for me to get by.

Even if I restarted, the amount of food available doesnt really allow for the kind of attempt I'm going to have to make for a step and turn all over and drop multiple items type puzzle where injury results if you fail.

I figured out what I'm supposed to do, I just cant physically do it. And that is frustrating as hell.

Its a nice mod besides that though, if I had 2 fully working hands I'd love it.
phittte  [author] May 15 @ 11:09pm 
@Vitalix: Glad you like it. I'm planning to make another mod for Grimrock 2, which hopefully will be out soon.

@BearDownChicagoBearsHo: The button is the last tiny bug left. It opens the secret door that closed behind you when you entered the room, but there are two triggers that close the door. Now if you trigger one of them to close the door, press the button, and then trigger the other one the door will close, open and close again. Doh. Did that button quickly before I uploaded the final update and didn't feel to upload another version for such a minor inconvenience, sorry for that.

My intention was that you'd know what to do by looking at the name of the room and by looking at the map/thinking about the layout of the room, but I agree that it would have been better to give another hint. I think the secret door was a mistake, I should have used a gate instead so you could see there is another room you need to enter.

I may update the mod again, thanks for the feedback!
BearDownChicagoBearsHo May 15 @ 5:00pm 
What does the secret button in the mess hall looking room before pitfall and synchroncity do? I don't see any results from pressing it.

Also about the pitfall puzzle, I think it's a bit unclear because of the following: You should have the area to the right of the lone pressure plate also trigger the portals. That way I believe there is no way to put items on all 3 from the basement floor. I was just doing that in all possible combinations. Theres nothing besides the name 'pitfall' that would lead you to believe that you need to drop items from above, since you can simply place them from below, and you cant hear any gate opening noises or anything from below so you have no idea if what youre doing is working or not.

Im having a good time all together though!
Vitalix May 11 @ 11:37am 
Ah, and there it was. Awesome! I was eager to find a better weapon. Thanks for getting back so quickly. Now off to finish the mod.

Do you have any others planned?
phittte  [author] May 11 @ 12:37am 
@Vitalix: Thanks! If you put a red gem inside a secret door will open, IIRC it is the one with the scimitar inside. It's quite close so if you listen carefully you should be able to hear the door open.
Vitalix May 10 @ 7:46pm 
Excellent mod .. a fine balance between adventure and combat! A question:

I found an indentation on level 4 which you can put a red gem into. However, I can't see any effect that occurs. Is this a leftover from a removed puzzle or does it do something I'm not aware?
phittte  [author] Apr 22 @ 11:01pm 
Thanks for the comments!

@Nuntius: Thanks for the feedback, didn't know that. Not sure what I can do about it though as it is an engine problem. Maybe increasing the size of the pillar helps.

@Matoi Rhao: The timed puzzle only works with a framerate of (exactly) 30 or above. Sorry about that, but this is also an engine problem I can't prevent as the script timers are tied to the framerate (happens in the original game as well with timed puzzles). If your framerate drops to less than 30 (even 29) the gates won't stay open long enough to pass. Try to decrease your video settings as much as possible for this puzzle, it's the only timed puzzle in the dungeon so you can set it back to whatever settings you use afterwards and never have to worry about it again.