324 ratings
Multi-Parent / Unparent Tool
Rate  
Favorite
Favorited
Unfavorite
Type: Tool, Addon
Tags: Build
File Size:
Posted:
Updated:
0.003 MB
Dec 6, 2012 @ 2:13pm
Jun 9 @ 1:02pm
10 change notes ( view )

Subscribe to download Multi-Parent / Unparent Tool

Subscribed
Unsubscribe
In 1 collection by [GME] TweaK
Server shit
22 items
Description
A Multi-Parent tool with a few extra options and a functional reliable unparenting tool.

Multi-Parent features:
-Area select function - hold use + left click
-Contraption select function - hold shift + left click
-Added undo functionality
-Option to clear all constraints before parenting
-Option to create a no-collide or disable all collisions
-Option to create a weld to retain physics ("super parent" mode)
-Option to set weight to 0.1 before parenting
-Option to disable shadows (new!)

Multi-Unparent features:
-Uses a clientside trace to select entities so there are no problems with the trace passing through parented entities
34 Comments
< >
(C.O.N) ESR 4 hours ago 
It my spacebuild ships keep clipping through the ground when I parent. Any help?
[iG][CK]FrankHigh Aug 25 @ 8:06pm 
@DIAX You would have to check the setweight function. What you're doing is parenting the props to the chip with their original weight, then hanging it off a little chip simply welded to a base prop. This is most definitely you're problem. If not, lemme know more details and I or someone could help you more. Anyone else needs help with this or another of the same sort, shoot a F/R and a message. More than willing to help
ds2198 Aug 21 @ 5:16pm 
This addon works perfect DIAX... You're just not using it right ;)
DIAX Aug 2 @ 5:59pm 
Even parenting to a gate, all this does is fuck the props up. It makes them wobble around ridiculously and does not work like parenting should. Reporting this addon and uninstalling.
Moron Jul 26 @ 8:54am 
Every single time I spawn a parented contraption with advanced dupe 2, I get:


Error applying entity modifer, "mass". ERROR: lua/includes/extensions/table.lua:78: bad argument #1 to 'pairs' (table expected, got userdata)
Error applying entity modifer, "mass". ERROR: lua/includes/extensions/table.lua:78: bad argument #1 to 'pairs' (table expected, got userdata)

Works fine with advanced dupe 1, tried reinstalling advanced dupe 2 and it did nothing
|DG ADMIN| [IM] harry8030 Jul 22 @ 11:01am 
@[IM] KrypteK one thing i have to say \qzretrytguyhkkj2jewufdysthqjk;owegqtfvwdbjdhgyqkfdshbjdiwlgyehdsfkuqwfywevfkjskfdiufdgwureddwegfsb,jasbdf,jb,fb,uufefkfdsbbfabclbrlgfbfskdbf,kjabewfbkds.jbalbfleuflrygjkadskjhrfjwbfuydjfvhuwqbm
Moron Jul 9 @ 4:15am 
When I spawn my parented plane with advanced dupe 2, collisions are disabled, but when I spawn it with advanced dupe 1, they are enabled, really annoying
Sniper Kid Jun 26 @ 10:57am 
When i multiparent a model i made and uncheck everything or check some boxes, the model spazes out or just dissapears...
The Omen May 16 @ 12:30am 
Oh my fucking god this tool is a jaw dropper! FUCKING HELL THIS ROCKS! OMFG THANK YOU!!!!!!!!
[A2fs] Lolwood Feb 2 @ 10:11am 
Needs area unparent