Shadowrun: Hong Kong - Extended Edition

Shadowrun: Hong Kong - Extended Edition

54 ratings
Dead Man Switch - Vox Populi
 
Rate  
Favorite
Favorited
Unfavorite
File Size
Posted
Updated
122.753 MB
Jul 25 @ 9:41pm
Aug 18 @ 3:06pm
12 Change Notes ( view )

Subscribe to download
Dead Man Switch - Vox Populi

Subscribed
Unsubscribe
Description
In the urban sprawl of the Seattle metroplex, the search for a mysterious killer sets you on a trail that leads from the darkest slums to the city’s most powerful megacorps. You will need to tread carefully, enlist the aid of other runners, and master powerful forces of technology and magic in order to emerge from the shadows of Seattle unscathed.

An adaptation of the Original H.B.S. Dead Mans Switch Campaign.
Popular Discussions View All (4)
259
2 hours ago
PINNED: Bug List
L0g41n
41
Aug 20 @ 1:22pm
Technical Questions
L0g41n
6
Aug 20 @ 3:08pm
Difficulty- Too easy?
RaustBD
< >
155 Comments
wave.of.atla  [author] Aug 20 @ 4:56pm 
Yeah, I think it's in the wrong camera region because the fade in trigger is what moves the camera to your character after they're teleported.
Tibbnak Aug 20 @ 4:48pm 
It might be more than that though? If I press escape during the soft lock I can open the PDA, and the scene I was just at fades back in but is fogged up and there's no characters, the camera is unlocked and can be panned fine, but I can't click the arrow to go to character. It's more like the camera just doesn't go to the right spot.
wave.of.atla  [author] Aug 20 @ 4:37pm 
I think that's actually unrelated. There's a very short delay of .6 seconds built into the Fade In trigger. For whatever reason, that trigger is stuck at that delay point for you and will never fire again.

I don't know the cause in your case, but I can build a trigger to reset the Fade In system on reload that should prevent it happening in the future.
Tibbnak Aug 20 @ 4:34pm 
OK, after the second elevator it does give a red error message about being unable to find the steam overlay dll. Why would that even be required though?
Tibbnak Aug 20 @ 4:32pm 
I guess it seems like all the triggers work except for actually moving the camera over and unlocking it? It does it again for the next elevator after the conversation point down the hall.
I'm using the gog version if that makes any difference.
wave.of.atla  [author] Aug 20 @ 4:28pm 
I will definately add this to the bug list, and kick the tires a few more times. It uses the same triggers every time your character is teleported, so something must have killed the "fade in, clear focus" trigger after you arrived at the lab.

Wild.
Tibbnak Aug 20 @ 4:26pm 
Fixed it by unchecking camera pan in options and then rechecking. *shrug*
Tibbnak Aug 20 @ 4:25pm 
Yeah even after new load the camera is locked and can't be moved besides by moving your character around.
wave.of.atla  [author] Aug 20 @ 4:25pm 
I can't duplicate at the moment, but it sounds like the camera is not fading back in after teleport.
Tibbnak Aug 20 @ 4:23pm 
I was able to trigger a hard save with the debug menu, and then alt f4'd out, and then loaded it back up and continued and it placed me in the lab I was supposed to end up in.