448 ratings
Advanced Ball Socket Tool (Adv. Ballsocket)
Type: Tool, Addon
Tags: Build
File Size:
0.002 MB
Nov 8, 2012 @ 5:53am
May 10 @ 2:38pm
2 change notes ( view )
In 1 collection by [GME] TweaK
Server shit
22 items
An essential tool for any builder, previously included with gmod but was for some reason removed in the latest update. Allows you to limit the rotation of props.

An excellent video by 13igAdam2040 explaining how it works:
< >
Uszatek Oct 28 @ 5:16pm 
hello, it is a nice tool but the rotational constraint option causes the constraint to get wonky over time, I made a video on it, add me if you wish to discuss& investigate this some more
JamesDennison Sep 22 @ 9:59pm 
Yeah. Its is strange how that works. Though sometimes can be a headache, Lol.
[GME] TweaK  [author] Sep 22 @ 9:13pm 
Ah, the ole turn it off and back on trick. Good to know.
JamesDennison Sep 21 @ 9:14pm 
and might I add, still a great tool. Works wonders with complex builds :)
JamesDennison Sep 21 @ 9:12pm 
I didnt delete it per se', But im guessing the validations from steam were either overlooked while checking workshop files or something. So, I disabled then re-enabled the tool. worked for me afterwards.
[GME] TweaK  [author] Sep 21 @ 7:10pm 
Interesting... so did you just delete the gma and let it redownload? If that did it then perhaps it is an issue of steam not verifying the file or something. Glad to hear you got it figured out, anyway.
JamesDennison Sep 17 @ 7:22am 
actually, i discovered the issue. wasnt an addon conflict, as its fine. turns out somewhere down the line the .gma file was overwritten. the is "was" that the advanced aspect of the tool was more along the lines of basic when the settings were nowhere to be seen. other than that, the tool itself still worked, sorta. now that i've corrected the .gma all seems fine.
[GME] TweaK  [author] Sep 17 @ 2:18am 
What exactly IS the issue you are experiencing? Have you tried disabling all other addons to test it? "It worked fine before" does not rule out an addon conflict.
JamesDennison Sep 13 @ 8:37pm 
No, unfortunately it isnt due to an addon conlict, as every addon client and server side worked fine several months back, and still the same set up. As I'm being told, i am not the only one experiencing this issue, other servers are as well. Figured there was a sort of bug that may have worked its way in during the update recently.
[GME] TweaK  [author] Sep 13 @ 1:13am 
It should be working fine with the current update... unless there is something I am not aware of? if you are experiencing a blank context menu then that is due to an addon conflict