STEAM GROUP
Steam Universe Steam U
STEAM GROUP
Steam Universe Steam U
84,740
IN-GAME
261,772
ONLINE
Founded
September 23, 2013
All Discussions > Steam Controller > Topic Details
marx Oct 18, 2015 @ 8:40am
Major configuration issues on Ubuntu 14.04
I'm trying to play games with my Steam Controller on Ubuntu 14.04 with all the latest updates installed. I'm running in Big Picture Mode, and have created a file in /etc/udev/rules.d/ with the rules from this thread: http://steamcommunity.com/groups/steamuniverse/discussions/2/490123197947211023/
Connecting the controller works fine. Navigating Steam works fine, and all of the controls react correctly when viewing the controller's Support interface.

The problem I'm having is that no configurations appear to work. It seems that the left pad AND the left stick are being mapped as the Up/Down/Left/Right keys, while the right pad is being mapped to the mouse pointer. The right trigger is being mapped to Mouse 1, and it's not clear what the other buttons are being mapped as.

No matter what configuration I apply, whether template, custom or community, I can't change these mappings as I'd like.

I've tried playing Borderlands 2, Knights of the Old Republic 2, and Portal 2 (which I figured would be a safe bet), but the controls made it impossible.

Any help would be appreciated! I'm happy to provide any info that will debug the problem further.
< >
Showing 1-3 of 3 comments
marx Oct 18, 2015 @ 8:54am 
It appears that this is the mapping that's being applied:
Back - Tab
Forward - Escape
A - Space
B - E
X - R
Y - F
Left Pad Up/Down/Left/Right - Up/Down/Left/Right
Stick Up/Down/Left/Right - Up/Down/Left/Right
Right Pad - Mouse
Left bumper - Mouse wheel down
Right humper - Mouse Wheel Up
Left Trigger - Mouse 2
Right Trigger - Mouse 1
Left grip - Mouse 3
Right grip, Left pad click, right pad click, Stick click - None
Roland Gunner Oct 18, 2015 @ 6:27pm 
Do you have your Steam setting set to enable the Steam Overlay in games? That is required to enable mapping the controller.

Valve hasn't done a good job of making this clear for users.
marx Oct 19, 2015 @ 3:10am 
Roland, thank you! I had the overlay disabled, enabling it completely solves the problem.

If anyone from Valve sees this, it would be useful to have a notification similar to the one that tells you to switch to Big Picture Mode, telling you to enable the Overlay if you have it disabled.
< >
Showing 1-3 of 3 comments
Per page: 15 30 50

All Discussions > Steam Controller > Topic Details