STEAM GROUP
Steam Universe Steam U
STEAM GROUP
Steam Universe Steam U
67,107
IN-GAME
264,072
ONLINE
Founded
September 23, 2013
Virtualbox Install Tutorial
This seems complicated, but even if you aren't too experienced with Linux or VirtualBox-- this should only take 30-40 minutes tops, depending on how fast your computer is.

1.) Unzip contents of folder, SteamOSInstaller.zip
2.) ISO up the contents of folder, with same directory hierarchy.
Originally posted by Fred:

GNU/Linux
mkisofs -J -o SteamOSInstaller.iso SteamOSInstaller

OS X
hdiutil makehybrid -iso -joliet -o SteamOSInstaller.iso SteamOSInstaller

Windows
Use IsoCreator[sourceforge.net].
3.) Create debian64-bit virtual machine.
4.) Enable EFI in the settings for said virtual machine.
5.) Boot up the machine, and mount the install disk you created.
6.) Once booted type FS0:\EFI\BOOT\BOOTX640 into the "2.0 Shell>" prompt, and press enter.

you're going to have to sit at the "error: prefix is not set" thing for a minute before GRUB actually comes up.

7.) Follow the instructions here: http://steamcommunity.com/groups/steamuniverse/discussions/1/648814395741989999/ under "How do I install SteamOS" after "Pick "Automated Install" from the next menu."

8.) There are further instructions, courtesy of Fred:
Originally posted by Fred:
When you get to SteamOS GRUB, pick Recovery Mode. Once you are in the terminal session, type the following command to find all NVIDIA packages:
dpkg --get-selections | grep nvidia

Remove these packages with the command:
apt-get purge <name>

Then remove the NVIDIA configuration file:
rm /usr/share/X11/xorg.conf.d/55-nvidia.conf

Regenerate a new configuration file:
dpkg-reconfigure xserver-xorg

Mount the VirtualBox Guest Additions and then type:
mount /media/cdrom

Run the VirtualBox Guest Additions installer:
sh /media/cdrom/VBoxLinuxAdditions.run

Now reboot:
shutdown now -r
After you boot in, and login with "desktop" "desktop" or "steam" "steam", it may take some time for you to get to a desktop, be patient. Also I got in by logging in to "Default Xsession", and then loading up Big Picture mode.

For the particularly inattentive:
Originally posted by Widgetaah:
I've created a video of the steps outlined in this tutorial: http://www.youtube.com/watch?v=glTxRlT1RpM

I hate to ruin it by posting screenshots, so I won't.

There are some out there, but you should see it for yourself, it's pretty incredible.
Last edited by baaked the wall; Dec 14, 2013 @ 11:13am
< >
Showing 1-15 of 566 comments
baaked the wall Dec 13, 2013 @ 5:24pm 
Oh, addendum: you're going to have to sit at the "error: prefix is not set" thing for a minute before GRUB actually comes up.
Demodude123 Dec 13, 2013 @ 5:26pm 
Do you still need an nvidia card for this? I'm using amd.
baaked the wall Dec 13, 2013 @ 5:27pm 
It seems like this thing boots, but I can't type into any of the virtual terminals, typically indicating some kernel driver issues. Maybe it's not that, I'll just wait a little bit longer. THIS IS THE NEXT GENERATION!1!
Demodude123 Dec 13, 2013 @ 5:28pm 
Ill try it in vmware since you are doing virtualbox
McSetty Dec 13, 2013 @ 5:28pm 
How does this work? I thought ISOs were CDFS and EFI only supported FAT?
baaked the wall Dec 13, 2013 @ 5:31pm 
Looks like I can get into a terminal and view the filesystem by booting into recovery mode. :D
El Mariachi Dec 13, 2013 @ 5:32pm 
does this work with VMWare Player aswell?
heatsink_ Dec 13, 2013 @ 5:32pm 
Originally posted by McSetty:
How does this work? I thought ISOs were CDFS and EFI only supported FAT?
Depends on your motherboard. Most UEFI setups support most CD file systems, FAT and FAT32. Some support NTFS read only, shockingly.
NoXPhasma Dec 13, 2013 @ 5:37pm 
Installation works fine, but I get only a blackscreen on boot. I'm also unable to get any bootup text, no matter if I force it in the grub settings.
baaked the wall Dec 13, 2013 @ 5:40pm 
Yeah, that's where I'm at as well. I'm looking to see what drivers are failing in recovery dmesg. It seems like the fallback drivers that recovery uses work to control terminals. But need to roll Xorg back to some sort of generic.

Odd they claim this only supports nvidia when I'm pretty sure I saw the installer putting on fglrx, and I'm pretty sure fglrx is radeon.

also kind of lame they left the default debian grub background, you think they could come up with something steamier
Last edited by baaked the wall; Dec 13, 2013 @ 5:41pm
Phoenix Rising Dec 13, 2013 @ 5:43pm 
The Radeon graphics are there, but they're not as stable (if at all) as the Nvidia graphics. Probably because Nvidia was an active partner in this project:

"Added various third-party drivers and updated graphics stack (Intel and AMD graphics support still being worked on)"
Demodude123 Dec 13, 2013 @ 5:45pm 
Originally posted by Phoenix Rising:
The Radeon graphics are there, but they're not as stable (if at all) as the Nvidia graphics. Probably because Nvidia was an active partner in this project:

"Added various third-party drivers and updated graphics stack (Intel and AMD graphics support still being worked on)"
Ok, not having sucess with vmware, but that just may be my iso file. My intel laptop wont recognize the usb flash drive with a valid os.
baaked the wall Dec 13, 2013 @ 5:47pm 
Originally posted by Demodude123:
Ok, not having sucess with vmware, but that just may be my iso file. My intel laptop wont recognize the usb flash drive with a valid os.
You may need to verify that vmware support UEFI, and you have enabled support for it (it probably isn't default).
Demodude123 Dec 13, 2013 @ 5:48pm 
ok, my iso seems to work so far on virtualbox following the tutorial, so it cant be my iso file that's causing problems with the laptop.
McSetty Dec 13, 2013 @ 5:48pm 
hmmm I get to grub and get "error prefix is not set"... new one on me
< >
Showing 1-15 of 566 comments
Per page: 15 30 50

Date Posted: Dec 13, 2013 @ 5:21pm
Posts: 566