KeeperRL

KeeperRL

Alpha22 is available for testing (Windows only)

48 Rate up
Share
< >
15 Comments
SoftMonster May 13 @ 8:33am 
One good way to test a tutorial is to see what a child does. My daughter tried the tutorial.

Notes I made are:
1) She got attacked by a deer. Got the "keeper in trouble" question and stuck in control mode
2) Then left the "resources" menu open and selected a block of trees as storage instead of chopping them
3) Proceeded to dig out the wrong area but worked it out herself in the end
4) Wanted to click on the map behind the objectives box but could not
5) Got lost in the unexplored area of the map
6) Built a solid block of bookcases blocking herself in

This sort of thing is quite common when following a tutorial for the first time, but they can also be fixed.
SoftMonster May 13 @ 7:21am 
Another way to help Mr Noob. I think starters may scroll around on the map and lose where their keeper is located (get lost in the unexplored black area). On the objective to look around the map, perhaps introduce a new "k" command in God-eye mode to scroll back to the keeper immediately. This is also useful on low resolution laptops and zoomed in display, for any player.
SoftMonster May 13 @ 1:47am 
What happens when you try to follow these steps:

1) Select the Steam library
2) Right click on "KeeperRL" in the steam library
3) Select the "properties" menu item from the context menu that comes up
4) Select the "Betas tab"
5) On the Betas tab select the "dev - Alpha 22 testing" option from the betas drop down list
Spike Berd May 13 @ 1:14am 
I can't switch to the beta branch. Any reason as to why?
Jabislaw The Great May 12 @ 1:20pm 
OH YEAH, another update! (kind of)
SoftMonster May 12 @ 1:15pm 
You could minimise the tutorial objectives to look like this:

[Objectives]

So that you can see the map behind.

Clicking on that objectives button could normalise the objectives so you can see them again.
SoftMonster May 12 @ 1:00pm 
Out of ideas for now
SoftMonster May 12 @ 12:58pm 
Clicking on continue during the tutorial could close open menus (the menus listed below in my other post)
SoftMonster May 12 @ 12:52pm 
The compass could go to the mini map instead of the empty campaign map when in any single player game or tutorial.
SoftMonster May 12 @ 12:44pm 
There are probably lots of little ways to help Noob if he gets stuck.

1) The building menus already close when you click on a wrong tile. The buidling menus are:

a) Stucture (Fill up/Reinforce)
b) Floors (Wooden, Stone, Carpet selection)
c) Storage (Resources, equipment)
d) Training Room (Wooden, Iron, Steel)
e) Manufacturers (Workshop, Forge, Lab, Jeweler, Steel)
f) Installations (Many menu items)
g) Traps (Many menu items)

The tree square could be considered a wrong tile for storage until you have actually cut down the tree. The menu could just close if you try to store resources on a tree.

2) Doors could lock when you left click and when you right click. The tutorial advice could be to right click

Edit: The building menus already close for invalid squares. Trees are not really valid for storage space until the trees are cut down. In summary, it could just close the menu.

Edit: Lots of edits for this post because I want to be as clear as possible.