Tales of Maj'Eyal 1.2.0 aka "The Exercise of Vital Powers" is released!

45 Rate up
Share
19 Comments
< >
JOIN THE LODGE Jun 9 @ 6:32am 
You really smoothed out the game play somehow. Earlier, the game felt sluggish and laggy, which was a bit ridiculous on a strong gaming pc.

Feels far more enjoyable clicking around now. Great work.
Johnny Jun 8 @ 11:51am 
Thanks man! Great update! :)
DarkGod Jun 5 @ 5:40am 
Yes you simply click, download unzip the game somewhere and run it :)

Playing 1.2.0 will not have any effects on your 1.1.5 saves
anthracite Jun 4 @ 3:18pm 
DarkGod,

I greatly appreciate your response to my rant, and I apologize if it was excessive. At that moment it felt very "deja-vu" ish with my experience with Dredmor, and I was frustrated.

I will try what you suggested. Do I simply click the link and download it? Do I have to move anything (like save files) from a Steam folder to a new location? I am barely computer literate but can follow directions well.

Also, if I decide to start a new game under the new patch, does that have any consequences to my old save files that I still want to pursue?

Thank you again for your response.
Gargan Jun 4 @ 12:57pm 
If you right-click a game in library, then go to properties, betas, you can choose a specific version to update or return to, IF that particular version is marked as a beta branch. So you cannot return to any version you like, only to a version set by the game's creator. I made use of this feature to be able to continue my game in Crusader Kings II after the Rajas of India update.
DarkGod Jun 3 @ 5:02pm 
No idea why steam wont let you play without updating :/
But fear not my minion, you can simply download the 1.1.5 client from http://te4.org/download and finish your character :)
anthracite Jun 3 @ 4:28pm 
Is there no way to continue playing without updating? I know it was previously stated in the previous announcement (last Thursday) that the then-current save files would be incompatible, but I read in the comments from a person named "Havington" I think, that if you disable auto-update, which I did, then you can continue playing your old save file until you are ready to update.

Well right now, it is not letting me play unless I do a mandatory update. I find this very upsetting because I have never gotten as far as I am currently, and having no choice right now but to let it "die" from incompatibility issues as just as bad as losing a charactor in Dungeons of Dredmor from a game crash, which is why I stopped playing that game.
r. Jun 3 @ 3:42pm 
Thank you Based DarkGod.
Kiryusha Jun 3 @ 2:26pm 
Thank you!
BaNNshEy Jun 3 @ 12:48pm 
Praises be to DarkGod!