New update is out!

1 Rate up
Share
10 Comments
< >
Motoki May 11, 2014 @ 1:11pm 
"Please note: Game controllers are not yet supported."

That was on December 9, 2013. It's not over 5 months later. Just when is "yet" supposed to happen? I think it's shameful that you promise a feature on this game, abandon any updates and yet are now trying to put more games in through Greenlight, which you will in turn probably use for another quick cash grab and soon abandon them as well.
Gavener Apr 13, 2014 @ 4:15pm 
Yo any new updates ever ?
Cocky Apr 13, 2014 @ 11:56am 
I have the same problem KWorld mentioned. For some reason when messing around with the settings I put it on the lowest resolution and now I can't change it back because I can't see the option to save settings. Tried every solution I could. I remember when a simple uninstall/reinstall would fix any problem.
Wroth Apr 12, 2014 @ 8:29pm 
I am also very much looking forward to controller support
Nasra Apr 1, 2014 @ 3:13pm 
I have same problem :
I still have a problem with menu. After clicking on [Play] in main menu.

My System : Elementary OS Luna (12.04 Based), Nvidia 331, 650 Ti
S.W.A.T.™ Apr 1, 2014 @ 1:30pm 
Looking forward to controller support!
GOKUPP[Event Host] Jan 27, 2014 @ 7:59pm 
I just got Ravensword with the Indie Gala Bundle. The game seems promising. I however can NOT play it do to lack of control pad support. I can NOT use WASD layout its a physical limitation for me rather than an actual flaw with the game. Pad emulators are flakey and un reliable for me. thus making this very nice looking game unplayable for me. An update with Full pad support would be very greatly welcomed.
Tidusrose Dec 10, 2013 @ 6:48am 
Same problem than croco :
I still have a problem with menu. Nothing appears after clicking "Play" in main menu. No buttons on screen.

My system : Linux Mint 16 - Nvidia 331 driver - GTX 670 or Intel HD
Crocodile Croco Dec 10, 2013 @ 2:02am 
I still have a problem with menu. After clicking on [Play] in main menu, A misty mountain scene will appear, but I can do nothing. There is no buttons on screen. Please help. My system: ubuntu 12.04, linux, nvidia 319 drivers.
Handsome Manny Pardo Dec 9, 2013 @ 11:48am 
There is also a bug where if you have the launcher in windowed and you have it set on the smallest resolution the back/save settings button isn't visible or accessible meaning that it gets stuck like that.