Valve Anti Cheat. HELP!
Ok so when I try to play on Team Fortress 2, after about 10 minutes of gameplay I will get kicked from the server with the message Something on your computer is blocking the vac system. You cannot play on vac servers.. (no really there are 2 periods). valve says to enable DEP. which i did. It didn't help. it also says to repair steam service. Didn't help. Then it says that its another program running thats interfering. I make sure nothing else is on when I play. I dont know what to do. Please help!
Showing 1-15 of 19 comments
< >
Caps Jul 8 @ 9:05pm 
From Steam Support:

Enable DEP
Data Execution Prevention (DEP) must be enabled to play on VAC secured servers. To restore DEP settings to default please follow the steps below:
Exit Steam.
Click the Start button, then 'All Programs', and 'Accessories'
Right-click on Command Prompt and click "Run as administrator..."

- Please note if you are running Windows 8 you will need to press Windows Key + X and select Command Prompt (Admin)

In the command prompt, type the following command and press Enter:

bcdedit.exe /deletevalue nx

Restart your computer.
Launch Steam and test the issue again.
Restart your computer
If this is a problem for you on all servers then you can try fixing this problem by exiting Steam and restarting your computer.
Repair the Steam Service
This may also indicate a Steam Service failure. Please try repairing the Steam Service:
Exit Steam.
Click Start > Run (Windows Key + R)
Type the following command:

"C:\Program Files (x86)\Steam\bin\SteamService.exe" /repair

(If you have installed Steam to another path, please replace C:\Program Files (x86)\Steam with the correct path.)

This command requires administrator privileges and may take a few minutes.
Launch Steam and test the issue again.
Conflicting Software
This issue can be caused by third party software interfering with your game or Steam. Please restart your computer, then launch Steam and the game without running any other third party software.
If you read what I had typed out, you would now that I have already tried all of these. Do you have any other suggestions?
Caps Jul 8 @ 9:13pm 
Originally posted by Breezy Strings ۩≈PoF≈۩:
If you read what I had typed out, you would now that I have already tried all of these. Do you have any other suggestions?

Just out of curiosity have you made sure that you did all that it asked?
Yes each and every thing. (sorry if I sounded rude in that last post)
Caps Jul 8 @ 9:22pm 
Originally posted by Breezy Strings ۩≈PoF≈۩:
Yes each and every thing. (sorry if I sounded rude in that last post)

Thats fine, but anyway try restarting your router see if that works at all
Last edited by Caps; Jul 8 @ 9:22pm
umm... you see, its not exactly my internet. the neighbors are letting me use theirs.
Caps Jul 8 @ 9:32pm 
Originally posted by Breezy Strings ۩≈PoF≈۩:
umm... you see, its not exactly my internet. the neighbors are letting me use theirs.

Try going to your libary > Right click on any game that has this problem > Properties > Local Files tab > Verify integrity of game cache
Profile Jul 9 @ 1:36am 
I accept that you claim nothing else is running, but it's relevant and important that you are certain of all the possible things that might be a factor.

What are you using in terms of secuirty software such as Anti-Virus/Firewall any "Registry/Sysstem Cleaner" type software (i.e. CCleaner)

Do you use any "Booster" software or "Downloader" clients?

That you are presumably using a WiFi connection from your neighbours is fine - that shouldn't affect anything since you are clearly (by posting here) able to connect to the internet at least.

You might check with your neighbours that ports are open, however - Are you able to play other Steam games online okay? Do your neighbourrs use Steam?
Jokimoto Jul 9 @ 7:28am 
Originally posted by Breezy Strings ۩≈PoF≈۩:
umm... you see, its not exactly my internet. the neighbors are letting me use theirs.

Gotta ask, given the fishy way (imo) you wrote that: Are the neighbors actually aware that you're using their internet? Or are you, maybe, I dunno, sort of kinda just dipping into an unprotected wifi network? Just a thought.

Anyway if it's the latter, like I suspect, then no one can help you. Except maybe the neighbors. I know I'd be perfectly willing to help the stranger who's been leeching off my wifi. They'll probably offer to let you configure their router yourself, just to save you time and aggravation in the future.

Of course if you're not a leech then ignore everything I just said.
I use Avast Antivirus. The neighbors are aware of the fact that I use there internet. (Its password protected) Every other game I own plays online just fine. The neighbors do not own steam. As for download clients, II have none on this computer. I dont know what a booster client is. Although I have Hamachi Always running. Could that interfear with VAC?
Dixie Flatline Jul 9 @ 2:47pm 
Avast is listed as a program which may potentially interfere with Steam.
https://support.steampowered.com/kb_article.php?ref=9828-SFLZ-9289

I do not recommend ever disabling antivirus software, it's basd paractice for anyone to do so, however, you may find that allowing Steam / csgo processes as exceptions to any heauristic checking etc. that Avast! doews might be of use.

Hamchi as in VPN? This may also be problematic.
ReBoot Jul 9 @ 3:05pm 
Originally posted by Companion Cube:
I do not recommend ever disabling antivirus software, it's basd paractice for anyone to do so
Not always. Disabling it to test if it actually causes the trouble without downloading anything while it's disabled is perfectly safe.
I verified integrity of game cache. It didnt help. I will try dissabling Hamchi and avast to test it out.
I dissabled Hamachi and Avast. didnt help.
Dixie Flatline Jul 10 @ 5:28am 
Originally posted by ReBoot:
Not always. Disabling it to test if it actually causes the trouble without downloading anything while it's disabled is perfectly safe.
Depending on the expertise of the end user, "not downloading anything" is easier said than done.




Originally posted by Breezy Strings ۩≈PoF≈۩:
I dissabled Hamachi and Avast. didnt help.

Did you reboot the computer, re-validate cache files and reset DEP, then re-set network adapters after this, then try again?
Showing 1-15 of 19 comments
< >
Per page: 15 30 50
Date Posted: Jul 8 @ 9:02pm
Posts: 19