Squally Jul 8, 2014 @ 9:02pm
Valve Anti Cheat. HELP!
Ok so when I try to play on Team Fortress 2, after about 10 minutes of gameplay I will get kicked from the server with the message Something on your computer is blocking the vac system. You cannot play on vac servers.. (no really there are 2 periods). valve says to enable DEP. which i did. It didn't help. it also says to repair steam service. Didn't help. Then it says that its another program running thats interfering. I make sure nothing else is on when I play. I dont know what to do. Please help!
< >
Showing 1-14 of 14 comments
Caps Jul 8, 2014 @ 9:05pm 
From Steam Support:

Enable DEP
Data Execution Prevention (DEP) must be enabled to play on VAC secured servers. To restore DEP settings to default please follow the steps below:
Exit Steam.
Click the Start button, then 'All Programs', and 'Accessories'
Right-click on Command Prompt and click "Run as administrator..."

- Please note if you are running Windows 8 you will need to press Windows Key + X and select Command Prompt (Admin)

In the command prompt, type the following command and press Enter:

bcdedit.exe /deletevalue nx

Restart your computer.
Launch Steam and test the issue again.
Restart your computer
If this is a problem for you on all servers then you can try fixing this problem by exiting Steam and restarting your computer.
Repair the Steam Service
This may also indicate a Steam Service failure. Please try repairing the Steam Service:
Exit Steam.
Click Start > Run (Windows Key + R)
Type the following command:

"C:\Program Files (x86)\Steam\bin\SteamService.exe" /repair

(If you have installed Steam to another path, please replace C:\Program Files (x86)\Steam with the correct path.)

This command requires administrator privileges and may take a few minutes.
Launch Steam and test the issue again.
Conflicting Software
This issue can be caused by third party software interfering with your game or Steam. Please restart your computer, then launch Steam and the game without running any other third party software.
Squally Jul 8, 2014 @ 9:09pm 
If you read what I had typed out, you would now that I have already tried all of these. Do you have any other suggestions?
Caps Jul 8, 2014 @ 9:13pm 
Originally posted by Breezy Strings ۩≈PoF≈۩:
If you read what I had typed out, you would now that I have already tried all of these. Do you have any other suggestions?

Just out of curiosity have you made sure that you did all that it asked?
Squally Jul 8, 2014 @ 9:17pm 
Yes each and every thing. (sorry if I sounded rude in that last post)
Caps Jul 8, 2014 @ 9:22pm 
Originally posted by Breezy Strings ۩≈PoF≈۩:
Yes each and every thing. (sorry if I sounded rude in that last post)

Thats fine, but anyway try restarting your router see if that works at all
Last edited by Caps; Jul 8, 2014 @ 9:22pm
Squally Jul 8, 2014 @ 9:27pm 
umm... you see, its not exactly my internet. the neighbors are letting me use theirs.
Caps Jul 8, 2014 @ 9:32pm 
Originally posted by Breezy Strings ۩≈PoF≈۩:
umm... you see, its not exactly my internet. the neighbors are letting me use theirs.

Try going to your libary > Right click on any game that has this problem > Properties > Local Files tab > Verify integrity of game cache
Squally Jul 9, 2014 @ 1:04pm 
I use Avast Antivirus. The neighbors are aware of the fact that I use there internet. (Its password protected) Every other game I own plays online just fine. The neighbors do not own steam. As for download clients, II have none on this computer. I dont know what a booster client is. Although I have Hamachi Always running. Could that interfear with VAC?
ReBoot Jul 9, 2014 @ 3:05pm 
Originally posted by Companion Cube:
I do not recommend ever disabling antivirus software, it's basd paractice for anyone to do so
Not always. Disabling it to test if it actually causes the trouble without downloading anything while it's disabled is perfectly safe.
Squally Jul 9, 2014 @ 3:21pm 
I verified integrity of game cache. It didnt help. I will try dissabling Hamchi and avast to test it out.
Squally Jul 9, 2014 @ 4:03pm 
I dissabled Hamachi and Avast. didnt help.
Squally Jul 10, 2014 @ 2:37pm 
Ok I found out it WAS Avast. when i said I disabled it before I just opend hamachi and disabled shields. what I had to do was go into task manager and end the service. thank you for your help!
zeroxxx Jul 10, 2014 @ 8:58pm 
Haha Avast again. I'd never use that darned AV.
Squally Jul 13, 2014 @ 4:35pm 
Okay I tried playing TF2 again, and the problem has returned. any sugestions? (I dont know if this has any relevence at all, but I noticed the huntsmen is glitched as well)
< >
Showing 1-14 of 14 comments
Per page: 15 30 50

Date Posted: Jul 8, 2014 @ 9:02pm
Posts: 14