Thaek Sep 25, 2013 @ 11:06am
Steam Hardware Enthusiast Badge: Controller & Big Picture
I can't get the "Steam Hardware Enthusiast Badge" because the "Launch and play a game using a gamepad in Big Picture mode" is not attainable for me. I tried playing "Payday 2" using my Xbox 360 wired controller. But the badge is still locked. Anyone else having problems?
Showing 1-15 of 122 comments
< >
jwiv Sep 25, 2013 @ 11:07am 
It may just take some time for it to update? Not entirely sure.
Chris Sep 25, 2013 @ 11:07am 
Nope I just launched a game in pib picture with xbox 360 wired controller and works perfect
Chris Sep 25, 2013 @ 11:07am 
was instant, I played the game fo a few minutes but the badge appeared instantly.
Mr. Barnacle Sep 25, 2013 @ 11:11am 
Hmm... can't get mine to work.
Thaek Sep 25, 2013 @ 11:17am 
Here is what I did: (Several times..)
1) Connected XBox 360 Controller to PC
2) Launched Steam using my Keyboard/Mouse
3) Switched to Big Picture Mode using Keyboard/Mouse
4) Used XBox 360 Wired Controller to start Payday 2 which has full gamepad support
5) Played for several minutes
6) Quit game/steam using gamepad

Still no badge. Can someone that was able to get the badge explain if they did anything different?
Termite Sep 25, 2013 @ 11:18am 
bump! i hope they can work this out! i wanna steam box :D
Chris Sep 25, 2013 @ 11:21am 
Try to restart your system restart steam, try another game, does the controller appear in your devices? which OS do you have?
Last edited by Chris; Sep 25, 2013 @ 11:25am
Henri Des Sep 25, 2013 @ 11:23am 
Gonna have to buy a controller :(
Rex Kwon Do Sep 25, 2013 @ 11:25am 
I played a game using the controller in Big Picture almost a year ago and I have a community profile and neither task is showing as being completed.
Chris Sep 25, 2013 @ 11:26am 
Don't bother there was 21k beta entrants when I joined and they will only pick 300. Chances are slim to none. 30 of those are special entrants.
Last edited by Chris; Sep 25, 2013 @ 11:26am
RayeGunn Sep 25, 2013 @ 11:27am 
I got it with Tomb Raider and a Xbox 360 controller... As others have said, using a controller in a game is not enough, you have to do it from Big Picture mode. If you're on a monitor, it's ok, it still works. Wworked for me, didn't feel like going to the livingroom :p
xXalexcordelXx Sep 25, 2013 @ 11:29am 
I had to do exactly what you did to get it for mine. I also played Just Cause 2 to get it. It was buggy for me for a while though. I also had a play a mission or two before it was unlocked.
Last edited by xXalexcordelXx; Sep 25, 2013 @ 11:30am
Tim (ง'̀-'́)ง Sep 25, 2013 @ 11:35am 
Try playing a game that has the controller support icon. All I did was plug in my DualShock 3 (PS3) controller with MotionJoy drivers running, started big picture mode, started JC2, quit JC2 and quit big picture.
Thaek Sep 25, 2013 @ 11:36am 
Solved: Steam required a SECOND update. (Steam updated itself when i started it therefore i assumed it was up-to-date. But now after a few hours online a second update appeared) Try updating your steam client if you are having problems.
ikkew Sep 25, 2013 @ 11:53am 
Doesn't work for me to.. i use the gamepad and it gives a popup about my gamepad in steam, but not badge progression
Showing 1-15 of 122 comments
< >
Per page: 15 30 50
Date Posted: Sep 25, 2013 @ 11:06am
Posts: 122