Howl at the Moon (Banned) Aug 14 @ 7:19am
Игры на движке Unity - как в них играть без лагов? [Решено]
Конфигурация ноутбука
Intel Core i7-4900MQ
nVIDIA GeForce GTX 780M
RAM 32 GB
HDD RAID0 2xWD Black 750Gb

Мощное железо? Даже более чем. CoD Ghost с настройками ближе к максимальным, FarCry3, Crysis3 и прочее-прочее ресурсоёмкое - всё тип-топ.

Windows 8.1 SL Eng со всеми обновлениями
nVIDIA Driver version 331.65
Все системные библиотеки - DirectX, VCRedist, PhysX - установлены и обновлены.

ПРОБЛЕМА:
Квесты на движке Unity (Anna Extended Edition, Huntsman The Orphanage, Doorways, The Tower) безбожно тормозят. Когда начинаются какие-то эффекты (горит огонь, вспышки, взрывы и тому подобное) - лаги просто катастрофические (на глаз - 1-2 fps), играть просто невозможно, всё превращается в слайдшоу.

Фоновых процессов минимум, антивирус отключён, все настройки графики в играх пробовал ставить на самый минимум - на самый минимум, результат тот же. Всякие шаманства в настройках nVidia пробовал, режимы совместимости - результат отрицательный.
Движок хоть и ресурсоёмкий, но на таком железе эти игры должны летать аки ракеты (собственно все игры и летают кроме тех что на Unity).

Какие настройки системы, драйверов... могут вызывать лаги в упомянутых выше играх?

====================================

РЕШЕНИЕ
Игры на этом движке (в отличие от большинства других игр и программ) не могут автоматически повышать частоту процессора при выставленном в системе энергосберегающем режиме.
В Win8 настройки:
Control Panel\All Control Panel Items\Power Options\Edit Plan Settings
Processor power management - Minimum processor state - и тут нужно вручную выставить в процентах значение минимальной частоты процессора. 1500 Мгц вполне достаточно для игры.
Last edited by Howl at the Moon; Aug 15 @ 3:15am
Showing 1-10 of 10 comments
< >
Emitedoroom(RUS) Aug 14 @ 8:04am 
Иногда проблемы проявляются в противоположном случае - из-за относительно или через чур мощного железа, под которым запускаются старые игры. Имеет ли это отношение к юнити - не знаю.
Howl at the Moon (Banned) Aug 14 @ 8:36am 
Так игры - не старые (год от силы, The Tower вообще на стадии разработки), конфигурация ноутбука - тоже годичной давности (в продаже появился прошлым летом).
Попробовал обновлять драйвера на nVidia - результат тот же. Отключал SetPoint и всё прочее что висит в процессах - то же самое.
Попробовал на интегрированной в процессор интеловской видеокарте - результат во время эффектов целом тот же (и за счёт слабой видеокарты игра в целом сама по себе чуток подтормаживает).
Howl at the Moon (Banned) Aug 14 @ 8:37am 
Попробовал откусить 24 гига оперативки под виртуальный диск (чтобы игре не казалось что памяти много) - тоже не помогло.
Howl at the Moon (Banned) Aug 14 @ 2:49pm 
Я таки нашёл в чём загвоздка.
Ключевое слово было - "ноутбук".
Всё дело в том, что у меня в настройках электропитания выставлена возможность автоматического перехода процессора в энергосберегающий режим работы (частота понижается до 800 Мгц) когда нет задач (тем более лето, жара, - нефиг ему на полную мощность шпарить всё время). Когда запускается какая-нибудь ресурсоёмкая задача (или игра) - частота автоматически повышается. Вполне обыденная ситуация.
Почему частота не повышается при запуске упомянутых игр - тайна великая есть, скорее всего так как игры на одном движке - то причина в кривизне движка.
Secundo Aug 14 @ 2:54pm 
Originally posted by Howl at the Moon:
Я таки нашёл в чём загвоздка. :sniperbrain: :sniperbrain: :sniperbrain:
Ключевое слово было - "ноутбук".
Всё дело в том, что у меня в настройках электропитания выставлена возможность автоматического перехода процессора в энергосберегающий режим работы (частота понижается до 800 Мгц) когда нет задач (тем более лето, жара, - нефиг ему на полную мощность шпарить всё время). Когда запускается какая-нибудь ресурсоёмкая задача (или игра) - частота автоматически повышается. Вполне обыденная ситуация.
Почему частота не повышается при запуске упомянутых игр - тайна великая есть, скорее всего так как игры на одном движке - то причина в кривизне движка.
Это switchable graphics по-моему... У меня по умолчанию все игры сначала в power saving режиме запускаются: комп матерится, мол не потяну такое! Ан нет, ставлю high performance - и вот Thief на максе летает.
Howl at the Moon (Banned) Aug 14 @ 3:23pm 
Secundo
Нет, не не в графике дело (потому что запускаю именно с GeForce-видеокарты, а интеловская в это время отключена), а в настройках энергосбережения процессора.

В Win8 вот тут эти настройки:
Control Panel\All Control Panel Items\Power Options\Edit Plan Settings
Processor power management - Minimum processor state - и тут можно выставить в процентах.
У меня стояло минимальное значение - 5% (процессор работал на минимально возможной частоте 800 МГц). Выставил минимум 50%, процессор стал работать на 1500 МГц, теперь никаких лагов и подтормаживаний нет.
Secundo Aug 14 @ 3:44pm 
Howl at the Moon
А, даже так. У меня только вышеописанная загогулина. Не знал.
Molodec Aug 14 @ 4:45pm 
"CoD Ghost с настройками ближе к максимальным" - проиграл

А так, я тебя понимаю, сам сотню раз говорил, что этот движок убожество
/Nightcore/ -Dem2n- Aug 14 @ 6:54pm 
1) проверь нет ли висящих процессов жрущих ресурсы
2) если в ноутбуке 2 видеокарты переключи на игровую
3) проверь антивирусом
4) если проблемы именно с юнити попробуй переустановить драйвера которые идут вместе с играми на юнити
Howl at the Moon (Banned) Aug 15 @ 3:13am 
/Nightcore/ -Dem2n-
В теме помимо первого сообщения есть ещё и другие (их немного в целом), в которых и указано решение проблемы
Добавил решение в первый пост и заголовок.
Last edited by Howl at the Moon; Aug 15 @ 3:15am
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Aug 14 @ 7:19am
Posts: 10