scavy2009 Sep 11, 2013 @ 2:37am
Video don't play - steam client - greenlight only
Hi All,

Has anyone else had this issue? When looking at games outside of Greenlight, I can watch the videos with no issues. However, once I access the Greenlight section of games and try to watch a video, I only get sound. If I open a browser (Safari) and look at the games, the video plays fine. It's just the steam client for me and just this one area where I have issues. Any thoughts?

Running OS X 10.8.4 on a newer iMac with an NVIDIA GeForce GTX 680MX 2048 MB.

Thanks,
Showing 1-6 of 6 comments
< >
brocksta Sep 11, 2013 @ 7:12pm 
I also have this problem. On 10.8.4 also.
= ^ . ^ = Sep 12, 2013 @ 10:39am 
Im on Late 2012 mac mini 10.8.4, videos dont always play and trying to fullscreen the ones that do results in crashing the steam client, only had this issue after accepting the latest update, this problem occurs on multipul videos as well
Dr. Piranha Sep 15, 2013 @ 6:28pm 
I'm also having these issues. The community videos don't show up, but their audio plays. Also when exiting a full screen video from the store the steam client will crash.

Mac OSX 10.8.4
Last edited by Dr. Piranha; Sep 15, 2013 @ 6:28pm
JeffAD Oct 18, 2013 @ 1:34pm 
I have the same problem no video, only sound in the client. Was there a fix?
MAC OSX 10.6.8
CoreDude98 Jan 9 @ 7:41pm 
Same problem >.< 10.9.1 OSX Mavericks.
JeffAD Feb 27 @ 11:58am 
Working now..something needed updated. Hadent logged in for 3 months.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Sep 11, 2013 @ 2:37am
Posts: 6