Justin Jul 12, 2013 @ 3:51pm
Having trouble running some games?
The current release of the Steam client has a bug which is preventing some games to fail to launch, including Bastion, Bleed, DLC Quest, and SpaceChem.

EDIT: Unfortunately, issues are still ongoing with GTA3 and GTA: San Andreas. We are aware of the issues, have a good idea what's going on, and are working with Rockstar to resolve the issues with these games.

EDIT2: GTA3 and GTA: San Andreas have been fixed now.

We have pushed a fix for this issue to the Steam client beta, and we are hoping to release it to everyone soon.

To opt into the Steam beta, select Steam -> Preferences… from the Mac OS X menu bar.
Click on the “Change…” button in the “Beta participation” section, and then select “Steam Beta Update” from the dropdown.
Once you’ve clicked “OK” to accept the change, Steam will download and apply the beta.

If you find problems with the client beta, please post to http://steamcommunity.com/groups/SteamClientBeta
Last edited by Justin; Jul 16, 2013 @ 6:53pm
Showing 1-15 of 20 comments
< >
m.j.sm Jul 12, 2013 @ 8:51pm 
Thanks, opted in to the Steam client beta, downloaded an update and... same error as before on San Andreas.
crim.warly Jul 13, 2013 @ 4:41am 
Bqstion dont run in my mac :(
Lurifax Jul 13, 2013 @ 4:12pm 
Gmod doesn't launch for me D:
Mimichantress Jul 14, 2013 @ 12:51pm 
:D
Lurifax Jul 14, 2013 @ 12:58pm 
Gmod works now for me, dunno why
awsomekiller222 Jul 14, 2013 @ 2:01pm 
On Hard Rain I cant enter it says Server restricts model/infect/spitter
MrFlipgraf Jul 14, 2013 @ 10:23pm 
Not with games, but my problem is very bad... I can't open overlay on any of my games. I tryed to change buttons for overlay, baut it didn't help. I also cannot make a screenshot or record any video& How can I fix it?
Иисус Христос Jul 15, 2013 @ 12:39am 
I havent problem
Oprah Windfury Jul 15, 2013 @ 6:46am 
Same problem with me for almost every game that I try to run on my Mac, including CS:GO, TF2...
[MzaG]Guitarsluk_94 Jul 15, 2013 @ 2:31pm 
my mac is in dfu mode??help me!!!!
acanterelle Jul 15, 2013 @ 3:30pm 
Hey peculiarly Halflife 2 is launching correctly through the valve logo, while TF2 fails at the launch without reaching the valve logo. As both launch with (the, a, same, similary) launcher why does TF2, after successful file validation, fail to reach the valve logo? No other installed games exhibit launch problems than TF2. TYIA M
|ÅΩ| Sovox Jul 16, 2013 @ 5:26am 
Some games still keep crashing from time to time
BookofJobe Jul 16, 2013 @ 7:19am 
I'm having problems with bastion as well.
Eclipse Jul 16, 2013 @ 8:25am 
All games I've tried to download so far have come up with "not supported on current platform". I'm running the new MacBook Air, is it just that the games have not been optimised for the new hardware yet?
Val - school prepare your anus!! Jul 16, 2013 @ 12:30pm 
apple juefiefizbfizfgzif
Showing 1-15 of 20 comments
< >
Per page: 15 30 50
Date Posted: Jul 12, 2013 @ 3:51pm
Posts: 20