=(eGO)= BoNeZ_MC Jun 18, 2013 @ 7:02pm
New Steam update error for CS:S filesystem_stdio.dylib
This is the error I get when starting CS:S.

Unable to load /Users/Jim/Library/Application Support/Steam/steamapps/common/Counter-Strike Source/bin/filesystem_stdio.dylib

Anyone know how to fix this? I just updated steam and was playing perfectly fine before. Please help!

P.s. I tried to verify the integrity of my game cache already.
Last edited by =(eGO)= BoNeZ_MC; Jun 18, 2013 @ 7:07pm
< >
Showing 1-15 of 18 comments
DESTROYER Jun 19, 2013 @ 12:15am 
Im sorry to tell you this... but we are going ot have to wait for Valve.
mushu Jun 19, 2013 @ 12:16am 
Yeah i'm getting this on TF2 just after the new Steam update...
mushu Jun 19, 2013 @ 12:16am 
And also i just validated my files and I got this : 1 file failed to validate and will be reacquired. I guess it will be fixed after validating your files?
EDIT: Nope.. no reacquiring... :/
Last edited by mushu; Jun 19, 2013 @ 12:17am
=(eGO)= BoNeZ_MC Jun 19, 2013 @ 12:20am 
Yeah it seems to be happening to a lot of things. I couldn't play CS:S, TF2, or Portal 2. I wonder what else isn't working.
mushu Jun 19, 2013 @ 12:22am 
I know all my friends on PCs are playing fine on tf2... I still have my filesystem_stdio.dylib but it doesn't seem to be working. I might try and replace it with one from a pc...
OR MAYBE I'LL DELETE IT and then see what happens.
=(eGO)= BoNeZ_MC Jun 19, 2013 @ 12:24am 
Well, if you do something that works, please let us know. I want to play again.
mushu Jun 19, 2013 @ 12:30am 
Yeh, I have the actual file that's all working and everything except it just doesn't load it. Maybe a component in one of the other files?
mushu Jun 19, 2013 @ 12:36am 
I got it!!!

Opting out of steam client beta works. To do this, go to Steam at the top left of your screen next to the apple, hit preferences, under beta participation hit change, make sure it is set to opt out of beta programs (it should be set to this when you first hit change), then click ok and it should restart steam. This will make source games work again.
I got this from Michael Turtle on thread http://steamcommunity.com/app/440/discussions/0/864971134832075381/#p2
Last edited by mushu; Jun 19, 2013 @ 12:36am
=(eGO)= BoNeZ_MC Jun 19, 2013 @ 12:44am 
Hell yes! You're a genius! Nice find!
thesuperadventurer Jun 19, 2013 @ 5:34am 
thank you so much! I had this problem last night as well and i couldn''t play TF2. so frustrating. thank you thank you thank you. NOW FOR SOME TF2!
Last edited by thesuperadventurer; Jun 19, 2013 @ 5:34am
💯 big dad 💯 Jun 19, 2013 @ 9:20am 
i think if you want to play with tf 2 use windows or linux, the linux is the best
ieeks Jun 19, 2013 @ 10:38am 
gogogo valve
henryg Jun 19, 2013 @ 11:13am 
A fix is currently being worked on. For now, if you go to Preferences in your Steam client, you can opt out of the client beta and restart Steam. You should be able to launch again after that.
russell Jun 20, 2013 @ 2:56pm 
I dunno
BipolarBear191 Dec 5, 2013 @ 3:04pm 
I found out this is because filesystem_stdio.dylib is an empty file, it needs a command so it knows what to do. If you can fine a replacement I'm sure it'll work, that's what I'm trying to do right now :/
< >
Showing 1-15 of 18 comments
Per page: 15 30 50

Date Posted: Jun 18, 2013 @ 7:02pm
Posts: 18