seanck78 Jun 8, 2013 @ 6:03pm
Civ5 crash
Everytime you select the Internet option under muliplayer the game crashes. Any suggestions?
Showing 1-8 of 8 comments
< >
derrel Jun 18, 2013 @ 5:30pm 
Did you ever find a fix? It's happening for me too.
MajWoops Jun 19, 2013 @ 2:41pm 
It's the latest Steam beta update.. somehow it causes Civ V to crash. If you opt out of the beta, the game will play, but might not have any sound or music in-game (that was my experience, anyway).
Agent AA1 Jun 20, 2013 @ 8:47am 
It crashed for me too yesterday; however, my friend sent me an invite and it worked.
pro gamer Jun 20, 2013 @ 11:06am 
me too :(
derrel Jun 27, 2013 @ 6:04pm 
It's worked for me twice in two days now, just tried it again though and it crashed...
G-Squirrel Jun 28, 2013 @ 7:02am 
I don't think I've managed to play Civ V on Mac for more than a couple of hours withough a crash... it's pretty disappointing.
macboon Jul 29, 2013 @ 1:04pm 
It reliably crashes for me in midgame just as I turn over a turn to the AI. The error message says that it is trying to access something about steam. This is really sad...

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000020
Crashed Thread: 0 MainThrd Dispatch queue: com.apple.main-thread

How do I opt out of the beta steam thingie?
LanceA63 Jul 29, 2013 @ 2:17pm 
to reiterate: beta access must be disabled for Civ 5 to work?
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Jun 8, 2013 @ 6:03pm
Posts: 8