Vitamac Dec 12, 2012 @ 1:31pm
Steam not running after last update (today)
OS X 10.8.2 Mountain Lion
Please help me.

Repair permission, remove corrupted preferences, … not help me
Showing 1-15 of 45 comments
< >
huntnzombies Dec 12, 2012 @ 4:05pm 
yeah i am having the same problem, playing tf2 one minute and i leave and when i come back an update installs and now i can't play
chrpica Dec 12, 2012 @ 10:23pm 
Same here - I can't get the program to launch.
CAFE KUT- FA1L Dec 13, 2012 @ 3:27am 
Same goes for me; icon appears in the dock for a split second, then vanishes and nothing else happens. Can do this over and over again.

13" MachBook Pro, 2011 model
2.7 GHz i7
Mac OS X v10.7.5
Last edited by CAFE KUT- FA1L; Dec 13, 2012 @ 3:28am
Vitamac Dec 13, 2012 @ 9:31am 
I tried reinstalling Steam. But simply without uninstalling everything. You can try.

I had no application in the directory Steam Applications, but in a subfolder.

1. I downloaded the current version of Steam.
2. I pulled the Steam application of DMG in the directory Applications.
3. I let Steam application of this new position.

Note: Yesterday when I was trying to revive the application to remove all items from the application directory according to one of the guides here on the forum. It is possible that you will need to take that step.

~/Library/Application Support/Steam/config/htmlcache/
CAFE KUT- FA1L Dec 13, 2012 @ 10:28am 
Tried the above, didn't work...
Vitamac Dec 13, 2012 @ 10:42am 
I am writing this as an option, which helped me. Your problem may be different.

I start the application stopped working after the latest Steam update in a way that did not come even application icon Steam.
DarkCloud14 Dec 13, 2012 @ 12:27pm 
They screwed something up in the steam.sh shell script.
If you've the Steam application file in a location where the path contains spaces it doesn't work. E.g. Steam.app is in /Volumes/My Awesome HD/Games/ then it will not work.

You can temporary resolve the problem by moving the Steam.app file into your Applications directory or into a directory where the whole path doesn't contain spaces. That means no directory with a space in it.

If a somebody of Steam support should read this it's the following part at the beginning of steam.sh which doesn't correctly parse the steam binary name:

if [ -z $STEAMEXE ]; then
STEAMEXE=`basename $0 .sh`
fi
Last edited by DarkCloud14; Dec 13, 2012 @ 12:28pm
chrpica Dec 13, 2012 @ 12:36pm 
Good post DarkCloud - I'll have to try it when I get home. Hopefully they go about fixing it... Kind of frustrating!
DarkCloud14 Dec 13, 2012 @ 12:44pm 
Yeah I hope so too! I tried to manually fix the steam.sh shell script but if you start steam it'll automatically overwrite the fixed steam.sh file with the buggy one. -.-

It also didn't completly startup by just fixing the line mentioned above.
But as it updated the shell script after start I cannot say, if it tried to start the false shell script again after updating it or if there is another problem in the script when directories of the path to steam contain spaces.

An alternative if you really cannot move it for some reason is to start steam over the shell script within a terminal. At least then it worked fine for me even with the buggy steam.sh shell script as it then get's the path with the correct syntax for spaces inside directory names..
Last edited by DarkCloud14; Dec 13, 2012 @ 1:02pm
CAFE KUT- FA1L Dec 13, 2012 @ 1:56pm 
Thanks DarkCloud, worked!
Xavier J. Khoulwhip Dec 13, 2012 @ 4:45pm 
Thanks, DarkCloud. I moved my Steam app to a directory that doesn't have spaces, and it worked just fine. I'm going to update the support ticket I made earlier to notify Valve that this is the problem in the hope that they will update the script file to properly work with directory names with spaces (a very common thing on the Mac OS).
Last edited by Xavier J. Khoulwhip; Dec 13, 2012 @ 4:45pm
Jim Bond Dec 13, 2012 @ 4:52pm 
This isn't the first time a Steam update broke the Mac build. :-(
vikinghammer2 Dec 13, 2012 @ 5:08pm 
i also have the same problem after update. steam or any docked games wont load up. i have a ticket open since tuesday and it has gone un-answered. i wish someone from value/steam would say whats wrong.
Last edited by vikinghammer2; Dec 14, 2012 @ 4:26pm
Toa Of Space Dec 13, 2012 @ 5:57pm 
It removed most files from my mac. Im ♥♥♥♥ED OFF at steam and valve
DarkCloud14 Dec 13, 2012 @ 10:15pm 
No spaces in directories includes also the name of the hard drive.

Such paths may be resolved to /Volumes/<your hard drive name>/Directory/Steam.app
Also if you moved the Steam.app to your documents directory or any other user home directory it can be a problem if your user name (Unix user name) contains spaces!

The easiest way would be to move it into the default Applications directory at least for now. There the folder should always be resolved as /Applications/Steam.app ...

I guess the reason for the problem has something todo with the linux beta as it looks like the shell script is used for both operating systems.
Last edited by DarkCloud14; Dec 14, 2012 @ 3:51am
Showing 1-15 of 45 comments
< >
Per page: 15 30 50
Date Posted: Dec 12, 2012 @ 1:31pm
Posts: 45