Blstrgmr May 12, 2013 @ 1:13pm
Anna - Extended Edition Installation Questions
On the Mac App Store, Anna is required to run with OSX 10.6.whatever and above. However on steam, it requires OSX 10.8.whatever to run. Is it ok to purchase Anna from Steam if I'm running OSX 10.7?
Date Posted: May 12, 2013 @ 1:13pm
Posts: 0