Dette emnet har blitt låst
ErniePC12 7. mai, 2013 @ 15:30
Steam Client stuck on 'Checking for Available Updates'
( Edit by henryg @ Valve: We have released a fix for this problem. Please re-download Steam from the "Install Steam" link at the top of this web page and copy it to your applications folder, replacing your existing copy. )

I was trying to launch the Steam client earlier today, and I was just at the loading screen. I thought it was a problem with the client, so I replaced it with a new download from the Web. I was able to launch the application, and it updated itself. But now on relaunch, I'm sitting at a screen that says "Updating Steam. Checking for Available Updates..."

I'm on a different network than before, and I tried to replace the client more than once. I also tried renaming the registry.vdf file. Nothing has worked so far.

Any thought? Thanks!

{UPDATE] As of June 12th, this issue was fixed.
Sist redigert av ErniePC12; 24. juni, 2013 @ 18:52
< >
Viser 1-15 av 96 kommentarer
Mfashnick 7. mai, 2013 @ 20:35 
I'm no help, but you're not alone. I have the exact same problem. I've reported it with a trouble ticket. I was hoping to get some relaxing game time in tonight, but no go. They'd better fix this soon.
ErniePC12 8. mai, 2013 @ 8:47 
FYI, in the steam.log file. I have the following entries...

CsComm Session May- 7-2013 13:34:24.399 [2958618624] ReconnectThread (2958618624) Starting

DebugAssert, Name: ?, Line: 4615, Expr: lReleaseCount >= 1, File: /Users/buildbot/buildslave_steam/steam2_rel_beta_osx/build/Projects/GazelleProto/Client/Engine/../../../Common/Misc/PosixWin32.cpp

DebugAssert, Name: ?, Line: 4624, Expr: pSem->m_pPThreadSem->m_cSem > 0, File: /Users/buildbot/buildslave_steam/steam2_rel_beta_osx/build/Projects/GazelleProto/Client/Engine/../../../Common/Misc/PosixWin32.cpp

CsComm Session May- 7-2013 13:38:39.625 [2958618624] ReconnectThread (2958618624) Told to exit
ErniePC12 25. mai, 2013 @ 19:08 
I opened a ticket for this issue, and while it's not been resolved, it was closed for some reason.

I'm still waiting...
ErniePC12 8. juni, 2013 @ 17:35 
FYI, I"m still waiting on this to be resolved.

And I've had to reopen the ticket twice now.

I"m still waiting on the following issue...

/Users/buildbot/buildslave_steam/steam_rel_client_osx/build/src/common/net.cpp (1760) : Assertion Failed: Unable to set default socket options, error 55

I'm just not connecting and communicating to the Steam system. And I feel that all I'm getting is an automated response every 5-7 days. So I don't really feel that anyone is helping me.

It's been over a month now. This really isn't acceptable...
Lil' fish 9. juni, 2013 @ 4:31 
I'm having the same issue, unfortunately. Have tried everything and it wont work...
Mfashnick 9. juni, 2013 @ 6:18 
Yep... I miss gaming. I miss Legend of Grimrock and Portal. It's been, what, five weeks now?
Despite the new update, nothing has changed. Despite countless re-installs, deleting files, adding a line of code to a file, getting rid of all programs that start automatically when the computer starts, changing my router settings, and even, earlier on, updating my operating system, still I get:
"Updating Steam..."
"Checking for available updates..."

Forever and ever and ever...
Sparkster2600 9. juni, 2013 @ 7:14 
Yup, I still can't access my Steam Library games. This sucks.
Iverloney 9. juni, 2013 @ 15:16 
I'm having the same problem, and have also submitted a help ticket. The more of us complaining about this the better.
ErniePC12 10. juni, 2013 @ 6:26 
I should also stress that my "support ticket" has been closed twice now without the problem being resolved.

Lil' fish 10. juni, 2013 @ 15:18 
I'm getting sick of this issue and of Steam support, I send them pictures of the issue, a full step by step of what I did, console messages, my whole system configuration and the only thing they tell me to do is delete everything but Steam apps from Application Support and download their client again, I even received the same message twice from their support, feels like I'm talking to a machine...
Sist redigert av Lil' fish; 10. juni, 2013 @ 15:19
ErniePC12 10. juni, 2013 @ 18:14 
I agree fully. The support messages aren't very human.

While I think it's an interesting fix, re-downloading is like rebooting the computer, I believe that it's something in their code that is preventing this from working. I do wonder if they even look at these tickets, or they just let the Turing Test run a few steps before they decide that it's something.

I would just be careful to make sure they don't close your ticket like they have tried with mine.

I do have Bootcamp installed on this computer, so the Steam Client still works there, and I have the client working on another Mac that runs the latest OS X Lion. But the only computer I really do my gaming on, is this MacBookPro.

I'm at my wits end here. I've tried just about everything I can think of, and even gone so far as to trace all of my outgoing/incoming network connections. I just can't see anything other than the Steam Client as the cause of my problem...
henryg 10. juni, 2013 @ 18:15 
I'm sorry that all of you are having problems accessing your Steam library. If you are one of the unfortunate few who are experiencing this exact issue (stuck at "Checking for available updates...") then please contact me directly at <removed> so that I can work with you to find out what is happening and develop a fix.
Sist redigert av henryg; 11. juni, 2013 @ 9:27
Mfashnick 10. juni, 2013 @ 19:40 
I sent you an email just now, henryg. I do wonder, though, what the point of issuing trouble tickets is when I have to find out from a forum post that I should email you directly instead.
DJV 10. juni, 2013 @ 19:43 
Steam client IS the problem. Steam is the problem. They are callous asshats who care nothing for their customers. THey never answered my trouble ticket after a week. I wish I knew how much Stem sukked before I bought anything from them.

Why is the president of Steam such a♥♥♥♥♥♥♥♥canoe? No idea. Doesn't care about people, only money I guess.
Lil' fish 11. juni, 2013 @ 6:53 
Opprinnelig skrevet av henryg:
I'm sorry that all of you are having problems accessing your Steam library. If you are one of the unfortunate few who are experiencing this exact issue (stuck at "Checking for available updates...") then please contact me directly at <removed> so that I can work with you to find out what is happening and develop a fix.

I have sent you an email aswell, thank you for your help.
Sist redigert av henryg; 11. juni, 2013 @ 9:27
< >
Viser 1-15 av 96 kommentarer
Per side: 15 30 50

Dato lagt ut: 7. mai, 2013 @ 15:30
Innlegg: 96