Quetzalcoatsy Dec 5, 2013 @ 7:05pm
Steam not opening
I recently (a couple of weeks ago) installed 10.9, but Steam has worked fine from then until yesterday, so I'm not sure if that's the issue.

Now it won't start up at all, it just bounces a single time in the dock and does nothing. Having terminal open gives no messages when it does this.

It works if I delete the app from my applications folder and redownload it, but if I quit, it will not start up again. So far, this has effectively meant I have to redownload Steam (~100mb after the update so not really a fun thing every time) every time I want to open it.

I've done all the standard stuff recommended: reinstalled OS X, repaired permissions, reset PRAM, but nothing works.

Hopefully someone out there is having the same experience and we can get a solution. This also happens on my computer with Spotify (although that for a week now, rather than just a couple of days).
Showing 1-12 of 12 comments
< >
Kolacats Dec 6, 2013 @ 9:29am 
We have a group trying to solve issues with steam games. http://steamcommunity.com/groups/MacGamingHelp
Widow Engie Dec 6, 2013 @ 10:52am 
When you redownload Steam opt into the Beta branch. I did this and the only issue I've had was the overlay not working in TF2, although I have a feeling that's TF2's fault, not Steam's.
Quetzalcoatsy Dec 8, 2013 @ 12:57pm 
Thanks, will try beta. And thanks Kolacats.
Aichon Dec 8, 2013 @ 5:09pm 
Same issue here. I was playing games a few days ago, quit Steam after that, and now when I launch Steam on my 10.9 Mac, it doesn't run. It gets to the black "Connecting Steam account: <account name>" box, but then crashes before the main window ever appears. I'm completely unable to access any of my games, as a result.

I have my Mac configured to display an error log when an app crashes, so I do get that, at least. Also, you may want to check the Console app instead of Terminal, since that's where the errors will appear.

I was about to give reinstalling the app a try. If that does work for me, then I suspect I'll be leaving the app open until the next Steam update comes out, which will hopefully address this issue.
Mauren Dec 8, 2013 @ 5:24pm 
nice
Quetzalcoatsy Dec 8, 2013 @ 7:46pm 
Sorry, I did mean the console. That provides no error messages.
<font color="#00FF00">Вани</ Dec 9, 2013 @ 1:30am 
+
Quetzalcoatsy Dec 19, 2013 @ 10:33am 
Bump
ᅠᅠ ᅠ ᅠ ᅠ ᅠ ᅠ ᅠ Dec 19, 2013 @ 11:10am 
On windows open...
Quetzalcoatsy Dec 19, 2013 @ 11:37am 
I've found my solution! The file compression app Clusters is not compatible with 10.9, and although I thought I'd uninstalled it fully, it was still running as a background process. I can only assume this was causing my problem, because deleting it, restarting, and reinstalling Steam has solved the crashing problem :)
AssassinTabris Dec 19, 2013 @ 3:30pm 
(:
Mr.Hackz Dec 19, 2013 @ 7:06pm 
mc is ♥♥♥♥ thats why not opening :D
Showing 1-12 of 12 comments
< >
Per page: 15 30 50
Date Posted: Dec 5, 2013 @ 7:05pm
Posts: 12