ZERO Jan 11 @ 10:24am
Glitched Forums
On my Mac, I cannot see anything because there are grey boxes covering every single post and on all forums. Heck even on the front page, there are thumbnails in awkward places. On my PC, this does not happen, its a Mac issue. I updated and everything.

How do i fix this?
Showing 1-10 of 10 comments
< >
Ron Jan 11 @ 2:18pm 
Not a
Mac issue because many Mac users here. Sounds more like it's a "your computer" issue. Maybe re-install steam? What machine and OS are you running?
ZERO Jan 12 @ 12:09am 
Will that delete my games that i have installed too?
Kateweb Jan 12 @ 1:28am 
Originally posted by ZERO:
Will that delete my games that i have installed too?


no just drop the app and choose 'replace'
ZERO Jan 12 @ 1:35pm 
nope, didnt work
ZERO Jan 12 @ 1:45pm 
I think its a glitch that Valve needs to look into. Its an App problem, just because everyone doesnt have it, doesnt mean no one has this problem.
Kateweb Jan 12 @ 2:19pm 
Originally posted by ZERO:
I think its a glitch that Valve needs to look into. Its an App problem, just because everyone doesnt have it, doesnt mean no one has this problem.
people tend to complaine when they have the tinyest little problem, Im not sure what your problem with the fourm is , but I will try and look into it more and see if I can find another fix.
ZERO Jan 12 @ 5:32pm 
is there a way to post a screenshot?
Kateweb Jan 13 @ 3:44am 
Originally posted by ZERO:
is there a way to post a screenshot?
take one and uploadto imgur, then post the link.
ZERO Jan 14 @ 3:53am 
http://imgur.com/7a4lEyr
Every forum is like this
Last edited by ZERO; Jan 14 @ 3:54am
ZERO Jan 14 @ 7:27am 
Would also like to point out that many of the buttons on the main page dont work like the "Next 10" buttons or the side scroller for the games being promoted.
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Jan 11 @ 10:24am
Posts: 10