tomglfan Mar 1 @ 10:33am
Half-Life 1 not running on iMac
I always wanted to play the original Half-Life, but I'm a Mac user. I saw that Half-Life had finally been ported to the Mac on Steam -- requirements on the Half-Life page in the store clearly state Mac, OSX 10.6.3 or higher (I use 10.6.8), RAM 1GB, Hard Drive 4GB, etc. I'm pretty sure I meet all the other requirements: ATI Radeon HD4670 graphics chipset, mouse, keyboard, internet. All Half-Life 2 eps run just fine on my iMac (except Lost Coast, which is PC only.)

So for ten bucks I bought and installed Half-Life 1. When I try to start it, though, I get the message "Half-Life is not supported on your current platform." The Store page clearly says that Half-Life should work. I would not have bought the game if it was not available for Mac. Any ideas or suggestions on what I should try to get the game to run would be welcome. Thanks in advance for your help.

PS: I already tried restarting the iMac and several other tricks, including modifying the appropriate file in Terminal. No luck. And by the way -- how do I subscribe to this thread so I can actually find your help when you give it?
Showing 1-6 of 6 comments
< >
bondpat Mar 1 @ 10:36am 
Maybe try contacting steam support? They might be able to give you a refund, it sounds like you've tried most logical things
BOT Wich Mar 1 @ 2:38pm 
.
alecsantr Mar 2 @ 4:06am 
.
Jim Bond Mar 2 @ 8:56pm 
Upgrade to Mavericks
Dr. Hoffman Mar 4 @ 7:37pm 
:/ man that sucks, if I was in your position I would contact steam, not just trying to get help users but the professionals. Good luck! (I love the Half-Life series! :D)
tomglfan Mar 8 @ 12:50pm 
Thanks, everybody. I finally have it working thanks to Steam Support. It just took a lot of patience and retrying. I had to move everything out of the SteamApps folder into a new folder, SteamApps_old, then delete everything but that folder, and do a clean reinstall of Steam. First two tries, same old crap. Third time was the charm. Half-Life copied back into the new SteamApps folder and suddenly it was playable. No idea why the third time was different; just glad I was stubborn enough to keep trying. Again, thanks to everyone who answered.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Mar 1 @ 10:33am
Posts: 6