[HOH]Neptonic Jul 23, 2014 @ 2:03pm
Steam Overlay weirdness
I have OS X 10.9.4, and I just got the new (July 23) Steam Beta. So I go to open TF2, and the pop up saying you have to allow Steam to access your computer to use the overlay, go to your System Preferences to enable it. Now this is a bit weird since this was already enabled, but I thought it was just a quirk of the beta. So I go to the right menu in Preferences, and Steam is alread enabled. So I just disabled it, then renabled it. The game now boots automaticlly after I close System Preferences.
Now it starts to get weirder. First, instead of the icon for hl2_OSX Unix Executable showing up, a second Steam icon appears, and begins to bounce. The game now begins to load in a window in the bottom left corner of the montor. Now the hl2_OSX appears with the TF2 logo like normal, next to the bouncing 2nd steam icon. The Game crashes. I try to launch again. It does the same things, except for the crash. Now it loads for a very long time, around a minute and a half (Normally it's only like 30 seconds). Finally it launches, but my cursor cannot interact with any of the buttons on the main menu. The Music isn't playing either. So I decide to CMD+OPT+ESC to force quit, and I see something strange. I have the few applications on my other desktop (Chrome, Textedit), Steam, TF2, and a strange application with the Steam logo. From what I could tell from the name, the steam overlay had opened as a Application.
So I force quit everything. I then turned off the accessiblity for steam in System Preferences. I open steam again and launch a game. It works fine. Then I decide to renable the accessiblity, and try to get out of the beta. It took 5 mintues to load the stable build. I launch a game... and the bouncing icon is back, but this time it doesn't have the steam icon, it has the icon of an application with no icon (The A made of a ruler or somethin').
I have no idea how to get it back to normal. Help me with a fix, or Valve with a patch.

EDIT: Apparently store pages are broken too (Missing/out of place images and icons, videos not appearing, text not aligning correctly) and I keep getting error -401 when I look at a community page which is fixed with a refresh.
Last edited by [HOH]Neptonic; Jul 23, 2014 @ 2:13pm
Showing 1-7 of 7 comments
< >
RichardPounder Jul 24, 2014 @ 6:07pm 
Ive been having the exact same problem
Mint_ Jul 25, 2014 @ 10:54am 
Man each and every detail i have the exact same experience. The only kind of weird fix i have going is to launch tf2, go into the steam overlay, SHIFT-TAB out, then force quit the bouncing untextured steam app, and cross my fingers. Really it isn't a real fix, and half the time it doesn't work so i hope valve does something fast, and in the mean time just try to ingore it.
[HOH]Neptonic Jul 25, 2014 @ 1:09pm 
I just kept opting in and out of the beta, and it fixed almost all of the problems. Only now, when steam is closed, the icon in the dock is set to the default app icon. (The little A made out of a ruler or whatever.)
Slander Jul 25, 2014 @ 1:39pm 
Im having the same issue... I tryed almost everything, and I still can't acces the Community Overlay on my games.... wtf???
CejoNNNNN :D Aug 22, 2014 @ 7:31am 
Nice..!
grantoldman Aug 22, 2014 @ 8:01am 
1) Make sure Steam is not running and uncheck it from the accessibility preference pane.
2) Close system preferences.
3) Open Terminal and copy/paste the following exactly as you see it, including all quotes:

sudo sqlite3 /Library/Application\ Support/com.apple.TCC/Tcc.db 'delete from access where client like "%Steam%"'

4) Re-open the accessibility preference pane and make sure that Steam is not listed.
5) Close system preferences, launch Steam, and try to play a game. The warning dialog box about the Steam overlay will pop up again. Use it to go back into system preferences and Steam should have re-appeared. Check the box if it's not already, close system preferences, and you should be good to go.
[HOH]Neptonic Aug 22, 2014 @ 8:37pm 
What you guys want to do is open the accesibility options, uncheck all the applications, restart, and recheck everything. It worked for me.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Jul 23, 2014 @ 2:03pm
Posts: 7