netdobeiras Aug 18 @ 7:10pm
steam not working for mac os x 10.5?
i recently read about their big new update and saw that it says " ends support for Mac OS X 10.5?" is this true? steam no longer works on these macs? i click on it and it won't even start? someone help me
Showing 1-11 of 11 comments
< >
Ian Pickert Aug 18 @ 8:36pm 
yeah they dropped support
ikir Aug 19 @ 5:14am 
Just update you computer as you should have done 4 years ago.
Janichsan Aug 19 @ 1:10pm 
^ This. There is absolutely no reason for not upgrading to Snow Leopard.
Черниговское Aug 19 @ 1:25pm 
ну ну мазафака нига
netdobeiras Aug 19 @ 7:28pm 
my computer is up to date and i never wanted to upgrade to snow leopard cause it costs money but now that i see the benefits i most certaintly will. thank you
ikir Aug 19 @ 11:25pm 
You didn't because you don't understand how important is to upgrade. You lost a lot of new features in these years, most apps doens't even work on 10.5 and with 10.6, 10.7 and 10.10 you get much faster 3D drivers. Probably you need more ram and upgrade to 10.9. SOrry if i sound rude but is incredible to read messages like yours in 2014. Upgrade in PC world costa a lot, in Mac land the price was always super low and now it is free, everybody should update always.
Janichsan Aug 20 @ 12:57am 
Originally posted by ikir:
You didn't because you don't understand how important is to upgrade. You lost a lot of new features in these years, most apps doens't even work on 10.5 and with 10.6, 10.7 and 10.10 you get much faster 3D drivers. Probably you need more ram and upgrade to 10.9.
If his computer came with 10.5, it's very likely that it's probably not supported by 10.9, quite possibly not even by 10.7. Anyway, there's no excuse for not upgrading to 10.6 at least, which was superficially almost identical to 10.5, but faster, more stable and better in every other way.

And it only costed $30.
ikir Aug 20 @ 1:41am 
It depens, most MacBook Pros and iMac which cames with 10.5 can run perfectly 10.9 with 4GB of Ram, i have an old 2007 imac witch runs great with 10.9
But yes i agree 10.6 is a perfect upgrade for sure, faster, use less RAM and more stable thank 10.5
Last edited by ikir; Aug 20 @ 1:43am
battlepriestone Aug 20 @ 11:22am 
Some systems are stuck where they are. I know I tried to upgrade an older 2006 machine to Mavericks and it wasn't allowed.) Wether or not they can actually handle upgrade to latest is debateable and a subject for another day and place.
Last edited by battlepriestone; Aug 20 @ 11:23am
ikir Aug 20 @ 11:28pm 
If the machine was ade with 10.5, probably can run 10.9 or at least 10.8. On Mac land we can upgrade for many years luckily. A 2006 machine could not run mavericks because RAM limit or too older architecure it depends, but from 2007 virtually any Macs can use 10.9
Spell Aug 21 @ 6:06am 
мак прикол вещ
Showing 1-11 of 11 comments
< >
Per page: 15 30 50
Date Posted: Aug 18 @ 7:10pm
Posts: 11