Rambazotti Aug 14 @ 4:39pm
Universal Access / MAC / Newest Steam Update (15th Aug.)
I activated the universal access in my preferences before and steam is telling me now that I didn't. Steam is still marked as "Access" in my private preferences. Does anyone got the same problem?

Message was: "To use the steam overlay ... blablabla"
Showing 1-15 of 20 comments
< >
Mogie Aug 14 @ 5:01pm 
I've been at this all of this afternoon, and honestly it's ticking me off. I finally got the overlay up, though the keys used to make the overlay come up are reversed for no reason.. (Shift+Tab is what I'd usually do, but it opened doing Tab+Shift) They NEED to fix this
Rambazotti Aug 15 @ 4:46am 
Okay, but it works even If steam is telling me that I have to grant steam the access in my preferences?
iliketoskivt Aug 15 @ 6:59am 
I have the same exact problem. I enabled it, but it still wont work.
Flying_Belgian Aug 15 @ 7:01am 
Found it!
first of al check that accessibility is allowed for steam (system preferences> security and privacy>privacy>allow steam , then lock changes and close preferences.)
after this you just restart your mac and it shoud be fine ,thats what i did and it worked.
i have a macbook pro late 2013 i5 16 gb ram.
kybotster98 Aug 15 @ 8:32am 
Going off topic a little here but macs with retina displays have been out for quite some time now and this is the biggest update i have seen in a while. What the hell has valve still not added full support for retina resolutions in their client app? They could at lease use the new close, minimise, expand button designs.
Flying_Belgian Aug 15 @ 8:45am 
Originally posted by kybotster98:
Going off topic a little here but macs with retina displays have been out for quite some time now and this is the biggest update i have seen in a while. What the hell has valve still not added full support for retina resolutions in their client app? They could at lease use the new close, minimise, expand button designs.
probably because gaming is morer for windows and plus its still okay like this for people with retina displays. personally i dont think its a must.
King Darío Aug 15 @ 9:07am 
Originally posted by Flying_Belgian:
Found it!
first of al check that accessibility is allowed for steam (system preferences> security and privacy>privacy>allow steam , then lock changes and close preferences.)
after this you just restart your mac and it shoud be fine ,thats what i did and it worked.
i have a macbook pro late 2013 i5 16 gb ram.
I checked that it was enabled,it has been since Febuary of 2013, restarted by Mac,no luck. Im on a Dektop just so you know.
luchaos Aug 15 @ 9:44am 
Originally posted by Flying_Belgian:
Found it!
first of al check that accessibility is allowed for steam (system preferences> security and privacy>privacy>allow steam , then lock changes and close preferences.)
after this you just restart your mac and it shoud be fine ,thats what i did and it worked.
i have a macbook pro late 2013 i5 16 gb ram.

I second that, although I did several additional steps before restarting my macbook (OS X Mavericks):

- unticked and ticked Steam > Preferences > In-Game > "Enable the Steam Overlay while in-game"
- Steam > Preferences > Account activated Steam Beta Update participation
- closed steam
- renamed /Users/[user]/Library/Application Support/Steam/ClientRegistry.blob to ClientRegistryOld.blob (still not rebuilt yet btw)
- removed Steam.app from accessibility pane via terminal:
sudo sqlite3 /Library/Application\ Support/com.apple.TCC/Tcc.db 'delete from access where client like "%Steam%"'
- started steam & game (Borderlands 2) still accessibility message appeared but Steam.app was re-added to accessibility pane, ticked Steam.app checkbox
- closed steam and restarted OS X

I think that in my case the full OS X restart would have been totally sufficient (I tend to not restart my macbook for several months)

No idea if any of those steps in between did something useful ;)
Last edited by luchaos; Aug 15 @ 9:48am
Flying_Belgian Aug 15 @ 9:51am 
Originally posted by luchaos:
Originally posted by Flying_Belgian:
Found it!
first of al check that accessibility is allowed for steam (system preferences> security and privacy>privacy>allow steam , then lock changes and close preferences.)
after this you just restart your mac and it shoud be fine ,thats what i did and it worked.
i have a macbook pro late 2013 i5 16 gb ram.

I second that, although I did several additional steps before restarting my macbook (OS X Mavericks):

- unticked and ticked Steam > Preferences > In-Game > "Enable the Steam Overlay while in-game"
- Steam > Preferences > Account activated Steam Beta Update participation
- closed steam
- renamed /Users/[user]/Library/Application Support/Steam/ClientRegistry.blob to ClientRegistryOld.blob (still not rebuilt yet btw)
- removed Steam.app from accessibility pane via terminal:
sudo sqlite3 /Library/Application\ Support/com.apple.TCC/Tcc.db 'delete from access where client like "%Steam%"'
- started steam & game (Borderlands 2) still accessibility message appeared but Steam.app was re-added to accessibility pane, ticked Steam.app checkbox
- closed steam and restarted OS X

I think that in my case the full OS X restart would have been totally sufficient (I tend to not restart my macbook for several months)

No idea if any of those steps in between did something useful ;)
why woudnt you restart your macbook (just curious, you dont need to tell if you dont want to )??
XD
King Darío Aug 15 @ 9:52am 
Erh....this is getting to0 complicated for my Small mind... i think il wait for Valve to solve the issue,they have to have noticed by now,since they themselves use Macs.
Last edited by King Darío; Aug 15 @ 9:52am
luchaos Aug 15 @ 9:56am 
Originally posted by Flying_Belgian:
why woudnt you restart your macbook (just curious, you dont need to tell if you dont want to )??
XD

:D good question! I guess it's lazyness in the end - just sending it to sleep all the time
as it seems even OS X needs some restarting once in a while - not only when system updates require it
luchaos Aug 15 @ 10:18am 
Originally posted by King Darío:
Erh....this is getting to0 complicated for my Small mind... i think il wait for Valve to solve the issue,they have to have noticed by now,since they themselves use Macs.

As I said, I don't think all of those steps were necessary except for the restart of OS X - the overlay worked again immediately after that. Hopefully there's a more convenient solution to this problem soon
Last edited by luchaos; Aug 15 @ 10:19am
Flying_Belgian Aug 15 @ 11:48am 
Originally posted by luchaos:
Originally posted by King Darío:
Erh....this is getting to0 complicated for my Small mind... i think il wait for Valve to solve the issue,they have to have noticed by now,since they themselves use Macs.

As I said, I don't think all of those steps were necessary except for the restart of OS X - the overlay worked again immediately after that. Hopefully there's a more convenient solution to this problem soon
i think (hope) valve is also working on it so that people ho have no clue what to do also can solve this problem
Jaquio Aug 19 @ 5:06pm 
This worked for me. Thanks Flying Belgian!! Fiddled with this for 15 minutes, didn't even think to restart, doh!

Originally posted by -_^ WcC ^_- Flying_Belgian:
Found it!
first of al check that accessibility is allowed for steam (system preferences> security and privacy>privacy>allow steam , then lock changes and close preferences.)
after this you just restart your mac and it shoud be fine ,thats what i did and it worked.
i have a macbook pro late 2013 i5 16 gb ram.

FYI...Macbook Pro 17" Late 2011, Mavericks, i7, 16GB RAM
Last edited by Jaquio; Aug 19 @ 5:06pm
Flying_Belgian Aug 19 @ 5:09pm 
Originally posted by Jaquio:
This worked for me. Thanks Flying Belgian!! Fiddled with this for 15 minutes, didn't even think to restart, doh!

Originally posted by -_^ WcC ^_- Flying_Belgian:
Found it!
first of al check that accessibility is allowed for steam (system preferences> security and privacy>privacy>allow steam , then lock changes and close preferences.)
after this you just restart your mac and it shoud be fine ,thats what i did and it worked.
i have a macbook pro late 2013 i5 16 gb ram.

FYI...Macbook Pro 17" Late 2011, Mavericks, i7, 16GB RAM
no problem. itjust popped up in my head to restart my oc (cuz normally,just like an os x update you restart your mac,you restart your mac)
Showing 1-15 of 20 comments
< >
Per page: 15 30 50