Insanity's Lips Jul 30, 2014 @ 7:17pm
Universal Access is on but Steam won't recognize it: Mac
This is the second time this has happened in the past week. Steam says I need to turn on universal access under system preferences. I go to system preferences > accessibility, and it is checked, as in it's on. But I close and reload Steam, and it still says I need to turn on universal access. I have checked and unchecked it, and restarted Steam. No dice, still doesn't work.

I am on a Macbook Pro (no flaming please), and the first time this happened it lasted a few days, then randomly started working again. It's getting annoying. Any ideas?
Showing 1-15 of 26 comments
< >
Senpai BioLake Jul 31, 2014 @ 10:15am 
I have a Mac book pro and the same thing happned to and nothing I do is helping me. I think either Apple is stupid or something with Stean :/
Last edited by Senpai BioLake; Jul 31, 2014 @ 10:15am
Thionysas Aug 1, 2014 @ 11:59pm 
Same thing is happening to me. Please let there be a fix.
k-swizzle Aug 2, 2014 @ 9:32am 
same. GET YOU ♥♥♥♥ TOGETHER VALVE.
Oopsydaisy Aug 24, 2014 @ 4:51am 
has anyone tried reinstalling steam?
lashbridge57 Aug 24, 2014 @ 9:33am 
Yeah, I agree Steam needs a huge bug fix, especially for mac users, my Steam won't even open.
Sammy Davis Jr. Jr. Aug 24, 2014 @ 5:42pm 
This has been happening to me and I have uninstalled and reinstalled. This hasn't fixed the problem.
lashbridge57 Aug 25, 2014 @ 5:21am 
Hopefully they will bring a new update out for Mac os X users.
Janichsan Aug 25, 2014 @ 6:05am 
Originally posted by Lips:
This is the second time this has happened in the past week. Steam says I need to turn on universal access under system preferences. I go to system preferences > accessibility, and it is checked, as in it's on. But I close and reload Steam, and it still says I need to turn on universal access. I have checked and unchecked it, and restarted Steam. No dice, still doesn't work.
Is the overlay actually not working or is Steam simply nagging about it? I had Steam complaining a few times about Universal Access, although the overlay actually just worked fine.
Sammy Davis Jr. Jr. Aug 25, 2014 @ 6:35am 
For me the overlay isn't working at all.
henryg Aug 25, 2014 @ 6:20pm 
Please try disabling universal access for Steam, restarting your computer, and then re-enabling it. There seems to be a problem with 10.9.x where the checkbox gets out of sync with the actual OS behavior. Once it is working again (after a reboot), it should stay working.
grantoldman Aug 25, 2014 @ 6:46pm 
If unchecking the box doesn't work, try this:

1) Make sure Steam is not running and uncheck it from the accessibility preference pane.
2) Close system preferences.
3) Open Terminal and copy/paste the following exactly as you see it, including all quotes:

sudo sqlite3 /Library/Application\ Support/com.apple.TCC/Tcc.db 'delete from access where client like "%Steam%"'

4) Re-open the accessibility preference pane and make sure that Steam is not listed.
5) Close system preferences, launch Steam, and try to play a game. The warning dialog box about the Steam overlay will pop up again. Use it to go back into system preferences and Steam should have re-appeared. Check the box if it's not already, close system preferences, and you should be good to go.
一天世界 Aug 26, 2014 @ 3:54am 
nice
Foolonthehill Oct 26, 2014 @ 6:11pm 
Worked thanks
Chris Oct 29, 2014 @ 1:24am 
Same problem. Terminal command only works for a while, after restarting computer or waking it from sleep and opening Steam again it starts asking again.
lief Oct 31, 2014 @ 4:29pm 
I have a similar problem but, when I go into system preferences, Steam isn't actually there. I tried to drag the application into it, but it didn't work. HELP.
Showing 1-15 of 26 comments
< >
Per page: 15 30 50
Date Posted: Jul 30, 2014 @ 7:17pm
Posts: 26