rueking Mar 12, 2014 @ 4:57pm
(MAC) Steam overlay not working
I am running OSX 10.9.2 on a 2.2 GHz intel with 4GB of RAM. When launching a game (specifically, Insurgency), I receive a message stating that "The in-game Steam overlay requires access for assistive devices to be enabled. To enable to (sic) the in-game overlay, open the Security and Privacy > Privacy preference pane and allow access for Steam." It provides a link to launch my privacy settings in my System Preferences, however there is no option to add Steam as an assistive device. Due to this issue, I'm unable to use the Steam overlay in-game. I didn't find much following a google search or searching these forums aside from suggesting I enable the beta, which I have. I have also rebooted my computer and application, so there's that as well. Maybe I need to uninstall and reinstall?

On a side note, I am also having problems joining servers which my friends say have slots open, but to me it appears (and acts as if it's) full. Again, this in reference to Insurgency specifically. Any help would be appreciated.
Last edited by rueking; Mar 12, 2014 @ 4:57pm
< >
Showing 1-15 of 109 comments
rueking Mar 12, 2014 @ 5:03pm 
Care to translate?
Dunn Jul 25, 2014 @ 1:12pm 
THIS HAPPENS TO ME ALSO SOMEONE HELP
Neidy Jul 30, 2014 @ 3:32pm 
Happens to Me also . . While Updating, Playing and Downloading . . It Started only For Today :/ Any Issue??
L5hunter Jul 30, 2014 @ 3:53pm 
Originally posted by sergentpewdiepie:
Happens to Me also . . While Updating, Playing and Downloading . . It Started only For Today :/ Any Issue??
Wait wait...are we all on the OS X Yosemite beta?
Originally posted by L5hunter:
Originally posted by sergentpewdiepie:
Happens to Me also . . While Updating, Playing and Downloading . . It Started only For Today :/ Any Issue??
Wait wait...are we all on the OS X Yosemite beta?

Nah, I have the problem and not the beta.
IchegoFX Aug 1, 2014 @ 10:02am 
Finally, Its been fixed! Just launched dota 2 now and didnt get that annoying prompt and while in-game i could SHIFT + TAB.

:)
L5hunter Aug 1, 2014 @ 10:21am 
Originally posted by IchegoFX:
Finally, Its been fixed! Just launched dota 2 now and didnt get that annoying prompt and while in-game i could SHIFT + TAB.

:)
Yup! must have been an update!
Dark Shade Aug 1, 2014 @ 10:38am 
I have same problem
LN3000 Aug 2, 2014 @ 6:35pm 
I have this problem. OSX 10.9.4, latest Steam beta build, constant prompts, no overlay.
IchegoFX Aug 2, 2014 @ 10:52pm 
Originally posted by LN3000:
I have this problem. OSX 10.9.4, latest Steam beta build, constant prompts, no overlay.

Don't worry. It will be fixed for you with the next couple of updates to hit your client!
alybz Aug 3, 2014 @ 3:13am 
This problem occurs to me when updating to beta. Please HOW DO I FIX THIS?!?


(i want to use the music player feature that's why :3 )


Edit: I fixed by using L5hunter's suggestion(2 post below me). If it doesn't work, try restart mac.
Last edited by alybz; Aug 4, 2014 @ 5:42am
Choops Aug 3, 2014 @ 8:28am 
I have been getting this for a few weeks now... Very annoying.
L5hunter Aug 3, 2014 @ 10:06am 
Hello all. It seems to be a compatibilty issue. Ensure that you have the latest version of Steam and OS X. One day it just...fixed itself. Try going to Privacy, Accessibility, turn Steam off, restart steam, then turn it back on.
IchegoFX Aug 3, 2014 @ 1:08pm 
Originally posted by L5hunter:
Hello all. It seems to be a compatibilty issue. Ensure that you have the latest version of Steam and OS X. One day it just...fixed itself. Try going to Privacy, Accessibility, turn Steam off, restart steam, then turn it back on.

Yeah....what he said!
RadioWav3 Aug 14, 2014 @ 2:12pm 
i just got a new steam update today, and i could shift tab before the update but now i can't, its asking for me to go to my assitive devices with i have on but still, i turned steam overlay on and it still doesn't work? any help
< >
Showing 1-15 of 109 comments
Per page: 15 30 50

Date Posted: Mar 12, 2014 @ 4:57pm
Posts: 109