explo Apr 18, 2013 @ 5:51am
[TUT]: How to Fix Source SDK / Hammer after newest update!
How to Fix Source SDK after newest update!

1. Open up your Hammer editor

2. Click Tools > Options > Build Programs

3. Enter next directions on following boxes:

Game executable:
$SteamDir\steamapps\common\Counter-Strike Source\hl2.exe

Place compiled maps in this directory before running the game:
$SteamDir\steamapps\common\Counter-Strike Source\cstrike\maps


DONT TOUCH OTHER OPTIONS !

Now your hammer should work normally :) , enjoy.
Last edited by explo; Apr 18, 2013 @ 5:52am
Showing 1-13 of 13 comments
< >
blackbird4203 Apr 18, 2013 @ 7:04pm 
it dose not work, saying " Failed to load the default scheme file. the map views may be mmissing some visual elements."

then i get a application error, " The instruction at 0x0e711851 referenced memory at 0x0e711851. The memory could not be read.

those are the errors i get after that, then hammer closes.
NOT LARANGI PT Apr 19, 2013 @ 3:03am 
nop does not work here
Dim@№ Apr 19, 2013 @ 5:09am 
not work
Dr. Scheissekopf Jun 8, 2013 @ 12:11pm 
Originally posted by blackbird4203:
it dose not work, saying " Failed to load the default scheme file. the map views may be mmissing some visual elements."

then i get a application error, " The instruction at 0x0e711851 referenced memory at 0x0e711851. The memory could not be read.

those are the errors i get after that, then hammer closes.

I had the exact same problem and nobody seemed to know how to fix it. Finally after a week and a half of searching I found a russian youtube video with a solution


http://www.youtube.com/watch?v=PbbhL42WW-k&noredirect=1


The first step to fixing this problem is to get hammer to find the files.

there are 2 ways to do this. the first way is to go to source SDK and run it. Select the game you wish to mod then look under utilities and click on "Edit Game Configurations." A box with the game will come up saying "Current Game Configuration." Click on "Edit."

Make sure to change your username to common. This will tell it to look in the common folder where the files have been moved.

(Team Fortress 2 is being used as an example)

it should be "c:\program files (x86)\steam\steamapps\common\team fortress 2\tf"
instead of "c:\program files (x86)\steam\steamapps\USERNAME\team fortress 2\tf"

Another way to fix the configuration is to take all of the files in the game folder under COMMON and to move or copy them to USERNAME.

once that is done hammer should be able to find the proper location of the files, However, if you run hammer you will see a new problem arises. When attempting to make a new map a box will come up saying, "Failed to load the default scheme file. The map views may be missing some visual elements." and if you press okay, it crashes. to fix this go into the gameinfo document. (if you copied the file into the original location be sure to open the gameinfo document in the original location.) you will see somewhere in the file the words SteamAppId (sorry if "i" looks like "L") then some space and a three digit number. Below "SteamAppId" put "ToolsAppId" then push the tab key until your cursor is below the three digit number and type "211"

Like this (Using underscores to show empty space)

SteamAppId____________________ 440
ToolsAppId _____________________211

Now set source SDK as a shortcut on the desk top by locating it in tools and right clicking on it. A menu should come down. click on "Create Desktop Shortcut" or whatnot... Next go to desk top and right click on the Source SDK shortcut and chose the last option on the menu, "Properties." once the properties are displayed click on the tab that says, "Web Document" and look at the text next to URL. DON'T CHANGE THE TEXT. just make sure the three digit number matches the one next to ToolsAppsId. Then save the modifications to the gameinfo document.


Hope this works for you. Enjoy the world of map editing. Watch the video if you need a visual.
Last edited by Dr. Scheissekopf; Jun 8, 2013 @ 12:12pm
NotACreativeName Jun 11, 2013 @ 11:02am 
Source SDK is giving me "The configuration information for the game is invalid or missing" - I reinstalled it all - steam - refreshed content, even tried simply running the individual games before trying to run hammer editor - a common fix - and nothing... then when I try t run hammer anyways, it gives me that it can't find gameinfo.txt for the respective game I'm trying to run hammer for.

This frustrates the hell out of me. Halp.

[As I said before, ALREADY tried running the game before running hammer.]
Last edited by NotACreativeName; Jun 11, 2013 @ 11:03am
Kaypro Jun 11, 2013 @ 1:43pm 
Works :D ty
☠F☺celessMind☠ Jun 12, 2013 @ 4:54am 
it works , but this is not the better manner to fix the problem.
valve recommand to not use the sdk launcher anymore
there are fex bath file in your bin directory you must luanch the app from these batch files.
and be carefull about your VPROJECT env variable that is set in your window advanced settings.
the problem i got myself is about hlmv, that refuse to open any folders when i try to load a models and explorer the vpk.

@Terminal Cancer, open the bin directory and run set_sdk_env.bat as administrator. and run hammer;bat after that. and check the build settings.
to be sure the VPROJECT is properlly set go in computer>conficuration panel> system > adavanced settings > environnement variable, in user variables you must have a Vproject set for the game you want to edit.
if it doesn't change you env variable, you should edit the set_sdk_env;bat with notepad, and uncomment the SETX VPROJECT %VPROJECT%
Last edited by ☠F☺celessMind☠; Jun 12, 2013 @ 5:15am
☠F☺celessMind☠ Jun 12, 2013 @ 2:00pm 
Finally HLMV works fine if I extract the models and the texture from the VPK into the "/models/" and "/materials/" directories.
RIP [Delete me, new acc] Jun 15, 2013 @ 9:45am 
Watch this 2013 tutorial of how to fix the error messages, it was extremely useful for me

http://www.youtube.com/watch?v=pJ2c674jrrc

After watching it you got everything working, i promise!:D
Linzensoep [NL] Jun 29, 2013 @ 2:58am 
Works! Thanks mate! I changed the game configuration file to: Steam/Steamapps/Common/Team fortress 2/tf file. if you open hammer then, itll work
}: MOUSTACHE_MATT :{ Jul 10, 2013 @ 10:28am 
@Fuzz, what batch files and in what directory?
}: MOUSTACHE_MATT :{ Jul 10, 2013 @ 10:33am 
Never mind, you can completely bypass it. lol.
☠F☺celessMind☠ Jul 10, 2013 @ 1:00pm 
the title of this topic is not really appropriated and doesn't tell, what is the complete process on how to use hammer with valve games. and so this topic is more a [fix] than a [tut]just kind of hints/tips to fix the current problem.

if everything goes wrong you can delete your gameconfig.txt
execute hammer.bat and the gameconfig.txt will be regenerated.
when the game config window is display choose the right game, it should work, if the set_env_sdk.bat has been executed before you load hammer.

Last edited by ☠F☺celessMind☠; Jul 10, 2013 @ 1:02pm
Showing 1-13 of 13 comments
< >
Per page: 15 30 50