[Kevin] Sep 5, 2013 @ 6:26am
GMOD ERROR :/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by bin/steamclient.so)
When having error:
/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by bin/steamclient.so)

**** Fix
copy libstdc++.so.6 found in /Steam/linux32 to your server /gmod/bin

Then you get another error in some cases

Error 2
./srcds_run: line 183: gdb: command not found WARNING: Please install gdb first. goto http://www.gnu.org/software/gdb/

**** FIX (centos6.4)
yum groupinstall "Development Tools"

This works for me witch not says its work for you.
Please check your logs good or google like i did.
Dont blame me if this broke your game or something else
Showing 1-7 of 7 comments
< >
Reversed Zebra Oct 3, 2013 @ 11:06pm 
Beyond helpful mate, thanks alot :)
Acegame Oct 7, 2013 @ 11:37pm 
libstdc++-4.1.2-52.el5_8.1 rpm package.
H0K3R0 | PiiLs Oct 13, 2013 @ 3:55am 
thks
[Kevin] Oct 24, 2013 @ 4:12am 
Originally posted by Dr. Doctor:
Beyond helpful mate, thanks alot :)
no prob ;)
ThatGuy Jan 16, 2014 @ 11:23am 
Awesome, thanks a lot. There is another way of solving this btw, which I was doing for a while on Ubuntu. Just install the ia32-libs package with sudo apt-get ia32-libs and you are done. But as they are no longer available in Ubuntu 13.10, this is the fix I had to choose. Thanks a milli ;)
[SGC] KnightLife Feb 2, 2014 @ 4:36pm 
I wrote an article about this a little while ago.
http://danielgibbs.co.uk/2013/11/steamcmd-64-bit-ubuntu-13-10ubuntu-12-04/

@TawaRagesALot ia32-libs as it is now deprecated and no longer works in newer distros.

Debian: sudo apt-get install lib32gcc1
CentOS: yum install glibc.i686 libstdc++.i686

does the job :)

This is an issue for 64-Bit Distros.
H4xx3D™ ADD H4xx3D DA ORIGINAL Apr 15, 2014 @ 8:57am 
I'm an idiot cause I cant access the Steam/Linux32 folder cause I have an host, and If someone is nice enough to post a copy of that file, would be great.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50