TeeJay Sep 15, 2013 @ 11:49pm
CSGO problems using Workshop Collections
My CSGO server recently started a new behaviour: When I use a Workshop collection with more then one map, the server loads de_dust instead, despite what parameter I put in command line "workshop_start_map". Map voting does not work either. Collections with one map loads the right map. Default maps groups like mg_bomb works fine!

I have reloaded all my server files (steamcmd & csgo-ds folders) from scratch using default Valve techniques and the error is reproducible. I am experiencing this behaviour on a 2012 x64 server and have been able to reproduce the error on a Windows 8 Pro x64 machine. I am currently downloading on my Ubuntu to see whether the same behaviour applies to Linux servers.

You got any idea why and an idea how to fix it?
< >
Showing 1-8 of 8 comments
Sepp Sep 16, 2013 @ 12:36am 
Might have to do with 3 files located in the csgo folder:
Either delete them or make them "content empty". I remember there was a discussion on the csgo server mailing list about those. You can also try to put in your workshop collection ids.
Anyway...deleting them worked for me. Be aware that they'll be redownloaded everytime you update the server.
TeeJay Sep 16, 2013 @ 1:08am 
Hey Sepp. That worked! Thanks a lot. I have spent DAYS searching Google before posting here - and what do you know: The solution within one hour! (Note to self: Ask in the forums, better sooner than later!).
I have modified my update script so I'll remove the files automatically after each update.
Sepp Sep 16, 2013 @ 2:58am 
You're welcome...glad this helped.
SigHunter Apr 6, 2014 @ 9:51am 
omg thanks alot, i also spend days with this.

how stupid is it that those files exist in a default install of srcds
Jarzka May 4, 2014 @ 4:23am 
I had the same problem and this solution worked. Thank you very much Sepp. :)
I cannot find these files in my new deployment, yet I'm having the exact same issue.
Sepp Apr 28 @ 12:28am 
U sure you checked the right folder?
The both subscribed* files are gone for some time now, but the ugc_collection_cache.txt is still there and contains all of your workshop maps.
As you are talking about a new deployment did you wait long enough for the server to download all of the maps?
Cause when you start the server and maps need to be downloaded it actually runs on de_dust.
I'm a little embarrased to say, but I solved my own problem. The server will also hang showing de_dust if you run out of space while the server is downloading all the custom maps. I took a few off and left 800 MB free on my ssd and that fixed it! Also, I had two copies of mansion and I found out that was also a no go. So I was messed up all over the place.

But it's running like a champ now!! I hope this helps someone else.
< >
Showing 1-8 of 8 comments
Per page: 15 30 50

Date Posted: Sep 15, 2013 @ 11:49pm
Posts: 8