Steinmaster170 Jul 22 @ 10:20am
Steam Cmd Problem
Hi, i have a problem with the Steam Cmd and it says bind could't find an open port between 27037 and 27037 and when i set the command force_install_dir C:\server it does nothing. plese help and Thanks!
Showing 1-15 of 28 comments
< >
Knappy Jul 22 @ 10:46am 
If you are installing a server, which I assume is the case, make sure the server folder is not in the same folder as SteamCMD.

It would also help knowing which game server you are installing.
  • login anonymous (if it's server files you are downloading)
  • force_install_dir C:\server (make sure this C:\server folder indeed exists)
  • app_update APPID validate

Check the APPID and verify you are using the correct one.

The port message won't matter until you actually launch the server, in which you would then need to verify that the ports you set for your server (27015-27023 etc etc) are indeed forwarded[www.canyouseeme.org] properly.

If this fails, nuke the SteamCMD, (Shift-Delete the SteamCMD folder) and re-install.

If that also fails, post your system specs (dxdiag) and I will be on later to help you further.

Also, here are some of my guides which may be of use in the meantime.
Last edited by Knappy; Jul 22 @ 10:51am
Steinmaster170 Jul 22 @ 10:50am 
i did reinstall the steamcmd and it did not work
Knappy Jul 22 @ 10:52am 
Originally posted by Steinmaster170:
i did reinstall the steamcmd and it did not work
Did you nuke it before re-installing?

Note: I added a list of my guides in the above post which may help till I get back to my keys.
Last edited by Knappy; Jul 22 @ 10:52am
Steinmaster170 Jul 22 @ 10:55am 
you mean deleting the hole file yes
Knappy Jul 22 @ 11:03am 
Originally posted by Knappy:
It would also help knowing which game server you are installing
Post your system specs or dxdiag.txt, I should be back in an hour or so to help you with alternative methods.
Steinmaster170 Jul 22 @ 11:10am 
gpu gtx 760
cpu i5 650
8 gigs of ram
Steinmaster170 Jul 22 @ 12:32pm 
i got the server running but i dont know how to make it public?
Knappy Jul 22 @ 2:45pm 
Yet again, please provide the game you are hosting, as certain games have different launch options.
Last edited by Knappy; Jul 22 @ 2:46pm
Steinmaster170 Jul 22 @ 4:01pm 
garry's mod
Knappy Jul 22 @ 6:42pm 
Originally posted by Steinmaster170:
garry's mod
Thank you. In your launch options, add this to the srcds.exe shortcut:
-console -game garrysmod -ip 0.0.0.0 -port 27015 +ip YOURDEDIIP +map gm_construct +maxplayers 16

You can assign the -port to whatever you like, the standard is usually 27015-27020

-ip 1.0.0.0 is your internal ip, if you type "status" in the console, a similar IP should return along the lines of 192.168.#.# <that is your internal ip, thus in the command launch it would be:
-ip 192.168.#.#

Your public ip is exactly that when you type status in the console, it will return:
public ##.###.##.##:27015 or whatever port you assign in your launch options. See this[www.dropbox.com] for reference.

Also, see this example GMOD server cfg[www.dropbox.com]

For a more detailed explanation of server.cfg cvars, see this[www.dropbox.com]
Last edited by Knappy; Jul 22 @ 6:45pm
Knappy Jul 23 @ 5:52pm 
Status Report?
Steinmaster170 Jul 23 @ 9:14pm 
all good
Steinmaster170 Jul 30 @ 2:10pm 
when i open my server it says steam game server _initsafe failed and then it says lan only
Knappy Jul 30 @ 3:22pm 
Verify the port is open and ip along with the port is set properly.
Steinmaster170 Jul 30 @ 4:01pm 
ok thanks
Showing 1-15 of 28 comments
< >
Per page: 15 30 50