The King Possum Mar 7 @ 1:35pm
anyone else having trouble with nvidia driver 334.89?
it seems to fail on me while playing the game. it is the proper driver for my gtx 550 ti. geforce experience doesn't install it and I have to go to the website to download and install it. I have rolled back my driver and am using the 334.67 beta driver right now. any ideas on what might be wrong with it? I have sent feedback to nvidiia about this. thanks y'all.
Showing 1-5 of 5 comments
< >
Osiris Dragonia Mar 7 @ 2:29pm 
i had a video kennel driver thing, I am using a gtx 560. What i did was deleting the whole driver and re-installed it again WITHOUT THE BETA DRIVERS. I never install those beta drivers again, they mess up everything....
TeKraken Mar 7 @ 2:33pm 
I would use 314.22 for stability on a 500 series card.
Last edited by TeKraken; Mar 7 @ 2:33pm
The King Possum Mar 7 @ 4:32pm 
okay thanks. I was getting a kennel driver thing also. my PC would go black screen during the game and switch back and after I left the game I saw the notification.

TeKraken, why would you use that driver instead of the latest driver availible? I have always heard to keep the drivers updated to the latest drivers unless it is causing problems.

the beta I have is working fine for me. the geforce expereince does not do a good job installing these latest drivers though.
Rubik748 Mar 7 @ 5:25pm 
Last edited by Rubik748; Mar 8 @ 4:54am
The King Possum Mar 7 @ 8:02pm 
so what I have read is others are having similiar problems with drivers and nvidia has no clue as to why, lol. thanks Rubik748
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Mar 7 @ 1:35pm
Posts: 5