weehawky Apr 25, 2014 @ 3:50pm
AMD 14.4 CCC
Who has tried the new 14.4 CCC ? I stayed with 13.9 , 13.12 worked fine besides Alt + Tab took longer for the game (I guess the term here could be) "stream" to catch back up. Anyway, can anyone vouch for it yet that it's stable ?
Last edited by weehawky; Apr 25, 2014 @ 3:52pm
< >
Showing 1-5 of 5 comments
PowerHaus930 Apr 25, 2014 @ 6:50pm 
When I upgraded to 13.12 I started noticing some problems with slight fps drops after playing for 30 mins - 1 hour. The fps dropped to anywhere between 40-55fps and then went back to 60fps. This is only in Grid 2 and it seems to happen consistently about every 10 seconds. I know from loking at the GPU usage graph in MSI Afterburner. After I notcied it I tried the new 14.2 beta and that didn't seem to help. So I went back to using 13.10 beta v2 and the problem is still there. I only play multiplayer so i'm not sure if it happens offline or not. It can make the game unplayable after a certain amount of time and when I restart the game it runs smooth again. I have been monitoring my network usage while playing and that doesn't seem to be the problem. I have also checked my CPU usage and that seems fine as well.
Here is a screenshot of what the drops look like on the graph http://i.imgur.com/HkMxTS7.png
Framerate is the very bottom graph.
GPU temps are steady at about 55ºC. CPU temp is under 40ºC
The occasional spikes where the usage and framerate go down for a period of time is just me tabbing out of the game.
Last edited by PowerHaus930; Apr 25, 2014 @ 6:51pm
weehawky Apr 26, 2014 @ 11:30am 
Originally posted by BDK:
Working fine here. I've only been playing BF3 and so far so good. No crashing, no throttling, no nothing. Just uninstall your prev drivers before installing the new ones, with Mantle and all that good stuff.

Is Mantle the new Driver Sweeper ?
rotNdude Apr 26, 2014 @ 11:34am 
Originally posted by weehawky:
Is Mantle the new Driver Sweeper ?

Mantle is a new set of APIs that AMD thinks should replace DirectX.
weehawky Apr 26, 2014 @ 12:15pm 
I usually run Driver Sweeper, but it seems it's outdated and been replaced, when I go and do a driver upgrade.
weehawky Apr 26, 2014 @ 7:39pm 
Originally posted by BDK:
Well AMD have their own cleaner, also recently updated to work with Windows 8 / 8.1.
It works really well and it does indeed remove everything including stuff in registry etc.

http://support.amd.com/en-us/kb-articles/Pages/AMD-Clean-Uninstall-Utility.aspx

Sweet, maybe I'll start using it. I always like to get everything out first and bring it back to 800x600.

edit: never mind that thing removes chipsets, etc..
Last edited by weehawky; Apr 26, 2014 @ 9:40pm
< >
Showing 1-5 of 5 comments
Per page: 15 30 50

Date Posted: Apr 25, 2014 @ 3:50pm
Posts: 5