t.jacksongreenland Feb 24 @ 5:02pm
Alienware Constant wifi drops
Hey guys this is my first post as i am getting desperate lol. My laptop connects to my wifi network but every 10-15mins refreshes, it does not disconnect for more than a few seconds but just enough to stop my online gaming. I cant even start a game of Hearthstone and i am always disconnecting from the blacklight retribution server. i also cant watch videos as they always need to be refreshed which is extremely frustrating. I have noticed that when this occurs my wifi signal in the corner shows the blue spinning circle as if reconnecting, i know it is not the router as all my flatmates are not experiencing any problems with games or anything. I have rebooted the orcon router multiple times, downloaded the newest wifi drivers and more but the problem just wont go away, any help would be greatly appreciated, thanks!

P.S laptop is alienware 14 with the killer bigfoot wireless card.
Showing 1-9 of 9 comments
< >
_I_ Feb 24 @ 6:10pm 
wifi drops can be caused by interference or windows power saving

interference can be from alot of stuff
many 2.4 ghz devices, bluetooth, other wireless lans, cordless phones, ps3/360 controllers ect..
or other electronics, microwave ovens, plasma tvs, florescent lights ect..
t.jacksongreenland Feb 25 @ 12:46am 
Thanks for the reply but i dont think that is it as we have almost none of the above (uni flats are kinda crap lol) also it works perfectly for every other device in the flat, i have changed the power saving options also but to no avail. It is almost impossible to use the wifi sometimes, any other ideas? thankyou for the help :)
light_anubis Feb 25 @ 1:21am 
I remember this issue when I had my m17x it drove me nuts. I found it was a bad nic card. Just buy a cheap usb wifi adapter.
UberFiend (Banned) Feb 25 @ 1:24am 
Disable UPnP, and maybe SSDP.
t.jacksongreenland Feb 25 @ 2:49am 
thing is it works fine on other networks, this really has me stumped lol @UberFiend how do i do this exactly? Thanks btw guys!
UberFiend (Banned) Feb 25 @ 3:16am 
open Run command line & enter "services.msc".

Right-click each, Properties, Stop the service, & set to Manual Startup.
t.jacksongreenland Feb 25 @ 6:24pm 
Hey i did what you suggested but unfortunately the problem persists, i cant even download anything now as i get a failed network error, a huge hassle now
UberFiend (Banned) Feb 26 @ 3:41am 
Well just start them back up & set to Auto Startup.

Did you try just UPnP?
Bad-Motha Feb 26 @ 6:21am 
Is the laptop under warranty? Alienware can run diagnostics and replace faulty parts under warranty.

I had the same issue when I setup my mothers M11xR3. I went into the Network Adapter settings (Properties) and changed the channel and that did the trick.
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Feb 24 @ 5:02pm
Posts: 9