crisuK0M13 Feb 18 @ 6:35pm
Mic/Audio Help
I'm not to sure if this is the right place to be posting this or not...

So, I'm not even to sure how to begin searching for this problem. I'm hoping someone on here had this problem before, maybe someone knows how to fix it?

Basically, a friend and me both have the same exact mic (Blue Yeti), neither of us have a sound card, the only real difference is I'm using Windows 8.1, he's running Windows 7.

So as you know Windows has its own Microphone level setting, well our Blue Yeti microphone also have a dial which adjusts the sensitivity of the mic.

My settings: Windows Mic level 50%, Blue Yeti sensitivity 0%
Friends settings: Windows Mic Level 100%, Blue Yeti sensitivity 50%.

Me and him are the same exact volume.

This becomes a problem, when for example, games like DOTA 2, and the Titanfall Beta automatically boost my microphone to 100%, even though in the settings I have "Allow applications to take exclusive control of this device" and "Give exclusive mode application priority" both UNCHECKED. It ends up being REALLY loud when I launch those games for my friends, but when my friend launches those games, nothing happens and he remains the same volume(can't boost the mic any higher because it's already at 100% boost).

Has anyone experienced this? Any help or information would be useful.

PS. I've already updated my BIOS and my audio drivers. Also, the mic itself doesn't have any drivers. It's a USB mic.
Showing 1-1 of 1 comments
< >
crisuK0M13 Feb 19 @ 3:38pm 
Anyone? Anyone at all?
Showing 1-1 of 1 comments
< >
Per page: 15 30 50
Date Posted: Feb 18 @ 6:35pm
Posts: 1