Innerrayg Feb 17 @ 8:53pm
Windows 8.1 low virtual memory help!!!!
Does anybody know how to fix the Windows 8.1 low virtual memory problem??? It plagues all of my games including this Metro 2033 and Titanfall BETA and BF4

I have tried to go to advance system settings and changing the memory manually to 60000 but that still doesn't work I have also let windows to auto manage the memory but there doesn't seem to be any effect. I have searched up to page 30 in google searches for a solution but there doesn't seem to be one.

Please help me!!!

This problem has gotten so annoying an frustating that I have decided to reach out and ask for help because this is one fo the rare times google didn't come though with an answer.
Showing 1-15 of 20 comments
< >
Krystal Math Feb 17 @ 11:39pm 
I'm having the same problem with Titanfall Beta.
howlin' wolf Feb 18 @ 2:43am 
How much memory do you have? Something has some memory leak bug.
Krystal Math Feb 18 @ 3:54am 
8 gb here
_I_ Feb 18 @ 7:08am 
did you try rebooting after changing page file settings?
howlin' wolf Feb 18 @ 7:21am 
With 8 gb of memory he shouldn't need a page file. I'm on Linux now, but on my Windows machine I think I set the page file on 500 mb and it has only 4 gb of ram.
ontelo Feb 18 @ 7:52am 
Originally posted by howlin' wolf:
With 8 gb of memory he shouldn't need a page file. I'm on Linux now, but on my Windows machine I think I set the page file on 500 mb and it has only 4 gb of ram.

In theory no, but some programs still require it. Messing with it normally leads like problems like this.
a.k.a. Dead Feb 18 @ 8:19am 
Originally posted by ontelo:
Originally posted by howlin' wolf:
With 8 gb of memory he shouldn't need a page file. I'm on Linux now, but on my Windows machine I think I set the page file on 500 mb and it has only 4 gb of ram.

In theory no, but some programs still require it. Messing with it normally leads like problems like this.

^^This^^ - Let Windows manage the pagefile no matter how much memory you have installed.

Op, could you list your system specs please, including your hard drive size and how much free space is left on the drive where the pagefile is located.


_I_ Feb 18 @ 9:41am 
Originally posted by ontelo:
In theory no, but some programs still require it. Messing with it normally leads like problems like this.

the games that 'require' it will have a setting to disable the check and still run fine without it

Silicon Vampire Feb 18 @ 10:53am 
There are other, technical reasons you should not run Windows without a pagefile. It really isn't a good idea... but if you think you know better than the people that built it, far be it from me to stop you from doing it.
Innerrayg Mar 5 @ 12:14am 
**UPDATE**

for now the problem seems to have settled a bit. But overall its still sort of happening occasionally.

Bad-Motha Mar 5 @ 6:54am 
Would have been best to have let Windows Manage it and not mess with it manually.
But since u have tried a few changes for Virtual Memory / Page File, I would first go in there and set it to No Page File, click Set button to apply this and then Ok out of those screens until all is closed and then Restart Windows. This will remove the PageFile.sys file from your drive. After the reboot go back to the setting and select "Auto Manage Paging File Sizes for all drives" and click OK to apply, then restart once more.

After this go back in to the same screen again and see what the # amount is where it says "Currently Allocated"

If u continue to have this issue afterwards, I would download the appropriate diagnostic software meant for your brand of drive and run this to ensure the drive is ok. Might help to also run CHKDSK /F in a CMD prompt window (with Admin rights) and see if any bad sectors are detected. I have seen instances where Windows (or apps in general) can crash or say Virtual Memory is low due the PageFile.sys being allocated to an area of the drive that contains unmarked bad sectors, thus can cause all sorts of issues. CHKDSK /F can look for and mark any bad sectors and verify the data and free space on your drive.
Last edited by Bad-Motha; Mar 5 @ 6:58am
Innerrayg Mar 12 @ 10:22pm 
Thanks I will try that the next chance I get and I will post results. Sorry if you are edgarly awaiting but school is taking up time!
FALLING TOILET Mar 17 @ 9:44am 
If you have Intel graphics, downgrade the driver to version 9.17.10.2875, and disable automatic update for windows.

http://steamcommunity.com/discussions/forum/1/558747287821778188/
Bad-Motha Mar 17 @ 2:59pm 
I would not disable Windows Updates, however might be good idea to set it to "Check for Updates, but let me choose when to Download/Install them"

If you get any hardware updates showing up through Windows Updates, like for Intel HD, NVIDIA, Radeon GPUs, hide those updates and get them from their source website.
Showing 1-15 of 20 comments
< >
Per page: 15 30 50
Date Posted: Feb 17 @ 8:53pm
Posts: 20